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1 Foreword
PROFINET, an open industrial Ethernet standard, is especially well-suited for applications that require fast communication
with a high data rate combined with industrial IT functions. PROFINET is real-time capable and uses IT standards like TCP/IP.

STOBER drive controllers support PROFINET, a development of the successful PROFIBUS standard. The drive controllers are
tailored for real-time communication of I/O data and offer the ability to transfer all required data, parameters and IT
functions at the same time.

The fieldbus functionality is integrated into the firmware in the SC6 or SI6 series drive controllers.

The SC6 and SI6 series drive controllers successfully passed the conformance tests for PROFINET, PROFIsafe and PROFIdrive.
This means that the communication interface was tested to ensure the reliability and function of the lower-level
communication regardless of vendor.
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2 User information
This documentation assists you with commissioning the STOBER SC6 or SI6 series drive controllers (IO device) in
combination with a higher-level controller (IO controller) using a PROFINET network.

Technical knowledge

Operating your PROFINET network requires having familiarity with PROFINET network technology and the basics of the
associated Siemens SIMATIC automation systems.

Technical requirements

Before you begin operating your PROFINET network, you need to wire the drive controllers and initially check that they are
functioning correctly. To do this, follow the instructions in the manual for the relevant drive controller.

2.1 Storage and transfer
As this documentation contains important information for handling the product safely and efficiently, it must be stored in
the immediate vicinity of the product until product disposal and be accessible to qualified personnel at all times.

Also pass on this documentation if the product is transferred or sold to a third party.

2.2 Described product
This documentation is binding for:

SC6 or SI6 series drive controllers in combination with the DriveControlSuite software (DS6) in V 6.6-B or later and
associated firmware in 6.6-B-PN or later.

2.3 Directives and standards
Refer to the drive controller documentation for the European directives and standards relevant to the drive controller and
accessories.

2.4 Timeliness
Check whether this document is the latest version of the documentation. We make the latest document versions for our
products available for download on our website:
http://www.stoeber.de/en/downloads/.

2.5 Original language
The original language of this documentation is German; all other language versions are derived from the original language.

2.6 Limitation of liability
This documentation was created taking into account the applicable standards and regulations as well as the current state of
technology.

No warranty or liability claims for damage shall result from failure to comply with the documentation or from use that
deviates from the intended use of the product. This is especially true for damage caused by individual technical
modifications to the product or the project configuration and operation of the product by unqualified personnel.

http://www.stoeber.de/en/downloads/
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2.7 Formatting conventions
Orientation guides in the form of signal words, symbols and special text markups are used to emphasize specific
information so that you are able identify it in this documentation quickly.

2.7.1 Display of warning messages and information
Warning messages are identified with symbols. They indicate special risks when handling the product and are accompanied
by relevant signal words that express the extent of the risk. Furthermore, useful tips and recommendations for efficient,
error-free operation are specially highlighted.

ATTENTION!

Attention

This indicates that damage to property may occur

▪ if the stated precautionary measures are not taken.

CAUTION!

Caution

This word with a warning triangle indicates that minor personal injury may occur

▪ if the stated precautionary measures are not taken.

WARNING!

Warning

This word with a warning triangle means there may be a considerable risk of fatal injury

▪ if the stated precautionary measures are not taken.

DANGER!

Danger

This word with a warning triangle indicates that there is a considerable risk of fatal injury

▪ if the stated precautionary measures are not taken.

Information

Information indicates important information about the product or serves to emphasize a section in the documentation that
deserves special attention from the reader.
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2.7.2 Markup of text elements
Certain elements of the continuous text are distinguished as follows.

Important information Words or expressions with a special meaning

Interpolated position mode Optional: File or product name or other name

Detailed information Internal cross-reference

http://www.samplelink.com External cross-reference

Software and other displays

The following formatting is used to identify the various information content of elements referenced by the software
interface or a drive controller display, as well as any user entries.

Main menu 
Settings

Window names, dialog box names, page names or buttons, combined
proper nouns, functions referenced by the interface

Select 
Referencing method A

Predefined entry

Save your 
<own IP address>

User-defined entry

EVENT 52: 
COMMUNICATION

Displays (status, messages, warnings, faults)

Keyboard shortcuts and command sequences or paths are represented as follows.

[Ctrl], [Ctrl] + [S] Key, key combination

Table > Insert table Navigation to menus/submenus (path specification)

2.7.3 Mathematics and formulas
The following signs are used to represent mathematical relationships and formulas.

– Subtraction

+ Addition

× Multiplication

÷ Division

| | Absolute value

http://www.stoeber.de
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2.8 Trademarks
The following names used in connection with the device, its optional equipment and its accessories are trademarks or
registered trademarks of other companies:

EnDat® EnDat® and the EnDat® logo are registered trademarks of Dr. Johannes Heidenhain
GmbH, Germany.

PROFIBUS®, 
PROFINET®

PROFIBUS® and PROFINET® are registered trademarks of PROFIBUS
Nutzerorganisation e.V., Germany.

PROFIdrive®,
PROFIsafe®

PROFIdrive® and PROFIsafe® are registered trademarks of Siemens AG, Germany.

SIMATIC®, 
TIA Portal®

SIMATIC® and TIA Portal® are registered trademarks of Siemens AG, Germany.

All other trademarks not listed here are the property of their respective owners.

Products that are registered as trademarks are not specially indicated in this documentation. Existing property rights
(patents, trademarks, protection of utility models) are to be observed.

2.9 Explanation of terms
As relevant standards and products of other manufacturers are referenced, different manufacturer- or standard-specific
names are used for the same term in this documentation.

For improved understandability, the names in this documentation are standardized to the terminology of STOBER to the
greatest extent possible. The correlation of STOBER names to other sources can be found in the following table.

STOBER PROFINET

Controller IO controller

Drive controller IO device

Tab. 1: Correlation of STOBER terminology to PROFINET
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3 Safety notes

WARNING!

Risk of fatal injury if safety notes and residual risks are not observed!

Failure to observe the safety notes and residual risks in the drive controller documentation may result in accidents causing
serious injury or death.

▪ Observe the safety notes in the drive controller documentation.

▪ Consider the residual risks in the risk assessment for the machine or system.

WARNING!

Malfunction of the machine due to incorrect or modified parameterization!

In the event of incorrect or modified parameterization, malfunctions can occur on machines or systems which can lead to
serious injuries or death.

▪ Observe the security notes in the drive controller documentation.

▪ Protect the parameterization, e.g. from unauthorized access.

▪ Take appropriate measures for possible malfunctions (e.g. emergency off or emergency stop).
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4 Network structure
A PROFINET network generally consists of a PROFINET segment with a controller (IO controller) and all IO devices belonging
to this area, i.e. SC6 or SI6 series drive controllers and a PC as the IO supervisor.

The PS6 supply module, which you also need for SI6 series drive controllers, is not part of the PROFINET network.

The PROFINET network structure is generally tailored to the specific requirements of the respective system. STOBER drive
controllers support a star, line or tree topology.

All PROFINET nodes are integrated into the PROFINET network using internal or external switches (100 Mbps).

You can configure and parameterize the drive controllers using the DriveControlSuite DS6 software from STOBER; 
Siemens TIA Portal lets you do this for the entire PROFINET network, for instance.

The following graphic presents an abstract of a PROFINET network using the SI6 series as an example.

IO controller
SIMATIC S7-1500

PROFINET

IO devices
1 x supply module
3 x drive controllers

Commissioning

IO supervisor
commissioning

Co
m

m
an

d 
le

ve
l

Co
nt

ro
lle

r l
ev

el
Fi

el
d 

le
ve

l

PS6
SI6

Fig. 1: PROFINET: Network structure, using the SI6 series as an example



5 | Connection STOBER

12

08
/2

02
4 

| 
ID

 4
43

03
9.

05

5 Connection
For network connection, PROFINET only allows switches; these in turn allow for flexible network structure and nearly
unlimited network expansion of several kilometers at maximum speed.

5.1 Selecting suitable cables
The PROFINET transmission technology is based on the Fast Ethernet standard.

The connections between the nodes of a PROFINET network generally consist of symmetrical, shielded copper cables
twisted in pairs (shielded twisted pair, CAT 5e quality level). Fiber-optic cables are also a possible means of transmission.

Signals are transmitted according to the 100BASE TX method, i.e. with a transfer rate of 100 Mbps at a frequency of
125 MHz. A maximum of 1440 bytes can be transferred per frame. The maximum cable length is 100 m.

PROFINET cables exist in different versions that are tailored to different application scenarios and ambient conditions.

We recommend using the cables and plug connectors specified in the PROFINET installation guidelines. They are adjusted
for use in automation technology with regard to usage, resistance, EMC properties and color coding.

There are type A, B and C cables, differentiated by installation type:

§ Type A
4-wire shielded copper cable for fixed installation

§ Type B
4-wire shielded copper cable for flexible installation

§ Type C
4-wire shielded copper cable for constant movements

5.2 X200, X201: Fieldbus connection
In order to be able to connect the drive controllers to other PROFINET nodes, an integrated switch with both X200 and X201
RJ-45 sockets is provided. The sockets are located on top of the device. The associated pin assignment and color coding
correspond to the EIA/TIA-T568B standard.

Socket Pin Designation Function

1|2| ... |7|8 1 Tx+ Communication

2 Tx−

3 Rx+

4 — —

5 — —

6 Rx− Communication

7 — —

8 — —

Tab. 2: X200 and X201 connection description
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6 What you should know before commissioning
The following chapters provide a quick introduction to the structure of the program interface and accompanying window
designations as well as relevant information about parameters and generally saving your project configuration.

6.1 Program interfaces
The following chapters include an overview of the program interfaces for the described software components.

6.1.1 DS6 program interface
Using the graphical interface of the DriveControlSuite commissioning software (DS6), you can project, parameterize and
commission your drive project quickly and efficiently. In case of service, you can evaluate diagnostic information such as
operating states, fault memories and fault counters of your drive project using DriveControlSuite.

Information

The program interface of DriveControlSuite is available in German, English and French. To change the language of the
program interface, select Settings > Language.

Information

The DriveControlSuite help in the menu bar can be reached via Help > Help for DS6 or via the [F1] key on your keyboard.
When you press [F1] in an area of the program, the corresponding help topic opens.
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6 7 8
9

Fig. 2: DS6: Program interface

No. Area Description

1 Menu bar Using the File, View, Settings and Window menus, you can open and save projects, display
and hide program windows, select the interface language and access level and change
between different windows in the workspace.

2 Toolbar The toolbar enables quick access to frequently needed functions, like opening and saving
projects and hiding and displaying windows in the program interface.

3 Project tree The project tree forms the structure of your drive project in the form of modules and drive
controllers. Select an element using the project tree first in order to edit it using the
project menu.

4 Project menu The project menu offers you various functions for editing the project, module and drive
controller. The project menu adapts to the element that you selected in the project tree.

5 Workspace The different windows which can be used to edit your drive project, such as the
configuration dialog, wizards, the parameter list or the scope analysis tool, open in the
workspace.

6 Parameter check The parameter check points out irregularities and inconsistencies that were detected in
the plausibility check of calculable parameters.

7 Messages The entries in the messages log the connection and communication status of the drive
controllers, incorrect inputs caught by the system, errors when opening a project or rule
violations in the graphical programming.

8 Variable parameter
lists

You can use variable parameter lists to compile any parameters in individual parameter
lists for a quick overview.

9 Status bar In the status bar, you can find the specifications of the software version and get additional
information about the project file, the devices and the progress of the process during
processes such as loading projects.
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6.1.1.1 Configuring the view

In DriveControlSuite, you can change the visibility and arrangement of areas and windows, such as to optimize the available
space in the workspace when working with smaller screens.

Showing/hiding areas

Use the icons in the toolbar or the items in the View menu to show or hide specific areas in DriveControlSuite as needed.

Icon Item Description

– Reset Resets the view to factory settings.

Project Shows/hides the Project window (project tree, project
menu).

Messages Shows/hides the Messages window.

Parameter check Shows/hides the Parameter check window.

Variable parameter lists Shows/hides the Variable parameter lists window.

Arrange and group areas

You can undock and rearrange the individual areas via drag and drop. If you drag an undocked window to the edge of
DriveControlSuite, you can release it there in a color-highlighted area either next to or on top of another window to redock
it.

When you release the window onto another window, the two areas are merged into one window where you can use tabs to
switch between the areas.
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6.1.1.2 Navigation using sensitive circuit diagrams

Fig. 3: DriveControlSuite: Navigation using text links and symbols

In order to graphically illustrate the processing sequence of actual and set values, the use of signals or the arrangement of
drive components and to make configuring the accompanying parameters easier, they are displayed on the respective
wizard pages of the workspace in the form of circuit diagrams.

Blue text links or clickable icons indicate links within the program. These refer to the corresponding wizard pages and, as a
result, allow you to reach additional helpful detail pages with a click.
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6.1.2 TIA Portal program interface
The Siemens Totally Integrated Automation Portal (TIA Portal) offers a platform you can use to commission your PROFINET
system. The TIA Portal is broken down into the portal view and the project view.

TIA portal view

The TIA overall functionality is broken down into different task areas that you can reach using portals. The following graphic
shows the interface elements of the TIA portal view relevant to this documentation.

1 2

3

Fig. 4: TIA Portal: Program interface of the portal view

No. Area Description

1 Portal selection The portal selection offers you access to various portals for different tasks and functions.

2 Portal functions Depending on the selected portal, the portal functions are available here.

3 Project view The button lets you change to the project view.
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TIA project view

The TIA project view offers you access to all components of a project. The following graphic shows the interface elements of
the TIA portal view relevant to this documentation.

1

2

3

4

5

6

Fig. 5: TIA Portal: Program interface of the project view

No. Area Description

1 Project navigation Project navigation offers you access to all components of your TIA project.

2 Details view The details view shows you additional information about a selected object.

3 Workspace In the workspace, you can edit objects in the topology view, network view or device view,
for example.

4 Inspector window The inspector window shows you additional information about a selected object.

5 Task cards Task cards are available depending on the selected object and grant you access to the
hardware catalog, online tools, tasks or libraries, for example.

6 Portal view The button lets you change to the portal view.
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6.2 Meaning of parameters
You can use parameters to adapt the function of the drive controller to your individual application. In addition, parameters
visualize the current actual values (actual velocity, actual torque, etc.) and trigger actions such as Save values, Test phase,
etc.

Interpretation of parameter identification

Parameter identification consists of the following elements, where short forms are also possible, i.e. only specifying a
coordinate or the combination of coordinate and name.

E50 V0

Coordinate Name Version

Drive controller G6

Drive controller
generation/series

6.2.1 Parameter groups
Parameters are assigned to individual groups by topic. The drive controllers differentiate between the following parameter
groups.

Group Topic

 A Drive controllers, communication, cycle times

B Motor

C Machine, velocity, torque/force, comparators

D Set value

E Display

F Terminals, analog and digital inputs and outputs, brake

G Technology – Part 1 (application-dependent)

H Encoder

I Motion (all motion settings)

J Motion blocks

K Control panel

L Technology – Part 2 (application-dependent)

M Profiles (application-dependent)

N Additional functions (application-dependent; e.g. extended cam control unit)

P Customer-specific parameters (programming)

Q Customer-specific parameters, instance-dependent (programming)

R Production data for the drive controller, motor, brakes, motor adapter, gear unit and geared motor

S Safety (safety technology)

T Scope

U Protection functions

Z Fault counter

Tab. 3: Parameter groups
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6.2.2 Parameter types and data types
In addition to topic-based sorting in individual groups, all parameters belong to a certain data type and parameter type. The
data type of a parameter is displayed in the parameter list, properties table. The connections between parameter types,
data types and their value range can be found in the following table.

Data type Parameter type Length Value range (decimal)

INT8 Integer or selection 1 byte (signed) -128 – 127

INT16 Integer 2 bytes (1 word, signed) -32768 – 32767

INT32 Integer or position 4 bytes (1 double word, signed) -2 147 483 648 – 2 147 483 647

BOOL Binary number 1 bit (internal: 
LSB in 1 byte)

0, 1

BYTE Binary number 1 byte (unsigned) 0 – 255

WORD Binary number 2 bytes (1 word, unsigned) 0 – 65535

DWORD Binary number or
parameter address

4 bytes (1 double word, unsigned) 0 – 4 294 967 295

REAL32
(single type according to
IEE754)

Floating-point number 4 bytes (1 double word, signed) -3.40282 × 1038 – 3.40282 × 1038

STR8 Text 8 characters —

STR16 Text 16 characters —

STR80 Text 80 characters —

Tab. 4: Parameters: Data types, parameter types, possible values

Parameter types: Use

§ Integer, floating-point number
For general computing processes
Example: Set and actual values

§ Selection
Numeric value to which a direct meaning is assigned
Example: Sources for signals or set values

§ Binary number
Bit-oriented parameter information that is collected in binary
Example: Control and status words

§ Position
Integer combined with associated units and decimal places
Example: Actual and set values of positions

§ Velocity, acceleration, deceleration, jerk
Floating-point number combined with associated units
Example: Actual and set values for velocity, acceleration, deceleration, jerk

§ Parameter address
Referencing of a parameter
Example: In F40 AO1 source, for example, E08 n-motor filtered can be parameterized

§ Text
Outputs or messages
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6.2.3 Parameter types
The following types of parameters are differentiated.

Parameter type Description Example

Simple parameters Consist of one group and one line with a
defined value.

A21 Brake resistor R: Value = 100 ohms

Array parameters Consist of a group, a line and multiple
sequential (listed) elements, which have the
same properties but different values.

A10 Access level

§ A10[0] access level: Value = Access level
via operating unit

§ A10[2] access level: Value = Access level
via CANopen and EtherCAT

§ A10[4] access level: Value = Access level
via PROFINET

Record parameters Consist of a group, a line and multiple
sequential (listed) elements, which can have
different properties and different values.

A00 Save values

§ A00[0] Start: Value = Start action

§ A00[1] Progress: Value = Display action
progress

§ A00[2] Result: Value = Display action
result

Tab. 5: Parameter types

6.2.4 Parameter structure
Every parameter has specific coordinates with the following structure.

E200 [0]

Axis
Group

Line

1.

Element

§ Axis (optional)
Axis to which an axis-specific parameter is assigned; not applicable for global parameters (value range: 1 - 4).

§ Group
The thematic group to which a parameter belongs (value range: A – Z).

§ Line
Distinguishes the parameters within a parameter group (value range: 0 – 999).

§ Element (optional)
Elements of an array or record parameter (value range: 0 – 16000).
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6.2.5 Parameter visibility
The visibility of a parameter is controlled by the access level you set in DriveControlSuite and by the properties you project
for the respective drive controller (e.g. hardware, firmware and application). A parameter can also be shown or hidden
depending on other parameters or settings. For example, the parameters of an additional function are only shown as soon
as you activate the relevant additional function.

Access level

The access options for the individual software parameters are ranked hierarchically and divided into individual levels. This
means that parameters can be hidden for a specific purpose and, relatedly, their configuration options can be locked
starting from a specific level.

Each parameter has one access level for read access (visibility) and one access level for write access (editability). The
following levels are present:

§ Level 0
Elementary parameters

§ Level 1
Important parameters of an application

§ Level 2
Important parameters for service with extensive diagnostic options

§ Level 3
All parameters needed for commissioning and optimizing an application

The parameter A10 Access level controls general access to parameters:

§ Over CANopen or EtherCAT (A10[2])

§ Over PROFINET (A10[3])

Information

It is not possible to write to or read the parameter hidden in DriveControlSuite during communication via fieldbus.

Hardware

Which parameters are available to you in DriveControlSuite is determined by which series you select in the configuration
dialog for the drive controller, for example, or whether you project an option module. Basically, the only parameters that
are displayed are the ones you need to parameterize the configured hardware.

Firmware

Due to the further development and updating of functions for the drive controllers, new parameters and also new versions
of existing parameters are continuously being implemented in DriveControlSuite and in the firmware. The parameters are
displayed in the software according to the DriveControlSuite version used and the configured firmware version of the
respective drive controller.

Applications

Applications generally differ in terms of functions and their control. For this reason, different parameters are available with
each application.
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6.3 Signal sources and process data mapping
The transmission of control signals and set values in DriveControlSuite meets the following principles.

Signal sources

Drive controllers are controlled either over a fieldbus, using mixed operation consisting of a fieldbus system and terminals
or exclusively using terminals. 
You can use the corresponding selection parameters, referred to as signal sources, to configure whether the control signals
and set values of the application are obtained over a fieldbus or using terminals.

In case of activation over a fieldbus, parameters that are selected as data sources for control signals or set values must be
part of the subsequent process data mapping. In the case of activation using terminals, the respective analog or digital
inputs are specified directly.

Process data mapping

If you are working with a fieldbus system and have selected the source parameters for control signals and set values,
configure the fieldbus-specific settings, e.g. the assignment of the process data channels for transmitting receive and
transmit process data, as the last step.

6.4 Non-volatile memory
All project configurations, parameterizations and related changes to parameter values are in effect after transmission to the
drive controller, but are only stored in volatile memory.

Saving to a drive controller

To save the configuration in non-volatile memory on a drive controller, you have the following options:

§ Saving the configuration using the Save values wizard:
Project menu > Wizards area > Projected axis > Save values wizard: Select the Save values action

§ Saving the configuration using the parameter list:
Project menu > Parameter list area > Projected axis > Group A: Drive controller > A00 Save values: Set the parameter
A00[0] to the value 1: Active

§ Saving the configuration using the S1 operating button:
Drive controller with S1 operating button: Press and hold the operating button for 3 s

Saving to all drive controllers within a project

To save the configuration in non-volatile memory on several drive controllers, you have the following options:

§ Saving the configuration using the toolbar:
Toolbar > Save values icon: Click the Save values icon

§ Saving the configuration using the Online functions window:
Project menu > Online connection button > Online functions window: Click on Save values (A00)

Information

Do not shut off the drive controller while saving. If the supply voltage to the control unit is interrupted while saving, the
drive controller will start with fault 40: Invalid data the next time it is switched on. To successfully complete the saving
procedure, the configuration must be stored again in non-volatile memory.
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7 Commissioning
The following chapters describe the commissioning of a PROFINET network, consisting of a Siemens controller and multiple
STOBER drive controllers, with the help of DriveControlSuite and the Siemens TIA Portal.

We assume the following system environment as an example so that you can follow the individual commissioning steps
better:

§ Drive controllers from the SC6 or SI6 series with firmware version 6.6-B-PN or later

§ DS6 commissioning software version 6.6-B or later

in combination with

§ Siemens SIMATIC S7-1500 controller

§ Siemens Totally Integrated Automation Portal (TIA Portal) V16 automation software

Commissioning is divided into the following steps:

1. First, define the control for the drive controllers.

2. DriveControlSuite:
Project all drive controllers of your PROFINET network (device control, application and process data), parameterize all
general PROFINET settings and the motor, as well as the axis model or reference speed if necessary, then transmit
your configuration to the drive controllers of your PROFINET network.

3. TIA Portal:
Next, map your actual PROFINET network in TIA Portal and configure the individual nodes. Transfer the configuration
to the controller and start up your PROFINET network.

Information

Before you start commissioning your PROFINET network using DriveControlSuite and TIA Portal, you must network all nodes
of your PROFINET network with each other.
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7.1 Setting the control
The options described below are available for controlling STOBER drive controllers via TIA Portal.

Siemens technology objects (TO)

Technology object Description Application

TO_SpeedAxis Control of a velocity-controlled axis Controller-based application

TO_PositioningAxis,
TO_SynchronousAxis

Control of a position-controlled axis Controller-based application

TO_BasicPos Control of a position-controlled axis Drive-based application

Tab. 6: Siemens technology objects

You can access the technology objects directly in TIA Portal and add them to your controller.

Siemens function blocks (FB) from the DriveLib

Function block Description Application

FB SINA_SPEED Control of a velocity-controlled axis Drive-based application

FB SINA_POS Control of a position-controlled axis Drive-based application

Tab. 7: Siemens function blocks DriveLib

The function blocks can be downloaded free of charge from the Siemens website after registration and imported into TIA
Portal (https://support.industry.siemens.com). If you are already using the function blocks in TIA Portal, make sure that you
are working with the latest version.

Possible combinations

The following table shows examples of possible combinations of technology objects or function blocks with the available
application classes and telegrams.

During commissioning in TIA Portal, you will learn how to configure your control system based on these examples.

Control Application class Telegrams

TO_SpeedAxis AC1 Standard telegrams 1, 2, 3

TO_PositioningAxis,
TO_SynchronousAxis

AC4 Standard telegrams 3, 5 or Siemens telegrams 102, 105 (optionally in
combination with Siemens additional telegram 750)

TO_BasicPos AC3 Siemens telegram 111

FB SINA_SPEED AC1 Standard telegram 1

FB SINA_POS AC3 Siemens telegram 111

Tab. 8: Combinations: function block or technology object with telegram

Further information on the application classes and telegrams can be found in the corresponding PROFIdrive application
manual (see Detailed information [} 75]).

Information

This documentation focuses on the device-specific settings that must be considered for drive controllers from STOBER for
parameterizing technology objects from Siemens or controlling function blocks. For settings that are not described in detail,
refer to the Siemens documentation.

https://support.industry.siemens.com
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7.2 DS6: Configuring the drive controller
Project and configure all drive controllers for your drive system in DriveControlSuite DS6 
(see the chapter DS6 program interface [} 13]).

Information

The steps required for commissioning PROFINET are described based on the drive-based PROFIdrive application in
combination with PROFIdrive device control.

For further information on commissioning the application, refer to the corresponding PROFIdrive application manual 
(see Detailed information [} 75]).

Information

Always perform the steps described below in the specified order!

Some parameters are interdependent and do not become accessible to you until you have first configured certain settings.
Follow the steps in the specified sequence so that you can finish the parameterization completely.

7.2.1 Initiating the project
In order to be able to configure all drive controllers and axes of your drive system using DriveControlSuite, you must record
them as part of a project.

7.2.1.1 Projecting the drive controller and axis

Create a new project and project the first drive controller along with the accompanying axis.

Information

Make sure that you project the correct series in the Drive controller tab. The projected series cannot be changed
afterwards.

Creating a new project

1. Start DriveControlSuite.

2. On the start screen, click Create new project.

ð The new project is created and the configuration dialog for the first drive controller opens.

ð The Drive controller button is active.
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Projecting the drive controller

1. Properties tab: 
Establish the relationship between your circuit diagram and the drive controller to be projected in DriveControlSuite.

1.1. Reference:
Define the reference code (equipment code) of the drive controller.

1.2. Designation:
Give the drive controller a unique name.

1.3. Version:
Version your project configuration.

1.4. Description:
If necessary, save additional supporting information (e.g., the change history).

2. Drive controller tab:
Select the series, device type and firmware version of the drive controller.

2.1. Firmware:
Select the PROFINET version 6.x -PN.

3. Option modules tab, Safety module:
If the drive controller is part of a safety circuit, select the corresponding safety module.

4. Device control tab:
Project the basic control of the drive controller.

4.1. Device control:
Select PROFIdrive device control.

4.2. Rx process data, Tx process data:
Select PROFINET Rx and PROFINET Tx for transmitting PROFINET process data.

Projecting the axis

1. Click Axis A.

2. Properties tab: 
Establish the relationship between your circuit diagram and the axis to be projected in DriveControlSuite.

2.1. Reference:
Define the reference code (equipment code) of the axis.

2.2. Designation:
Give the axis a unique name.

2.3. Version:
Version your project configuration.

2.4. Description:
If necessary, save additional supporting information (e.g., the change history).

3. Application tab:
Select the PROFIdrive application.

4. Motor tab:
Select the type of motor you operate with this axis. If you are working with motors from third-party suppliers, enter
the accompanying motor data later.

5. Repeat the steps for axis B (only for double-axis controllers).

6. Confirm with OK.
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7.2.1.2 Configuring safety technology

If the drive controller is part of a safety circuit, you must configure the safety technology in accordance with the
commissioning steps outlined in the corresponding manual in the next step (see Detailed information [} 75]).

7.2.1.3 Creating other drive controllers and modules

In DriveControlSuite, all drive controllers within a project are grouped using modules. If you add a new drive controller to
your project, be sure to always assign it to an existing module. Group drive controllers in a module if, for example, they are
located in the same control cabinet or work together to operate the same machine part.

Creating a drive controller

1. In the project tree, select your project P1 > module M1 > context menu Create new drive controller.

ð The drive controller is created in the project tree and the configuration dialog opens.

2. Project the drive controller as described in Projecting the drive controller and axis.

3. Repeat the steps for all other drive controllers that you want to project.

Creating a module

1. In the project tree, select your project P1 > context menu Create new module.

ð The module is created in the project tree.

2. Project the module as described in Projecting the module [} 28].

3. Repeat the steps for all other modules that you want to project.

7.2.1.4 Projecting the module

Give your module a unique name, enter the reference code and, as an option, store additional information like the version
and change history of the module.

1. Select the module in the project tree and click on Project configuration in the project menu.

ð The configuration dialog for the module opens.

2. Establish the relationship between your circuit diagram and the module in DriveControlSuite.

2.1. Reference:
Define the reference code (equipment code) of the module.

2.2. Designation:
Give the module a unique name.

2.3. Version:
Version the module.

2.4. Description:
If necessary, save additional supporting information (e.g., the change history).

3. Confirm with OK.
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7.2.1.5 Projecting the project

Give your project a unique name, enter the reference code and, as an option, store additional information like the version
and change history of the project.

1. Select the project in the project tree and click on Project configuration in the project menu.

ð The configuration dialog for the project opens.

2. Establish the relationship between your circuit diagram and the project in DriveControlSuite.

2.1. Reference:
Define the reference code (equipment code) of the project.

2.2. Designation:
Give the project a unique name.

2.3. Version:
Version the project.

2.4. Description:
If necessary, save additional supporting information (e.g., the change history).

3. Confirm with OK.
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7.2.2 Parameterizing general PROFINET settings

ü You have projected the PROFINET Rx and PROFINET Tx process data for the drive controller.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the PROFINET wizard.

3. A100 Fieldbus scaling:
Leave the default value at 1: Native (values are passed unchanged).

4. A273 PN device name:
Elements [0] to [2] show the PROFINET device name that was assigned in TIA Portal if there is an online connection
between the drive controller and controller.
In elements [3] to [5], you have the option to enter the device name. This eliminates the need to assign the device
name in TIA Portal.

5. A109 PZD-Timeout:
Define the time that results from the tolerated failure time for monitoring the PZD communication plus the watchdog
time of the controller (TIA Portal: watchdog time) in the PROFINET network (default value: 20 ms).

7.2.3 Configuring PZD transmission
The PZD channel (process data transmission channel) serves to transfer control and status information as well as actual and
set values between a controller (IO controller) and drive controller (IO device) cyclically in real time.

The direction of data flow is important in this data exchange. From the perspective of the drive controller, PROFINET
distinguishes between receive PZD (RxPZD) and transmit PZD (TxPZD). STOBER drive controllers support a flexible
assignment of the parameter values to be transmitted.

You can transfer process data with a maximum of 48 parameters to be transferred over axes A and B (24 per axis).

The planned projected application determines which process data is exchanged between the controller and drive controller
during cyclical data transmission.

In the PROFIdrive application, process data mapping takes place automatically when the connection between the controller
and drive controller is established and depends on the selected telegram; manual parameterization is not required.

For further information on the supported communication objects of the PROFIdrive profile, refer to the corresponding
application manual.
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7.2.4 Parameterizing the motor
You have projected one of the following motors:

Synchronous servo motor with EnDat 2.2 digital encoder or EnDat 3 (with optional brake)

By projecting the corresponding motor, limiting values for currents and torques as well as associated temperature data are
automatically transferred to the respective parameters of the individual wizards. All additional data on the brake and
encoder is transferred at the same time.

Lean motor without encoder (with optional brake)

By projecting the corresponding motor, limiting values for currents and torques as well as associated temperature data are
automatically transferred to the respective parameters of the individual wizards. You only have to parameterize the cable
length in use. Even the brake purging and engaging times are already stored. You just have to activate the brake.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Motor wizard.

3. B101 Cable length:
Select the cable length of the power cable in use.

4. Repeat the steps for the 2nd axis (only for double-axis controllers).

Then activate the brake.

1. Select the relevant drive controller in the project tree and click on the first projected axis in the Project menu > Wizard
area.

2. Select the Brake wizard.

3. F00 Brake:
Select 1: Active.

4. Repeat the steps for the 2nd axis (only for double-axis controllers).

Motor protection

The drive controller has an i²t model of the motor, a computational model for thermal monitoring of the motor. To activate
it and set up the protective function, configure the following settings (deviating from the presets): U10 = 2: Warning and
U11 = 1.00 s. This model can be used instead of or in addition to temperature-monitored motor protection.
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7.2.5 Mapping the mechanical axis model
For a control in combination with telegram 111, you must map your complete mechanical environment in DriveControlSuite
to be able to commission your real drive train with one or more drive controllers.

For all other telegrams, do not make any changes to the axis model. Instead, parameterize the required limits directly in the
next step (see Parameterizing the reference speed [} 37]).

7.2.5.1 Parameterizing the axis model

Parameterize the setup of your drive in this order:

§ Define the axis model

§ Scale the axis

§ Parameterize the position and velocity window

§ Limit the axis (optional)

• Limit the position

• Limit the velocity, acceleration and jerk

• Limit the torque and force

Information

If you are using a double-axis controller with two projected axes, you must parameterize the axis model for each axis
individually.
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7.2.5.1.1 Define the axis model

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Axis model wizard.

3. I05 Type of axis:
Define whether the axis type is rotational or translational.

3.1. If you would like to configure the units of measure and the number of decimal places individually for specifying
and displaying positions, velocities, accelerations and jerk, select 0: User defined, rotational or 1: User defined,
translational.

3.2. If the units of measure and the number of decimal places for specifying and displaying positions, velocities,
accelerations and jerk are to be fixed, select 2: Rotational or 3: Translational.

4. B26 Motor encoder:
Define the interface to which the motor encoder is connected.

5. I02 Position encoder (optional):
Define the interface to which the position encoder is connected.

6. I00 Position range:
Define whether the travel range of the axis is limited or endless (modulo).

7. If you select I00 = 1: Endless, parameterize a revolution length when you scale the axis.

Information

When you parameterize I05 Type of axis, you can either use selection 0: User defined, rotational or 1: User defined,
translational to configure units of measure and the number of decimal places for the axis model individually or use
selections 2: Rotational and 3: Translational to revert to preset values.

Selection 0: User defined, rotational and selection 1: User defined, translational let you configure the unit of measure (I09)
and the decimal places (I06) individually. Velocity, acceleration and jerk are represented as the derivative of the unit of
measure with respect to time.

Selection 2: Rotational sets the following units of measure for the axis model: position in °, velocity in rpm, acceleration in
rad/s2, jerk in rad/s3.

Selection 3: Translational sets the following units of measure for the axis model: position in mm, velocity in m/s,
acceleration in m/s2, jerk in m/s3.

Information

If you do not parameterize it differently for I02 Position encoder, B26 Motor encoder is used for position control as
standard.
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7.2.5.1.2 Scale the axis

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Axis model wizard > Axis: Scaling.

3. Scale the axis by configuring the overall gear ratio between the motor and output.
To simplify this scaling for you, you are provided with the scaling calculator Conversion of positions, velocities,
accelerations, torque/force, which calculates the effects of changed motion variables on the entire system.

4. I01 Circular length:
If you have selected 1: Endless for I00 Position range, enter the revolution length.

5. I06 Decimal places position (optional):
If you have selected 0: User defined, rotational or 1: User defined, translational for I05 Type of axis, define the desired
number of decimal places.

6. I09 Measure unit (optional):
If you have selected 0: User defined, rotational or 1: User defined, translational for I05 Type of axis, define the desired
unit of measure.

7. I03 Axis polarity:
Use the polarity to specify the direction of interpretation between the axis movement and motor movement.

Information

A change to parameter I06 moves the decimal separator for all axis-specific position values! Ideally, define I06 before
parameterizing other position values and then check them.

If the axis receives set value specifications from a controller or follows the master values of a master, the resolution of
position values directly impacts the smooth operation of the axis. Therefore, you should define a sufficient number of
decimal places appropriate for your application.

Information

Parameter I297 Maximum speed position encoder must be parameterized according to your application case. If I297 is set
too low, the permitted maximum speed is exceeded even at normal operating speeds. On the other hand, if I297 is set too
high, measuring errors of the encoder can be overlooked.

I297 depends on the following parameters: I05 Type of axis, I06 Decimal places position, I09 Measure unit as well as
I07 Distance factor numerator position and I08 Distance factor denominator position or A585 Feed constant for CiA 402. 
If you have made changes to one of the parameters listed, select I297 accordingly as well.
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7.2.5.1.3 Parameterizing the position and velocity window

Enter position limits and velocity zones for set values. To do so, parameterize boundary values for reaching a position or
velocity.

1. Select the Axis model wizard > Window position, velocity.

2. C40 Velocity window:
Parameterize a tolerance window for velocity tests.

3. I22 Target window:
Parameterize a tolerance window for position tests.

4. I87 Actual position in window time:
Parameterize how long a drive must stay in the specified position window before a corresponding status message is
output.

5. I21 Maximal following error:
Parameterize a tolerance window for lag tests.

7.2.5.1.4 Limiting the axis

As an option, you can limit the maximum permitted motion variables of position, velocity, acceleration, jerk and torque/
force according to your application.

Information

To simplify the scaling and limiting of the axis, the Axis model wizard > Axis: Scaling provides you with the Conversion of
position, velocities, accelerations, torque/force scaling calculator, which calculates the effects of changed motion variables
on the entire system. You can use the scaling calculator to enter values for motion variables of the motor, gear unit output
and axis in order to convert the values to all other locations in the axis model.

Limiting the position

To secure the travel range of the axis, you have the option to limit the permitted positions using a software or hardware
limit switch.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Axis model wizard > Limit: Position.

3. I101 Source positive /limit switch, I102 Source negative /limit switch:
To limit the travel range of the axis via hardware limit switches, select the source of the digital signal that is used to
evaluate a limit switch at the positive or negative end of the travel range.

3.1. If a fieldbus is the source, select 2: Parameter.

3.2. If a digital input (direct or inverted) acts as the source, select the corresponding input.

4. I50 Software stop positive, I51 Software stop negative:
To limit the travel range of the axis via software limit switches, define the largest or smallest permitted position for
software position limiting.
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Limiting velocity, acceleration, jerk

As an option, you can limit the motion variables of velocity, acceleration and jerk and define the quick stop deceleration
according to your application. The default values are designed for slow velocities without gear units.

1. Select the Motor wizard.

2. B83 v-max motor:
Determine the maximum permitted velocity of the motor.

3. Select the Axis model wizard > Axis: Scaling.

4. Conversion of positions, velocities, accelerations, torque/force area:
Use the scaling calculator to determine the maximum permitted velocity of the output using the maximum permitted
velocity of the motor.

5. Select the Axis model wizard > Limit: Velocity, acceleration, jerk.

6. I10 Maximal speed:
Define the maximum permitted velocity for the output.

7. I11 Maximal acceleration:
Define the maximum permitted acceleration for the output.

8. I16 Maximal jerk:
Define the maximum permitted jerk for the output.

9. I17 Quickstop deceleration: 
Define the desired quick stop deceleration for the output.

10. Repeat the steps for axis B (only for double-axis controllers).

Limiting torque/force

As an option, you can limit the torque/force according to your application. The default values take into account the rated
operation together with the overload reserves.

1. Select the Axis model wizard > Limit: Torque/force.

2. C03 Maximum positive torque/force, C05 Maximum negative torque/force:
Define the maximum permitted set torque/maximum permitted set force.

3. C08 Maximum torque/force for quick stop:
Define the maximum permitted set torque/maximum permitted set force in case of a quick stop and in case of drive-
controlled emergency stop SS1, SS1 and SS2.
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7.2.6 Parameterizing the reference speed
Parameterize the reference value for the set and actual velocities as described below in order to ensure the function of the
application. For control in combination with telegram 111, the reference value is not evaluated and parameterization is
therefore not required.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Application PROFIdrive wizard > Additional functions > Drive data.

3. Reference speed in user unit:
Define the reference value for the target and actual velocities.

4. Repeat the steps for axis B (only for double-axis controllers).

Limiting velocity, acceleration, jerk

As an option, you can limit the motion variables of velocity, acceleration and jerk and define the quick stop deceleration
according to your application. The default values are designed for slow velocities without gear units.

1. Select the Motor wizard.

2. B83 v-max motor:
Determine the maximum permitted velocity of the motor.

3. Select the Axis model wizard > Axis: Scaling.

4. Conversion of positions, velocities, accelerations, torque/force area:
Use the scaling calculator to determine the maximum permitted velocity of the output using the maximum permitted
velocity of the motor.

5. Select the Axis model wizard > Limit: Velocity, acceleration, jerk.

6. I10 Maximal speed:
Define the maximum permitted velocity for the output.

7. I11 Maximal acceleration:
Define the maximum permitted acceleration for the output.

8. I16 Maximal jerk:
Define the maximum permitted jerk for the output.

9. I17 Quickstop deceleration: 
Define the desired quick stop deceleration for the output.

10. Repeat the steps for axis B (only for double-axis controllers).

Information

When you set the corresponding parameters on the controller side during commissioning in TIA Portal, note that some
units on the drive controller and controller side may be different.

Parameter DriveControlSuite Condition TIA Portal parameter

M571 Velocity reference value (reference speed in user unit) = Reference speed

Reference torque (C09 × 2.5) = Reference torque

I10 Maximal speed ≥ Maximum permitted velocity

I11 Maximal acceleration ≥ Maximum permitted acceleration/deceleration

I16 Maximal jerk ≥ Maximum permitted jerk

I17 Quickstop deceleration ≥ Emergency deceleration

Tab. 9: Limits: Required parameters on drive controller and controller sides
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7.2.7 Transmitting and saving the configuration
In order to transmit and save the configuration to one or more drive controllers, you must connect your PC and the drive
controllers over the network.

WARNING!

Injury to persons and material damage due to axis movement!

If there is an online connection between DriveControlSuite and the drive controller, changes to the configuration can lead
to unexpected axis movements.

▪ Only change the configuration if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

▪ For access via remote maintenance, there must be a communication link between you and a person on site with eye
contact to the axis.

Information

During the search, all drive controllers within the broadcast domain are found via IPv4 limited broadcast.

Requirements for finding a drive controller in the network:

▪ Network supports IPv4 limited broadcast

▪ All drive controllers and the PC are in the same subnet (broadcast domain)

ü The drive controllers are switched on and can be found in the network.

1. In the project tree, select the module under which you have recorded your drive controller and click Online
connection in the project menu.

ð The Add connection dialog box opens. All drive controllers found via IPv4 limited broadcast are displayed.

2. Direct connection tab, IP address column: 
Activate the IP addresses in question and confirm your selection with OK.

ð The Online functions window opens. All drive controllers connected through the selected IP addresses are
displayed.

3. Select the module and the drive controller to which you would like to transfer the configuration. Change the selection
of transmission type from Read to Send.

4. Change the selection Create new drive controller:
Select the configuration that you would like to transfer to the drive controller.

5. Repeat steps 3 and 4 for all other drive controllers to which you would like to transfer your configuration.

6. Online tab:
Click Establish online connections.

ð The configurations are transferred to the drive controllers.



STOBER 7 | Commissioning
08

/2
02

4 
| 

ID
 4

43
03

9.
05

39

Saving a configuration

ü You have successfully transferred the configuration.

1. Online functions window, Online tab, Actions for drive controller in online operation area:
Click Save values (A00).

ð The Save values (A00) window opens.

2. Select on which drive controllers you want to save the configuration.

3. Click Start action.

ð The configuration is stored on the drive controllers in non-volatile memory.

4. Close the Save values (A00) window.

Information

For the configuration to take effect on the drive controller, a restart is required: for example, after the configuration is
saved on the drive controller for the first time or when changes are made to the firmware or process data mapping.

Restarting a drive controller

ü You have stored the configuration on the drive controller in non-volatile memory.

1. Online functions window, Online tab:
Click Restart (A09).

ð The Restart (A09) window opens.

2. Select which of the connected drive controllers you want to restart.

3. Click Start action.

4. Confirm the safety note with OK.

ð The Restart (A09) window closes.

ð The fieldbus communication and connection between DriveControlSuite and drive controllers are interrupted.

ð The selected drive controllers restart.
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7.2.8 Testing the configuration
After you have transferred the configuration to the drive controller, first check your projected axis model and the
parameterized electrical and mechanical data for plausibility before continuing with the parameterization.

Information

Make sure that the values of the control panel are compatible with your projected axis model in order to obtain useful test
results that you can use to optimize your configuration for the respective axis.

The scaling calculator is available under the Axis model wizard > Axis: Scaling to recalculate the values for the control panel
according to your projected axis model.

WARNING!

Injury to persons and material damage due to axis movement!

When you activate the control panel, DriveControlSuite gives you sole control of the motions of the axis. If you are using a
controller, it no longer monitors the axis movements after the control panel is activated. The controller cannot intervene to
prevent collisions. The controller takes over control again when the control panel is deactivated, which can cause
unexpected axis movements.

▪ Do not switch to other windows when the control panel is active.

▪ Only use the control panel if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

▪ For access via remote maintenance, there must be a communication link between you and a person on site with eye
contact to the axis.

Testing the configuration using the jog control panel

ü There is an online connection between DriveControlSuite and the drive controller.

ü You have successfully stored the configuration on the drive controller.

ü No safety function is active.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Jog control panel wizard.

3. Click Control panel on and then Enable.

ð The axis is monitored via the active control panel.

4. Check the default values of the control panel and adjust them to your projected axis model if necessary.

5. To test the configuration of your projected axis for direction of motion, velocity, etc., move the axis gradually using
the Jog+, Jog-, Jog step+ and Jog step- buttons.

6. Use your test results to optimize your configuration as necessary.

7. To deactivate the control panel, click on Control panel off.

Information

Jog+ and Jog− cause a continual manual movement in the positive or negative direction. Jog step+ and Jog step- move the
axis relative to the current actual position by the increment specified in I14.

Jog+ and Jog− have a higher priority than Jog step+ and Jog step−.
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7.3 TIA Portal: Setting up a PROFINET network
A PROFINET networks generally consists of a controller (IO controller) and multiple drive controllers (IO devices). Using
TIA Portal, map your real PROFINET network in a TIA project, configure all PROFINET nodes and link them logically with each
other. Then, transfer the configuration to the controller and check the cyclical communication.

Information

Always perform the steps described below in the specified order!

Some parameters are interdependent and do not become accessible to you until you have first configured certain settings.
Follow the steps in the specified sequence so that you can finish the parameterization completely.

7.3.1 Installing the GSD file
To be able to map the STOBER drive controllers of your PROFINET network in your TIA project, you must import and install a
GSD file (general station description file) from STOBER in your TIA project. STOBER drive controllers are available in the
hardware catalog of your TIA project as soon as the GSD file has been installed.

Information

If you have already downloaded a GSD file from the STOBER download area at an earlier point, make sure that you are using
the current version of the GSD file required.

ü You have downloaded the current version of the GSD file from the STOBER download area and saved it locally.

ü You have created a TIA project and are in the TIA project view.

1. In the menu bar, select Options > Manage general station description files (GSD).

ð The Manage general station description files window opens.

2. Installed GSDs tab > Source path area:
Select the directory in which you have stored the GSD file from STOBER and confirm with OK.

ð The GSD file is displayed in the Content of the imported path area.

3. Content of the imported path area:
Select the desired GSD file and click on Install.

ð The GSD file is installed; the STOBER drive controllers are available in the hardware catalog.
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7.3.2 Projecting the PROFINET network
Map the controller and all drive controllers of your PROFINET network in a TIA project by selecting the corresponding
modules from the hardware catalog and incorporating them into the project.

7.3.2.1 Projecting the controller

Project the controller of your PROFINET network.

ü You have created a TIA project and installed the GSD file from STOBER.

ü You are in the TIA network view; the hardware catalog is open.

1. Hardware catalog:
Select Controller > SIMATIC S7-1500 > CPU and open the folder of the CPU type that belongs to your controller.

2. Drag and drop the desired controller into the network view.

ð The controller is incorporated into your TIA project.

7.3.2.2 Projecting the drive controller

Project all drive controllers of your PROFINET network.

ü You have created a TIA project and installed the GSD file from STOBER.

ü You are in the TIA network view; the hardware catalog is open.

1. Drag and drop the desired drive controller into the network view.

ð The drive controller is incorporated into your TIA project.

2. Repeat steps 1 and 2 for all drive controllers of your PROFINET network.
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7.3.2.3 Linking the controller and drive controller logically

Establish a logical gate link between the controller and drive controllers in order to enable the communication between the
devices.

ü You have projected the controller and drive controllers.

ü You are in the TIA network view.

1. Click on the interface of the controller and drag a connection to the interface of the first drive controller while holding
the mouse button.

2. Repeat the process for all drive controllers of your PROFINET network.

ð The controller and drive controllers of your PROFINET network are linked logically with each other.

Information

To be able to link the controller and drive controllers with each other logically, you must be in the TIA network view.

7.3.2.4 Connecting ports

If you want to implement a control in application class 4, you have to connect the ports of all nodes. For other application
classes, this step is optional.

In order for PROFIdrive to operate in application class 4, PROFINET must be in synchronous operation mode. For
synchronous operation via PROFINET IRT, you must define how all PROFINET nodes are connected to each other in the
connection topology. To do this, in the topology view, specify the connection of each individual cable from device to device
and the exact port.

ü You have logically linked the controller and drive controllers.

ü You are in the TIA topology view.

1. Click on the port you want to connect and drag it to the destination port while holding down the mouse button.

2. Repeat the process for all ports to be connected in your PROFINET network.

ð You have created the port connections.

Information

With an existing online connection, you can compare the connections you have created with your real cable connections.
For more information on the topology comparison, see the documentation from Siemens or the online help in TIA Portal.

7.3.3 Configuring network addresses
As needed, you can change the IP address and subnet mask of the controller.

ü You are in the TIA network view.

1. Double-click on the controller of your PROFINET network.

ð This switches you to the respective device view; the Inspector window shows the device properties.

2. Inspector window > General tab:
Select PROFINET interface > Ethernet addresses in the area navigation.

3. IP protocol area > Set IP address in the project:
If not set by default, activate this option and change the IP address and subnet mask of the controller.

ð The IP address and subnet mask of the controller are configured.
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7.3.4 Configuring the drive controller
Assign a device name for the drive controllers of your TIA project to be able to identify them in the PROFINET network.
Project a telegram for each axis and configure the settings for synchronization afterwards if necessary.

7.3.4.1 Assigning device names

Assign a device name for your drive controllers to be able to identify them in the PROFINET network.

ü You are in the TIA network view.

1. Double-click on a drive controller of your PROFINET network.

ð This switches you to the respective device view; the Inspector window shows the device properties.

2. Inspector window > General tab:
Select General in the area navigation.

3. Name:
Assign a device name for the drive controller that corresponds to the PROFINET naming conventions.

4. Device view:
Select the relevant drive controller and select Assign device name using its context menu.

ð The Assign PROFINET device name window opens.

5. Click on Update list.

ð All drive controllers are listed that were found in the subnet.

ð Depending on the drive controller, the device type, IP address and MAC address are displayed.

6. Mark the drive controller that you would like to name and click on Assign name.

ð The device name is assigned to the selected drive controller.

Information

Alternatively, you can enter the device name in DriveControlSuite in parameter A273[3] to [5]. This eliminates steps 4 to 6
in TIA Portal for assigning the device name.

Information

Using Flash LED, you can identify which drive controller you have currently selected if multiple drive controllers are found in
the same subnet.

As an alternative, you can identify the drive controller by its MAC address. The MAC address of the drive controller can be
read off in parameter A279 PN MAC addresses in DriveControlSuite (PROFINET wizard > Diagnostics).
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7.3.4.2 Projecting a standard telegram

Project one standard telegram per axis.

Information

For double-axis controllers, note that mixed operation of the PROFINET RT and PROFINET IRT transmission methods is not
possible. For example, if you project standard telegram 1 in AC1 for axis A and standard telegram 5 in AC4 for axis B,
standard telegram 1 is ignored.

ü You are in the TIA network view; the hardware catalog is open.

1. Double-click on a drive controller of your PROFINET network.

ð This switches you to the respective device view.

2. Hardware catalog:
Select Module > PROFIdrive modules.

3. Drag and drop the PROFIdrive modules module into the device overview of the drive controller at slot 1.

4. Hardware catalog:
Select Module > Submodules.

5. Select a telegram.

6. Drag and drop the selected standard telegram into the device overview of the drive controller at slot 1 2.

7. If you want to use an additional telegram, select it in the hardware catalog.

8. Drag and drop the selected additional telegram into the device overview of the drive controller at slot 1 3.

9. If you are using a double-axis controller, repeat steps 2 through 8 for the second axis and for slots 2, 2 2 and 2 3.
Project a telegram for the second axis even if you are not using it.

ð You have configured the telegrams.

Information

If you project additional telegram 900, define the additional process data that is to be transferred to the controller in
DriveControlSuite via the parameters A92 (RxPZD) and A96 (TxPZD). Elements [0] to [11] are used for axis A parameters and
elements [12] to [23] for axis B parameters. A data length of 12 bytes each is available for the receive and transmit process
data.
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7.3.4.3 Setting a drive controller synchronously

Configure the following settings for clock synchronization via PROFINET IRT if you want to implement control in application
class 4. For other application classes, this step is omitted.

ü You are in the TIA network view.

1. Double-click on a drive controller of your PROFINET network.

ð This switches you to the respective device view; the Inspector window shows the device properties.

2. Inspector window > General tab:
Select PROFINET interface > Advanced options > Isochronous mode in the area navigation.

3. Isochronous mode for local modules area > Isochronous mode:
Activate the option.

4. Detail overview area:
Activate the submodule with the inserted telegram in the Isochronous mode column to assign the synchronized
operation to the telegram.

5. If it is a double-axis controller, activate the second submodule with the inserted telegram.

ð The times are recalculated and entered in the Isochronous mode for local modules area. The transmission cycle is
taken from the GSD file.

ð You have configured the drive controller for synchronized operation.

7.3.5 Configuring the control
Next, configure the control of the application according to your use case by using technology objects or function blocks.

For further information on configuring the control and on technology objects and function blocks, refer to the
corresponding PROFIdrive application manual (see Detailed information [} 75]).
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7.3.6 Transmitting the configuration
Transmit the configuration of your TIA project from your PC to your controller.

ü You have fully mapped and parameterized your PROFINET network in the TIA project.

1. Project navigation > Devices tab:
Select the folder of the controller in question.

2. Select Online > Advanced download to device in the menu bar.

ð The Advanced download window opens.

3. Select target device area:
Select Show all compatible nodes and click on Start search.

ð All controllers are listed that were found in the subnet.

4. Select the controller where you would like to transfer the configuration and click on Download.

ð The Software synchronization before downloading to a device window opens.

5. Click on Continue without synchronizing.

ð The Preview download window opens.

6. Click on Download.

ð The configuration is transmitted to the selected controller and the Results of the download process window
opens.

7. Click on Finish.

ð The download process is complete; the configuration was transmitted successfully to the controller.

Information

If there is an online connection, you can identify which controller you have currently selected using Flash LED if multiple
controllers are located in the same subnet.

Information

In DriveControlSuite, parameter A271 provides information about the state of the drive controller in the PROFINET
network. If the application selected in DriveControlSuite does not match the inserted module in TIA Portal, the status 
6: Configuration Application / PROFINE does not fit is output there.

▪ In this case, make sure that the device control and the PROFIdrive application are projected in DriveControlSuite and
that a PROFIdrive module has been inserted in TIA Portal.

Information

Parameter A272 in DriveControlSuite provides information about the submodules projected in TIA Portal (display format:
XXX YYY ZZZ; XXX = submodule ID (telegram no.), YYY = TxPZD data length in bytes, ZZZ = RxPZD data length in bytes).
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7.3.7 Testing communication
Check the communication between the controller and drive controllers of your PROFINET network using the diagnostics
buffer of the controller.

ü You have transferred the configuration to the controller.

1. Project tree > Devices tab:
Open the folder of the relevant controller.

2. Double-click Online & diagnostics.

ð This switches you to the respective device view.

3. Select Online access in the area navigation.

4. Online access area:
Click on Go online.

ð An online connection to the selected controller is being established.

5. In the area navigation, select Diagnostics > Diagnostics buffer.

6. Results area:
Check the events in the diagnostics buffer for possible errors and correct their causes if necessary.

ð The connection between the controller and drive controller is projected and a data exchange between the nodes in
the PROFINET network is possible.

Information

If there is an online connection, you can identify which controller you have currently selected using Flash LED if multiple
controllers are located in the same subnet.

Information

Setup of the PROFINET network is complete. As an option, you can continue by programming the acyclical communication
services, as described in Programming acyclical communication services [} 62].
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8 Monitoring and diagnostics
For monitoring purposes and in the event of a fault, the various monitoring and diagnostic options described below are
available.

8.1 Connection monitoring
In order that the drive does not respond in an unwanted manner in the event of an interruption of the PROFINET
connection (cable break, etc.), we recommend monitoring the arrival of cyclical process data.

PROFINET provides the watchdog time (TIA Portal: response monitoring time) for connection monitoring. This time, in
combination with the cycle time (TIA Portal: update time), defines the IO cycle in the controller (IO controller).

The cycle time determines the interval in which data is transmitted from the controller to the drive controller in question
(IO device) and vice versa. It depends on various factors, including the data volume to be transferred, and is generally
calculated in TIA Portal automatically for each drive controller.

The watchdog time corresponds to the number of permitted cycles without a data transfer. In addition to the watchdog
time of the controller, parameter A109 PZD-Timeout can also be activated in DriveControlSuite. At the end of the watchdog
time projected for the controller, the PZD timeout also takes effect in the firmware of the drive controller.

Fault 52: Communication

Cause 4: PZD timeout
A109 PZD-Timeout

Time

Watchdog time

Connection interruption

Old dataValid data

A109 PZD-Timeout

Fig. 6: PROFINET: Connection monitoring

The configured watchdog time runs down as soon as an error has occurred, and then the timeout parameterized in A109.
Once the timeout has also elapsed, the drive controller changes to the Fault device state with the accompanying event 52:
Communication, cause 4: PZD-Timeout.
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8.2 LED display
The drive controllers feature diagnostic LEDs that visualize the state of fieldbus communication and the states of the
physical connection.

8.2.1 PROFINET state
There are 2 LEDs on the front of the drive controller that provide information about the connection between controller and
drive controller and about the state of the data exchange. This information can also be read out in parameter 
A271 PN state.

BF
Run
Psafe

1
2

Fig. 7: LEDs for the PROFINET state

1 Red: BF (bus error)

2 Green: Run

Red LED Conduct Description

Off No error

Rapid flashing Data exchange with controller not
active

On No network connection

Tab. 10: Meaning of the red LED (BF)

Green LED Conduct Description

Off No connection

Single blink Connection is set up to controller

Single blink, inverse Controller activates DHCP signal service

Flashing Existing connection to controller; data
exchange expected

On Existing connection to controller

Tab. 11: Meaning of the green LED (Run)
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8.2.2 PROFINET network connection
The Act. and Link LEDs at X200 and X201 on the top of the device indicate the state of the PROFINET network connection.

Li
nk

Li
nk

X2
00

X2
01

Ac
t

Ac
t

1

2

3

4

Fig. 8: LEDs for the state of the PROFINET network connection

1 Green: Link at X201

2 Yellow: Activity at X201

3 Green: Link at X200

4 Yellow: Activity at X200

Green LED Conduct Description

Off No network connection

On Network connection exists

Tab. 12: Meaning of the green LEDs (Link)

Yellow LED Conduct Description

Off No data exchange

Flashing Active data exchange with controller

Tab. 13: Meaning of the yellow LEDs (Act.)
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8.3 Events
The drive controller has a self-monitoring system that uses test rules to protect the drive system from damage. Violating
the test rules triggers a corresponding event. There is no possible way for you as the user to intervene in some events, such
as the Short/ground event. In others, you can influence the effects and responses.

Possible effects include:

§ Message: Information that can be evaluated by the controller

§ Warning: Information that can be evaluated by the controller and becomes a fault after a defined time span has
elapsed without the cause being resolved

§ Fault: Immediate drive controller response; the power unit is disabled and axis movement is no longer controlled by
the drive controller or the axis is brought to a standstill by a quick stop or emergency braking

Depending on the event, there are various measures you can take to rectify the cause. As soon as the cause has been
successfully rectified, you can usually acknowledge the event immediately. If the drive controller has to be restarted, a
corresponding note can be found in the measures.

ATTENTION!

Damage to property due to interruption of a quick stop or emergency braking!

If, when executing a quick stop or emergency braking, a fault occurs or STO is active, the quick stop or emergency braking is
interrupted. In this case, the machine can be damaged by the uncontrolled axis movement.

Information

To make it easier for control programmers to set up the human-machine interface (HMI), a list of events and their causes
can be found in the STOBER download center at http://www.stoeber.de/en/downloads/ by searching for Events.

http://www.stoeber.de/en/downloads/
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8.3.1 Event 52: Communication
The drive controller has a fault if:

§ A29 = 0: Inactive for Drive Based or PROFIdrive device control

Response:

§ The power unit is disabled and axis movement is no longer controlled by the drive controller

§ The brakes engage

The drive controller has a fault with a quick stop if:

§ A29 = 1: Active for Drive Based or PROFIdrive device control

Response:

§ The axis is stopped by a quick stop

§ During the quick stop, the brakes remain released

§ At the end of the quick stop, the power unit is disabled and axis movement is no longer controlled by the drive
controller

§ The brakes engage

Information

A rising edge for the release override signal (source: F06) is expected in the Switch on disabled, Ready to switch on, and
Switched on states (E48) so that the brake is released.

Cause Check and action

4: PZD-Timeout Missing process data Check the cycle time in the controller and
tolerated failure time for monitoring the PZD
communication in the drive controller and
correct if necessary (A109)

14: PZD parameter figure faulty Missing mapping Check the mapping for unmappable
parameters and correct them if necessary

15: Wrong firmware for
applicataion

Projected fieldbus identification
and that of the drive controller do
not match

Check the projected fieldbus identification and
the fieldbus identification of the drive
controller and change the fieldbus if necessary
(E59[2], E52[3])

16: PROFINET Sign-of-Life
synchronisation failed

Synchronization error Obey the information in the TIA Portal and
update the GSD file if necessary; check the
controller or technology object for clock
synchronicity and correct if necessary

Tab. 14: Event 52 – Causes and actions
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8.4 Parameters
The following diagnostic parameters are available for you in PROFINET communication in combination with SC6 or SI6 series
drive controllers.

8.4.1 A270 | X20x state | G6 | V0
State of the network connection (fieldbus).

§ [0]: X200

• 0: Error

• 1: No connection
No network cable plugged in

• 2: 10 MBit/s
Connection active; transfer rate of 10 Mbps

• 3: 100 MBit/s
Connection active; transfer rate of 100 Mbps, half-duplex

• 4: Link OK
Connection active; transfer rate of 100 Mbps, full-duplex

§ [1]: X201
See [0]: X200

8.4.2 A271 | PN state | G6 | V0
State of the drive controller in the PROFINET network.

§ 0: Offline
Hardware not ready for use

§ 1: Step 1
Hardware ready for use; no connection to the IO controller

§ 2: Step 2
IP address received; connection to the IO controller is set up

§ 3: Phase 1
Drive controller is configured by the IO controller

§ 4: Phase 2
Device start-up of IO controller and drive controller completed; process data communication is started

§ 5: Cyclic data exchange
Process data communication active

§ 6: Configuration Application / PROFINE does not fit
Configuration of the drive controller (projected application) and configuration of the IO controller (projected modules)
is contradictory; check whether the application selected in DriveControlSuite matches the connected module in the TIA
Portal.
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8.4.3 A272 | PN module/submodule | G6 | V1
Display of the IDs and data lengths of the submodules in the PROFINET network (source: IO controller; display format: XXX
YYY ZZZ; XXX = submodule ID (telegram no.), YYY = data length of TxPZD in bytes, ZZZ = data length of RxPZD in bytes).

§ [0] – [4]: Display of submodules

The assignment of elements results from the drive controller type and the configuration in the controller. There is no fixed
assignment of submodules to parameter elements. For single-axis controllers, only element [0] is usually described, since a
slot for a submodule is provided on the controller side for single-axis controllers. For double-axis controllers with two slots,
elements [0] and [1] are usually described. If the drive controller is equipped with the SU6 safety module for PROFIsafe, the
following element contains the information on the safety module. In the PROFIdrive application, a second submodule for an
additional telegram can be configured for each axis. This is displayed after the submodule for the telegram.

Example of double-axis controller with PROFIdrive application and PROFIsafe safety module:

§ [0]: Telegram of axis A

§ [1]: Additional telegram of axis A

§ [2]: Telegram of axis B

§ [3]: Additional telegram of axis B

§ [4]: PROFIsafe

§ [0]: Single-axis controller, double-axis controller axis A

§ [1]: Double-axis controller axis B

8.4.4 A273 | PN device name | G6 | V0
Device name of the drive controller (IO device) in the PROFINET network (source: IO controller).

§ [0] – [2]: Current device name; parts 1 – 3 (additional use: DriveControlSuite connection dialog)

§ [3] – [5]: Device name after the next fieldbus restart; parts 1 – 3

8.4.5 A274 | PN IP address | G6 | V0
IP address of the drive controller in the PROFINET network (source: IO controller).

§ [0]: Current IP address

§ [1]: IP address after the next fieldbus restart

8.4.6 A275 | PN subnet mask | G6 | V0
Subnet mask of the drive controller in the PROFINET network (source: IO controller).

§ [0]: Current subnet mask

§ [1]: Subnet mask after the next fieldbus restart

8.4.7 A276 | PN gateway | G6 | V0
Gateway address of the drive controller in the PROFINET network (source: IO controller).

§ [0]: Current gateway address

§ [1]: Gateway address after the next fieldbus restart
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8.4.8 A279 | PN MAC addresses | G6 | V0
MAC addresses of the drive controller in the PROFINET network.

§ [0]: PROFINET device

§ [1]: X200

§ [2]: X201
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9 More on PROFINET?
The following chapters summarize the key terms, services and relationships relating to PROFINET.

9.1 PROFINET
PROFINET (process field network) is the open industrial Ethernet standard for automation from Siemens, developed in
collaboration with the PROFIBUS-Nutzerorganisation e. V. PROFINET is standardized in IEC 61158 and IEC 61784.

PROFINET is based on Ethernet TCP/IP and is primarily used in cases where fast data communication over Ethernet
networks combined with industrial IT functions are needed.

PROFINET transfers process data (PZD), data for parameterization (parameter channel data), data for diagnostic purposes,
alarms and IT applications – all over a single network.

PROFINET transmits data with and without a real-time request, while process data and alarms are exclusively transferred
using the real-time communication. PROFINET provides two versions in order to scale this optimally: PROFINET RT for
unsynchronized communication and PROFINET IRT for cycle-synchronized real-time communication.

PROFINET follows the provider-consumer model where communication partners are on equal footing. Data can be sent
without a request from another network node. Normally, in the case of a data exchange, a controller (IO controller) reads in
the signals from the drive controllers (IO devices), processes them and provides them back to the drive controllers.

9.2 Device classes
PROFINET classifies network nodes into the following device classes based on their tasks.

IO supervisor (PC)

An IO supervisor is typically a piece of engineering and diagnostics software that can access all process and configuration
data and process alarms or diagnostic messages. The supervisor is normally only integrated into the network on a
temporary basis.

IO controller (controller)

An IO controller controls data communication, i.e. it receives process data and event-controlled messages and processes
them. A programmable logic controller (PLC, e.g. SIMATIC S7-1500) normally handles the role of the IO controller.

IO device (drive controller)

An IO device is typically a decentrally located field device (e.g. a drive controller) that is assigned to at least one 
IO controller.

An IO device transmits process and configuration data as well as alarms. It normally consists of modules that contain the
individual input and output signals of the respective process.
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9.3 Communication
A controller (IO controller) controls and regulates communication with drive controllers (IO devices) in the PROFINET
network. In the process, the controller transmits cyclical process data (PZD), such as control commands, to the drive
controllers and receives current status information from them.

In addition, the controller and drive controller acyclically exchange data that is not time-critical, such as configuration
parameter values or one-time events, using parameter channel data.

Both communication services run in parallel, with transmission of cyclical PZD having higher priority. In each cyclical
exchange of data, an acyclical frame is injected as needed.

Information

It is not possible to write to or read the parameter hidden in DriveControlSuite during communication via fieldbus.

9.3.1 Cyclical communication: Process data
Process data (PZD) is normally data that is required for controlling and observing the ongoing process, such as set positions,
travel velocities or acceleration information. 
It is generally used for data exchange in real time. It also gives you simultaneous access to multiple drive parameters.
Process data is exchanged quickly and cyclically with a high priority over the RT real-time channel.

For PROFINET, the cyclical data traffic relies directly on the MAC address of a device and does not contain any IP addresses.
This keeps the overall length of a data packet relatively small. 
The direction of data flow is of critical importance in this data transfer. From the perspective of the respective nodes, a
distinction is made between receive PZD (RxPZD) and transmit PZD (TxPZD).

The specific communication elements that are sent and received in a specific PZD can be freely selected. The length and
structure of the process data are defined as part of the project configuration by means of the process data modules 
(see Process data modules [} 74]).

Currently, 48 parameter values with a maximum total length of 72 bytes (36 words) can be exchanged between the 
IO controller and IO device per drive controller.

For further information on scaling the process data, see Fieldbus scaling [} 68].

9.3.2 Acyclical communication: Parameter channel data

Information

If you use the example project provided by STOBER for programming acyclical communication services, this chapter is not
relevant in practice.

The parameter channel is used to transfer data that is not time-critical. Parameter channel data enables read and write
access to the configuration parameters of a drive controller and transfers one-time events.

Parameter channel data is transmitted acyclically in ongoing cyclical PROFINET operation, without impairing PZD
communication. This requires drive-specific acyclical communication services. You can either program them based on the
RDREC and WRREC SIMATIC system function blocks (see the following chapters) or load a STOBER-specific example project
specifically tailored to the STOBER drive controllers from the STOBER download area in your TIA Portal and parameterize
the parameters appropriately for your system environment.
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9.3.2.1 RDREC and WRREC: Input and output parameters

In order to transfer acyclical parameter channel data, PROFINET offers the Read record and Write record functions. The
associated interfaces are controlled using the RDREC (read record) and WRREC (write record) SIMANTIC system function
blocks that operate asynchronously.

RDREC and WRREC contain special input and output parameters in a defined sequence. Both blocks communicate with the
IO devices in the network using the input and output parameters described below.

RDREC: Input and output parameters

The RDREC block reads a RECORD out of a hardware component addressed in the ID parameter.

RDREC
EN

REQ

ID

INDEX

MLEN

RECORD LEN

STATUS

ERROR

BUSY

VALID

ENO

= B02E hex

DataHeader “Response”

Fig. 9: RDREC system function block: Input and output parameters

Parameters Data type Declaration

EN BOOL IN Release input

REQ BOOL IN Transfer record (REQ = 1: Start transfer)

ID HW_IO IN Hardware identifier for an IO device; is issued automatically and
can be read out in the device properties (System constants tab),
for example

INDEX DINT IN Record number (the associated value must always be B02E hex)

MLEN UINT IN Maximum length of the record to be transferred

ENO BOOL OUT Release output

VALID BOOL OUT Record was received and is valid

BUSY BOOL OUT Status of the reading (BUSY = 1: still not finished)

ERROR BOOL OUT Status of the reading (ERROR = 1: faulty)

STATUS DWORD OUT Status of the RDREC block or error information

LEN UINT OUT Length of the record that was read

RECORD Variant IN/OUT Record (consisting of header + data, see the chapter RDREC,
WRREC: RECORD [} 70])

Tab. 15: Parameters of the RDREC system function block
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WRREC: Input and output parameters

The WRREC system function block transfers the RECORD to a hardware component addressed in the ID parameter.

WRREC

EN

REQ

ID

INDEX

RECORD STATUS

ERROR

BUSY

DONE

ENO

= B02E hex
DataHeader “Request”

Fig. 10: WRREC system function block: Input and output parameters

Parameters Data type Declaration

EN BOOL IN Release input

REQ BOOL IN Transfer record (REQ = 1: Start transfer)

ID HW_IO IN Hardware ID for an IO device; is issued automatically and can be
read out using TIA Hardware Manager > Device > Properties, for
example

INDEX DINT IN Record number (the associated value must always be B02E hex)

ENO BOOL OUT Release output

DONE BOOL OUT Status of the communication: Record was transferred

BUSY BOOL OUT Status of the writing (BUSY = 1: still not finished)

ERROR BOOL OUT Status of the writing (ERROR = 1: faulty)

STATUS DWORD OUT Status of the WRREC block or error information

RECORD Variant IN/OUT Record (consisting of header + data, see the chapter RDREC,
WRREC: RECORD [} 70])

Tab. 16: Parameters of the WRREC system function block
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9.3.2.2 RDREC and WRREC: Acyclical communication flow

The following diagrams clarify the communication flow of the RDREC and WRREC system function blocks.

Read record flow

1. WRREC [Header Request (Request_ID = 0x01)]

2. RDREC

3. RDREC [Header Response (Response_ID = 0x01) + Data]

3. RDREC [Header Response (Response_ID = 0x81) + Data]

Either
parameter value

or
error

Preparation of 
parameter value

IO controller IO device

Fig. 11: RDREC flow

During RDREC, be aware that each parameter service begins with a read record request and ends with a read record
response.

Write record flow

1. WRREC [Header Request (Request_ID = 0x02) + Data]                             

2. RDREC

3. RDREC [Header Response (Response_ID = 0x02) + Data]

3. RDREC [Header Response (Response_ID = 0x82) + Data]

Either
OK

or
error

Internal 
processing

IO controller IO device

Fig. 12: WRREC flow
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9.3.3 Programming acyclical communication services
To be able to transfer parameters acyclically, PROFINET provides the Read record and Write record services.

The services are controlled using SIMATIC function blocks RDREC and WRREC. You can either integrate this into the PLC
program yourself or load and parameterize one of the example projects provided for download by STOBER in the TIA Portal.

Information

In the context of the latter, observe the documentation belonging to the example projects.

1. To get the latest project version, switch to the download area on the STOBER website http://www.stoeber.de/en/
downloads/ and enter the term TIA Portal in the search field.

ð The TIA Portal Parameter Services (examples for generation 6) project is displayed in the result list.

2. Start the download and save the file to your PC.

3. Unpack the ZIP file.

ð The ZIP file contains a ZAP15_1 file (SAT_Param_Example_V15_1500) for the SIMATIC S7-1500 controller from
Siemens.

4. TIA Portal: 
Select Project > Retrieve and navigate to the directory where you saved the example project.

5. Open the example project.

ð The example project is loaded in the TIA project view.

6. Project tree > Devices tab: 
Open the folder of the controller > Program blocks

7. G6_Read_Acyclic and G6_Write_Acyclic function blocks:
Parameterize the blocks as described in the documentation of the example project.

Information

Specifically for double-axis controllers, note that only one acyclic access per device may be active at the same time! When
using the services in combination with internal function blocks, access coordination must be resolved in the application.

In the example project provided by STOBER, the xLockAcyclic bit coordinates simultaneous acyclical access to a drive
controller. The bit locks the communication for other blocks. Every block that acyclically accesses a drive controller locks
access using the xLockAcyclic bit and enables it again by resetting the bit as soon as the data exchange has ended.

http://www.stoeber.de/en/downloads/
http://www.stoeber.de/en/downloads/
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9.4 Communication protocols

...

HTTP SNMP

DHCP Standard data Real-time
data

TCP/UDP

IP

Real-time
protocol

Fast Ethernet

PROFINET applicationsIT applications

Fig. 13: PROFINET communication protocols

One protocol optimized for fast Ethernet is suitable for real-time communication: the real-time protocol. 
It allows for a high-performance transfer of cyclical real-time data and event-driven messages.

Standard PROFINET data without a real-time request, such as parameter values or diagnostic data, is usually transferred
using the TCP/IP or UDP/IP protocols. For typical IT applications such as the transfer of websites, e-mails, etc., PROFINET
relies on standard IT protocols such as HTTP or SNMP.

9.5 Service communication via PROFINET
Using PROFINET, it is possible to transport any Ethernet data traffic between nodes in a PROFINET network. This is how
STOBER enables service communication between DriveControlSuite and STOBER SC6 and SI6 drive controllers using the
PROFINET network.

The controller (IO controller) is used as a gateway to the Ethernet network, where the IP address, subnet mask and gateway
of the PROFINET nodes are stored. Ethernet data is transmitted acyclically, i.e. the PROFINET real-time properties (process
data communication) remain unaffected.

There are 2 different topologies for service communication via PROFINET:

§ Topology 1
TIA Portal and DriveControlSuite are operated on a PC; only the PROFINET network is used

§ Topology 2
TIA Portal and DriveControlSuite are operated on different PCs; transmission takes place between the PROFINET
network and Ethernet

Information

To be able to use the service communication via PROFINET, DriveControlSuite must be connected with the PROFINET
network and be in the same subnet as TIA Portal.

If you assign the IP address to the drive controller in non-volatile memory, DriveControlSuite can find the drive controller
even without the controller.
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9.6 Ethernet network addressing
All nodes in the PROFINET network are based on the Industrial Ethernet Standard, meaning that the assignment of the
following addresses and names is important to be able to communicate with drive controllers in the PROFINET IO system.

9.6.1 MAC address
Each network interface of a device in an Ethernet network requires its own address – a MAC address. The MAC address is
used as a source and destination address for cyclical data exchange.

A MAC address consists of a fixed and a variable part. The fixed part identifies the manufacturer (3 bytes) and the variable
part distinguishes the individual Ethernet nodes and must be globally unique (also 3 bytes). A MAC address can only
communicate between two nodes of the same subnet.

The MAC addresses of the interfaces are issued by STOBER and cannot be changed.

Information

The MAC address range of the STOBER hardware is: 00:11:39:00:00:00 – 00:11:39:FF:FF:FF

You can read out the MAC address of the PROFINET interface using parameter A279 PN MAC addresses.

9.6.2 IP address
Each PROFINET node has to support various Ethernet-based protocols, at least TCP/IP and UDP/IP.

All data packets sent over the IP protocol contain the respective recipient and sender addresses. Consequently, each
PROFINET node needs a unique IP address to be able to receive communication.

The IP protocol is hardware-independent; unlike the fixed MAC address, the IP address is explicitly assigned to each drive
controller.

The IP address is for acyclical data exchange, e.g. transferring the configuration to the controller, configuring the drive
controllers and reading out device and diagnostic information.

An IPv4 address consists of 4 decimal numbers from the value range 0 – 255 separated by a decimal.

Read out the IP address of a drive controller using parameter A274 PN IP address.

9.6.3 Subnet mask
An IP address always consists of a network ID (for identifying the network) and a host ID (for identifying the node). A subnet
mask defines which parts of the IP address are assigned to the network ID. It has the structure of the IP address but only
marks the network ID.

Read out the subnet mask using the A275 PN subnet mask parameter.
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9.6.4 Subnets and gateways
The IP addresses of a network are usually subdivided into subnets. The purpose of subnets is to provide autonomous
networks with an address range. All PROFINET nodes connected by switches are in a subnet, meaning that they
communicate over a direct path. All nodes of a subnet have the same subnet mask.

Gateways are components of a subnet and are responsible for forwarding subnet-specific network queries to other
subnets.

Information

Be aware that real-time communication is only possible within a subnet due to addressing with MAC addresses. It is not
possible to use routers for real-time communication via PROFINET.

9.6.5 MAC and IP addressing using device names
To be able to provide unique identification of a drive controller (IO device) in a PROFINET IO system, it must have a symbolic
device name that is unique in the system. It is assigned during the project planning phase in TIA Portal and then transferred
to the drive controllers. The device name is used for parameterizing the individual drive controllers during system start-up
and assigning the respective MAC and IP addresses, the latter using DCP or DHCP.

Observe the following conventions when specifying device names:

§ The device name must be limited to a maximum of 240 characters. 
Letters, numbers, periods and dashes are permitted.

§ A name component, i.e. a character string between 2 periods, may be a maximum of 63 characters long.

§ Special characters like umlauts, brackets, question marks, slashes, spaces, etc. are not allowed.

§ The device name may not begin with numbers.

§ The device name may neither begin nor end with a minus sign (−) or a period (.).

§ The device name may not take the form n.n.n.n (n = 0 – 999).

§ The device name may not begin with the character sequence port-xyz- (x, y, z = 0 – 9).

§ Underscores (_) are not allowed.

9.7 Cycle times
Possible cycle times can be found in the following table.

Type Cycle times Relevant parameters

PROFINET RT fieldbus, cyclical
communication

1 ms, 2 ms, 4 ms, 8 ms Adjustable in the TIA Portal

PROFINET IRT fieldbus, cyclical
communication

1 ms, 2 ms, 4 ms Adjustable in the TIA Portal

Tab. 17: Cycle times
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9.8 Activating and executing actions
To be able to activate and execute actions via fieldbus, you must first enable action activation in DriveControlSuite and
extend the process data by the control byte and status word for actions.

Enabling action activation

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Application PROFIdrive wizard > Additional functions.

3. Enable the Action activation option.

4. Repeat the steps for axis B (only for double-axis controllers).

Adjusting receive process data

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the PROFINET wizard > Received process data RxPZD.

3. A90[0] – A90[23], A91[0] – A91[23]:
Add the control byte for activating actions to the receive process data.
Single-axis controller: Add 1.A75.
Double-axis controller: Add 1.A75 for axis A and 2.A75 for axis B.

Adjusting transmit process data

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the PROFINET wizard > Transmitted process data TxPZD.

3. A94[0] – A94[23], A95[0] – A95[23]:
Add the status word for activating actions to the transmit process data.
Single-axis controller: Add 1.A69.
Double-axis controller: Add 1.A69 for axis A and 2.A69 for axis B.

Executing an action

Then execute the desired action. Here, take into account any prerequisites with regard to the device state as well as any
further measures required after the start of the action. All prerequisites as well as more detailed information on the
individual actions can be found in the corresponding parameter descriptions in DriveControlSuite.
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Selecting an action Establishing the device
state

Starting an
action

Executing the next
step

Completing an action
(by progress = 100%)

0001 bin =
Save values (A00)

— Execute
(A75, bit 0 =1)

— Undo execute
(A75, bit 0 = 0)

0011 bin =
Reset memorized values
(A37)

0111 bin =
Clear reference (I38)

1000 bin =
Delete limit switch
memory (I52)

0010 bin =
Restart (A09)

E48 ≠ 4: Enabled +
E48 ≠ 7: Quick stop

Execute
(A75, bit 0 =1)

— Undo execute
(A75, bit 0 = 0)

1101 bin =
Test winding (B43)

E48 = 2: Ready for
switch-on

Execute
(A75, bit 0 =1)

— Undo execute
(A75, bit 0 = 0)

1010 bin =
Test phase (B40)

E48 = 2: Ready for
switch-on

Execute
(A75, bit 0 =1)

Enable drive controller
(E48 = 4: Enabled)

Undo execute
(A75, bit 0 = 0) +
Undo enable1011 bin =

Calibrate motor (B41)

1100 bin =
Optimize current
controller (B42)

1110 bin =
Optimize current
controller (standstill)
(B49)

0100 bin =
Test brake (B300)

0101 bin =
Grind brake (B301)

0110 bin =
Brake 2 grind (B302)

1001 bin =
Test brake (S18)

Tab. 18: Selecting and executing an action
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9.9 Fieldbus scaling
Use parameter A100 in the DriveControlSuite commissioning software to define the scaling for the cyclical transmission of
process data in the PROFINET network. The values are either converted and represented as an integer or transmitted as a
raw value without scaling according to their data types. The acyclical transmission of the parameter channel data is defined
by the attributes of the parameter channel (see Attribute and format elements: Possible combinations [} 73]). The values
are also either transmitted as an integer or without scaling.

Regardless of the selected settings or attributes in parameter A100, the configuration as well as the firmware both work
exclusively with raw values. The following graphic shows an overview of fieldbus scaling.

A100

Fieldbus

PZD
(cyclical)

Parameter channel
data

(acyclical)

Raw value

Firmware

Configuration

Integer

Scaling

Parameter channel
attributes

Fig. 14: Overview of fieldbus scaling

For transmission as an integer, the number of decimal places can be defined for all parameters that affect positions,
velocities, accelerations, decelerations and jerk. For all other parameters, the number of decimal places is fixed. The values
for scaling are output in DriveControlSuite with the properties of a parameter. The following table lists the parameters
which you can use to define the number of decimal places for scaled transmission.

Scaling Axis model Master axis model

Position I06 G46

Velocity I66 G66

Acceleration, deceleration, jerk I67 G67

Tab. 19: Fieldbus scaling for integer: Parameters for defining the decimal places
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10 Appendix

10.1 Addressing parameters for RECORD record
To be able to address a parameter via fieldbus, you need its Axis_number, Parameter_number and subindex. These are
calculated from the STOBER parameter coordinates (axis, group, line, element).

For basic information on the parameters, see Meaning of parameters [} 19].

10.1.1 Determining the Axis_number
The Axis_number corresponds to the axis of the parameter.

10.1.2 Calculating the Parameter_number

Information

Note that the Parameter_number in the RECORD record must be specified in hexadecimal form.

The Parameter_number is calculated from the group and line of the parameter according to the following formula:

Parameter_number decimal = 8192 + (number of the group × 512) + number of the line

Calculation example for parameter E200 (number of the group = 4 , 
number of the line = 200):
Parameter_number E200 = 8192 + (4 × 512) + 200 = 10440 = 28C8 hex

Group Number Addressable parameters

A: Drive controller 0 A00 – A511

B: Motor 1 B00 – B511

C: Machine 2 C00 – C511

D: Target value 3 D00 – D511

E: Display 4 E00 – E511

F: Terminals 5 F00 – F511

G: Technology 6 G00 – G511

H: Encoder 7 H00 – H511

I: Motion 8 I00 – I511

J: Motion blocks 9 J00 – J511

K: Control panel 10 K00 – K511

M: Profile 12 M00 – M511

P: Customer-specific parameters 15 P00 – P511

Q: Customer-specific parameters, instance-dependent 16 Q00 – Q511

R: Production data 17 R00 – R511

S: Safety 18 S00 – S511

T: Scope 19 T00 – T511

U: Safety functions 20 U00 – U511

Z: Fault counter 25 Z00 – Z511

Tab. 20: Groups and parameters
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10.1.3 Determining the subindex
The subindex corresponds to the element of the array or record parameter. The subindex of simple parameters is 0.

10.2 RDREC, WRREC: RECORD

10.2.1 WRREC: RECORD request: Header structure
Parameter values are generally transferred using the RECORD header. For a RECORD request, the header consists of the
following elements in the specified sequence.

Element Data type Value, value range

Request_reference BYTE 0 hex – FF hex Freely selectable request number

Request_ID BYTE 1 hex Read request

2 hex Write request

All other values Reserved

Axis_number BYTE 0 – 3 Addressing the axis

Number_of_parameters BYTE 1 Number of parameters to be processed

All other values Reserved

Attributes BYTE 10 hex Access type: Value

80 hex Access type: Raw value

81 hex Access type: Integer

82 hex Access type: Floating point

Number_of_elements BYTE 1 – 32 hex 1 – 50 Parameters are to be written or read

Parameter_number WORD 2000 hex – 5FFF hex Group and line of a parameter

Subindex WORD 0 – 3E80 hex Element of an array and record parameter; in
single parameters, the value = 0

Format
(Condition: Request_ID = 2 hex)

BYTE 8 hex Transfer format: FLOAT

41 hex Transfer format: BYTE

42 hex Transfer format: WORD

43 hex Transfer format: DWORD

1C hex, 1D hex, 1E hex Transfer format: STRING with 8, 16 or 80
characters

Number_of_values
(Condition: Request_ID = 2 hex)

BYTE 1 – 50 Number of values to be processed; 
value = 1 (in a simple parameter) or value =
value of Number_of_elements; 
since a RECORD request may not exceed a
length of 240 bytes, it is not always possible –
depending on the respective format – to
transfer max. 50 elements

1st value
(Condition: Request_ID = 2 hex)

DINT 1st parameter value Value in a simple parameter

2nd value – 50th value
(Condition: Request_ID = 2 hex)

DINT 1 – 32 hex Value = Value of Number_of_elements

Tab. 21: WRREC: RECORD request: Header structure
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10.2.2 RDREC: RECORD response: Header structure
Parameter values are generally transferred using the RECORD header. For a RECORD response, the header consists of the
following elements in the specified sequence.

Element Data type Value, value range

Response_reference BYTE 0 hex – FF hex Value = Request number of RECORD request

Response_ID BYTE 1 hex Positive answer to a read request

2 hex Positive answer to a write request

81 hex Negative answer to a read request

82 hex Negative answer to a write request

Axis_number BYTE 0 – 3 Addressing the axis

Number_of_parameters BYTE 1 Number of parameters to be processed

Format BYTE 8 hex Transfer format: FLOAT

41 hex Transfer format: BYTE

42 hex Transfer format: WORD

43 hex Transfer format: DWORD

1C hex, 1D hex, 1E hex Transfer format: STRING with 8, 16 or 80
characters

44 hex Error in case of error

Number_of_values BYTE 1 Number of values to be processed

1st value or 
error code

DINT 1st parameter value Value in a simple parameter

WORD Error code in case of error (see table RDREC,
WRREC: Error codes [} 72])

2nd value – 50th value DINT 1 – 32 hex Value = Value of Number_of_elements

Tab. 22: RDREC: RECORD response: Header structure
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10.2.3 RDREC, WRREC: Error codes
The following table shows the possible error codes for the RDREC and WRREC system function blocks.

Error code Cause

0 hex Parameter unfamiliar or configuration stopped

1 hex Access to read-only parameter

2 hex Access to parameter with value outside the limit

3 hex Access to unavailable subindex (array parameter)

B hex User level not reached

11 hex Parameter may not be changed in the current device state; deactivate release

14 hex Invalid value within maximum limits; only occurs in the case of selection parameters with a broken
definition range

16 hex One or more incorrect values in the attribute, Number_of_elements, Parameter_number and subindex
elements

17 hex Invalid format specification

18 hex Contrary value in the Number_of_elements and Number_of_values elements

21 hex Invalid Request_ID = Service not supported; applies to errors in the header of the request block

A5 hex Error cannot be specified in more detail

B0 hex Parameter service currently not possible or valid parameter description not present

B2 hex Unfamiliar parameter address (parameter or element does not exist)

B3 hex Read/write access not possible for specified parameter address

B9 hex Parameter service: Value in definition gap (observe ENUM list)

BA hex Parameter service: Clash with other values

C0 hex Parameter service: Error in pre-read function

C1 hex Parameter service: Error in post-write function; value has already been received

Tab. 23: RDREC, WRREC: Error codes
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10.2.4 Attribute and format elements: Possible combinations
The attribute element describes the access to a parameter structure (e.g. to values, descriptive texts, etc.); the format
element describes the transfer format of a parameter. The values of both elements can be combined as follows.

Attribute Format

FLOAT 
(8 hex)

BYTE 
(41 hex)

WORD 
(42 hex)

DWORD 
(43 hex)

STRING
(1C hex, 1D hex,
1E hex)

Value 
(10 hex)

Not permitted Not permitted Not permitted Scaled value for all
parameters
represented as
integer (4 bytes)

8, 16 or 80
characters

Raw value 
(80 hex)

Unscaled raw
value, specifically
for FLOAT data type
(4 bytes)

Unscaled raw
value, specifically
for BOOL, WORD,
I8 data types
(1 byte)

Unscaled raw
value, specifically
for WORD, I16 data
types 
(2 bytes)

Unscaled raw
value, specifically
for DWORD, I32
data types 
(4 bytes)

Not permitted

Integer 
(81 hex)

Not permitted Not permitted Not permitted Scaled value for all
parameters
represented as
integer (4 bytes)

Not permitted

Floating
point 
(82 hex)

Scaled
representation for
all parameters as
floating point
(4 bytes)

Not permitted Not permitted Not permitted Not permitted

Tab. 24: Attribute, format: Possible combinations
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10.3 Process data modules
Process data modules determine the data volume for the PZD transmission. During configuration in TIA Portal, one of the
following process data modules must be configured for each axis of the drive controller. When creating a new project, we
recommend the all consistent transfer type.

Module Input data [byte] Output data [byte] Transfer

M101 02W PZD
all cons.

4 4 2 words (inputs, outputs),
all consistent*

M102 04W PZD
all cons.

8 8 4 words (inputs, outputs),
all consistent

M103 06W PZD
all cons.

12 12 6 words (inputs, outputs),
all consistent

M104 12W PZD
all cons.

24 24 12 words (inputs, outputs),
all consistent

M105 18W PZD
all cons.

36 36 18 words (inputs, outputs),
all consistent

M106 24W PZD
all cons.

48 48 24 words (inputs, outputs),
all consistent

M107 36W PZD
all cons.

72 72 36 words (inputs, outputs),
all consistent

M111 02W PZD
Item cons.

4 4 2 words (inputs, outputs),
Items consistent**

M112 04W PZD
Item cons.

8 8 4 words (inputs, outputs),
Items consistent

M113 06W PZD
Item cons.

12 12 6 words (inputs, outputs),
Items consistent

M114 12W PZD
Item cons.

24 24 12 words (inputs, outputs),
Items consistent

M115 18W PZD
Item cons.

36 36 18 words (inputs, outputs),
Items consistent

M116 24W PZD
Item cons.

48 48 24 words (inputs, outputs),
Items consistent

M117 36W PZD
Item cons.

72 72 36 words (inputs, outputs),
Items consistent

Tab. 25: Process data modules

*) all consistent: Process data packet is processed once the packet has been fully received

**) Items consistent: Individual parameters of the packet are processed once the parameter has been fully received
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10.4 Detailed information
The documentation listed below provides you with further relevant information on the 6th STOBER drive controller
generation. The current status of the documentation can be found in our download center at:
http://www.stoeber.de/en/downloads/.
Enter the ID of the documentation in the search field.

Title Documentation Contents ID

SC6 drive controller Manual System design, technical data,
project configuration, storage,
installation, connection,
commissioning, operation, service,
diagnostics

442790

Multi-axis drive system 
with SI6 and PS6

Manual System design, technical data,
project configuration, storage,
installation, connection,
commissioning, operation, service,
diagnostics

442728

Drive Based application (DB) 
– SC6, SI6

Manual Project configuration,
configuration, parameterization,
function test, detailed information

443437

PROFIdrive application – SC6, SI6 Manual Project configuration,
configuration, parameterization,
function test, detailed information

443270

Additional information and sources that form the basis of this documentation or are referenced by the documentation:

Information concerning PROFINET

You can find general information on PROFINET on the PROFIBUS & PROFINET International (PI) website at 
http://www.profibus.com. PROFINET-specific guidelines, profiles, presentations, brochures and software are available in
the corresponding download area.

Information concerning the Siemens TIA Portal

The most important information about the Siemens TIA Portal and additional documents, links and training courses can be
found at 
http://www.industry.siemens.com/topics/global/en/tia-portal/pages/default.aspx.

SC6, SI6 – Device description

A GSD file for easily integrating the drive controllers of the SC6 and SI6 series into the respective system environment can
be found in the STOBER download center http://www.stoeber.de/en/downloads/, search term GSD.

STOBER TIA Portal example projects – Programming acyclical communication services

STOBER-specific example projects along with the accompanying documentation for programming acyclical communication
services in TIA Portal can be found in the STOBER download center http://www.stoeber.de/en/downloads/ using the search
term TIA Portal.

http://www.stoeber.de/en/downloads/
http://www.profibus.com
http://www.industry.siemens.com/topics/global/en/tia-portal/pages/default.aspx
http://www.stoeber.de/en/downloads/
http://www.stoeber.de/en/downloads/
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10.5 Abbreviations

Abbreviation Meaning

BF Busfehler (Bus error)

CBA Component Based Automation

CPU Central Processing Unit

DCP Discovery and Configuration Protocol

DHCP Dynamic Host Configuration Protocol

DP Decentral peripherals

EMC Electromagnetic Compatibility

GSD General Station Description data

GSDML General Station Description Markup Language

HMI Human Machine Interface

HTTP Hypertext Transfer Protocol

IEC International Electrotechnical Commission

IEEE Institute of Electrical and Electronics Engineers

I/O Input/Output

IP Internet Protocol

IRT Isochronous Real-Time

LAN Local Area Network

LSB Least Significant Bit

MAC Media Access Control

PG Programmiergerät (programming device)

PROFIBUS Process Field Bus

PROFINET Process Field Network

PZD Prozessdaten (process data)

RDREC Read Record

RT Real-Time

RxPZD Receive PZD (receive process data)

SNMP Simple Network Management Protocol

PLC Programmable Logic Controller

TIA Totally Integrated Automation

TCP Transmission Control Protocol

TxPZD Transmit PZD (transmit process data)

UDP User Data Protocol

WRREC Write Record
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11 Contact

11.1 Consultation, service and address
We would be happy to help you!

We offer a wealth of information and services to go with our products on our website:
http://www.stoeber.de/en/service

For additional or personalized information, contact our consultation and support service:
http://www.stoeber.de/en/support

If you need our system support:
Phone +49 7231 582-3060
systemsupport@stoeber.de

If you need a replacement device:
Phone +49 7231 582-1128
replace@stoeber.de

Call our 24-hour service hotline:
Tel. +49 7231 582-3000

Our address:
STÖBER Antriebstechnik GmbH + Co. KG
Kieselbronner Strasse 12
75177 Pforzheim, Germany

11.2 Your opinion is important to us
We created this documentation to the best of our knowledge with the goal of helping you build and expand your expertise
productively and efficiently with our products.

Your suggestions, opinions, wishes and constructive criticism help us to ensure and further develop the quality of our
documentation.
If you want to contact us for a specific reason, we would be happy to receive an e-mail from you at:
documentation@stoeber.de

Thank you for your interest.
Your STOBER editorial team

http://www.stoeber.de/en/service
http://www.stoeber.de/en/support
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11.3 Close to customers around the world
We offer you committed, expert advise and support in over 40 countries worldwide:

STOBER AUSTRIA
www.stoeber.at
+43 7613 7600-0
sales@stoeber.at

STOBER CHINA 
www.stoeber.cn 
+86 512 5320 8850
sales@stoeber.cn

STOBER FRANCE 
www.stober.fr 
+33 478 98 91 80 
sales@stober.fr

STOBER Germany 
www.stoeber.de 
+49 4 7231 582-0
sales@stoeber.de

STOBER HUNGARY 
www.stoeber.de 
+36 53 5011140
info@emtc.hu

STOBER ITALY 
www.stober.it 
+39 02 93909570 
sales@stober.it

STOBER JAPAN 
www.stober.co.jp 
+81-3-5875-7583
sales@stober.co.jp

STOBER SWITZERLAND 
www.stoeber.ch 
+41 56 496 96 50 
sales@stoeber.ch

STOBER TAIWAN 
www.stober.tw 
+886 4 2358 6089 
sales@stober.tw

STOBER TURKEY 
www.stober.com 
+90 216 510 2290 
sales-turkey@stober.com

STOBER UK 
www.stober.co.uk 
+44 1543 458 858 
sales@stober.co.uk

STOBER USA 
www.stober.com 
+1 606 759 5090 
sales@stober.com
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Glossary

100Base-TX

Ethernet network standard based on symmetrical copper cables in which the nodes are connected to a switch via
copper cables twisted in pairs (shielded twisted pair, CAT 5e quality level). 100Base-TX is the subsequent progression
from 10Base-T and includes those properties with the option of a transfer speed of 100 Mbps (Fast Ethernet).

Application class (AC)

Standardized drive functions according to the PROFIdrive device profile. In view of its wide range of possible
applications, six classes specified according to functionality have been defined for PROFIdrive. A drive can cover one or
more classes.

Broadcast domain

Logical grouping of network devices within a local network that reaches all nodes via broadcast.

Function block

Functional software unit that includes a named copy of a data structure and associated operations defined by a
corresponding function block type.

GSD file

Includes the technical features of a PROFINET IO device (type, configuration data, parameters, diagnostic information,
etc.) in XML format in accordance with the GSDML specification. A GSD file serves as the configuration basis for project
configuration systems and is generally provided by the respective device manufacturer.

i²t model

Computational model for thermal monitoring.

IO controller

Generally, a programmable logic controller that controls automation tasks and regulates data communication.

IO device

A decentralized field device that is assigned logically to a PROFINET IO controller that manages and controls it. 
An IO device consists of multiple modules and submodules.

IO supervisor

Generally, engineering software that can access all process and configuration data. An IO supervisor is only engaged
temporarily for parameterizing the IO devices, commissioning the IO system and for diagnostic purposes.

IPv4 limited broadcast

Type of broadcast in a network with IPv4 (Internet Protocol version 4). The IP address 255.255.255.255 is entered as
the destination. The content of the broadcast is not forwarded by a router, which limits it to the local network.
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MAC address

Hardware address for unique identification of a device in an Ethernet network. The MAC address is assigned by the
manufacturer and consists of a 3-byte manufacturer ID and 3-byte device ID.

Process data (PZD)

Control and status information that is time-critical and transmitted in the PROFINET network cyclically using telegrams.
Depending on the view of the respective node, a distinction is made between receive PZD (RxPZD) and transmit PZD
(TxPZD).

PROFIdrive

Standardized drive interface for PROFIBUS and PROFINET open standard buses. It defines the device behavior and
procedure for accessing internal device data for electrical drives on PROFINET and PROFIBUS. The interface is specified
by PROFIBUS and PROFINET International (PI) user organizations, and is specified as the future-proof standard by
standard IEC 61800-7-303.

PROFINET

Open Ethernet standard of PROFIBUS Nutzerorganisation e. V. (PNO) for automation.

PROFINET IRT

Transmission method for high-precision as well as synchronized processes in a PROFINET IO system.

PROFINET RT

Transmission method for time-critical process data in a PROFINET IO system.

PROFIsafe

Communication standard for safety standard IEC 61508 that includes both standard as well as fail-safe communication.
The standard enables reliable communication for PROFIBUS and PROFINET open standard buses based on standard
network components, and is defined as the international standard in standard IEC 61784-3-3.

Receive PZD (RxPZD)

Process data received by a node in the PROFINET network.

Siemens telegram

Data with specified sequence and standardized contents that is exchanged cyclically between the controller and drive
controller during PROFIdrive communication. The standard telegram is structured according to the manufacturer-
specific specifications from Siemens.

Standard telegram

Data with specified sequence and standardized contents that is exchanged cyclically between the controller and drive
controller during PROFIdrive communication. The standard telegram is structured according to the PROFIdrive device
profile.
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System function block (Siemens)

Logic block as part of a distributed, structured Siemens user program used to call up important system functions for
PROFINET IO. Parameters for the associated input and output interfaces can be configured individually. The variable
values stored in a function block are saved and are not lost after processing. Typical Siemens system function blocks
are WRREC (Write record) and RDREC (Read record).

TCP/IP

Protocol family composed of the transmission control protocol (TCP) and the Internet protocol (IP). TCP is responsible
for transmission, i.e. actual data traffic; IP handles unique communication with a PC in a network.

Technology object (TO)

Software object in a Siemens controller that represents a mechanical component. It encapsulates the technological
functionality and allows uniform configuration and parameterization.

Transmit PZD (TxPZD)

Process data sent by a node.

UDP/IP

Minimalist transport protocol for networks such as LAN that only provides the essential functions for data transport.
UDP/IP is a simple service that functions without a continuous connection on both sides. There is no connection or
disconnection and no acknowledgment of the received data packets. There is the option to control data traffic using a
checksum. As with TCP/IP, there are no troubleshooting mechanisms. Therefore, it is entirely possible for the
transferred data to experience data loss, data duplication or sequence errors.
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