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1 Foreword
The DriveControlSuite commissioning software for 6th generation drive controllers offers convenient functions for efficient
project configuration and commissioning of drive controllers in multi-axis and single-axis applications.

The Drive Based application contained in the software provides universal solutions for drive-based motion control using
position, velocity and torque/force control types. The motion commands associated with these control types are
categorized into the following operating modes:

§ Command

§ Motion block

§ Velocity, torque/force

The Drive Based application enables you to implement a wide range of applications in the various operating modes, e.g. the
simple operation of pumps, fans or presses, or complex movements coordinated by a control system.

Additional functions for monitoring process variables such as positions or velocities offer added convenience in monitoring.

This documentation describes the general functions of the Drive Based application and guides you step by step through the
setup and project configuration of your drive project in the individual operating modes.
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2 User information
This documentation supports you in the setup and project configuration of your drive system with the Drive Based
application in conjunction with Drive Based device control.

Technical knowledge

To be able to commission one or more drive controllers using the Drive Based application, possibly in combination with a
controller, you should have basic knowledge of handling 6th generation STOBER drive controllers and of the
DriveControlSuite commissioning software.

Technical requirements

Before you begin operating your drive system, you need to have wired the drive controllers involved and initially check that
they are functioning correctly. To do this, follow the instructions in the manual for the relevant drive controller.

2.1 Storage and transfer
As this documentation contains important information for handling the product safely and efficiently, it must be stored in
the immediate vicinity of the product until product disposal and be accessible to qualified personnel at all times.

Also pass on this documentation if the product is transferred or sold to a third party.

2.2 Described product
This documentation is binding for:

SD6 series drive controllers in conjunction with the DriveControlSuite software (DS6) in V 6.5-L or later and associated
firmware in V 6.5-L or later.

2.3 Directives and standards
Refer to the drive controller documentation for the European directives and standards relevant to the drive controller and
accessories.

2.4 Timeliness
Check whether this document is the latest version of the documentation. We make the latest document versions for our
products available for download on our website:
http://www.stoeber.de/en/downloads/.

2.5 Original language
The original language of this documentation is German; all other language versions are derived from the original language.

2.6 Limitation of liability
This documentation was created taking into account the applicable standards and regulations as well as the current state of
technology.

No warranty or liability claims for damage shall result from failure to comply with the documentation or from use that
deviates from the intended use of the product. This is especially true for damage caused by individual technical
modifications to the product or the project configuration and operation of the product by unqualified personnel.

http://www.stoeber.de/en/downloads/
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2.7 Formatting conventions
Orientation guides in the form of signal words, symbols and special text markups are used to emphasize specific
information so that you are able identify it in this documentation quickly.

2.7.1 Display of warning messages and information
Warning messages are identified with symbols. They indicate special risks when handling the product and are accompanied
by relevant signal words that express the extent of the risk. Furthermore, useful tips and recommendations for efficient,
error-free operation are specially highlighted.

ATTENTION!

Attention

This indicates that damage to property may occur

▪ if the stated precautionary measures are not taken.

CAUTION!

Caution

This word with a warning triangle indicates that minor personal injury may occur

▪ if the stated precautionary measures are not taken.

WARNING!

Warning

This word with a warning triangle means there may be a considerable risk of fatal injury

▪ if the stated precautionary measures are not taken.

DANGER!

Danger

This word with a warning triangle indicates that there is a considerable risk of fatal injury

▪ if the stated precautionary measures are not taken.

Information

Information indicates important information about the product or serves to emphasize a section in the documentation that
deserves special attention from the reader.
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2.7.2 Markup of text elements
Certain elements of the continuous text are distinguished as follows.

Important information Words or expressions with a special meaning

Interpolated position mode Optional: File or product name or other name

Detailed information Internal cross-reference

http://www.samplelink.com External cross-reference

Software and other displays

The following formatting is used to identify the various information content of elements referenced by the software
interface or a drive controller display, as well as any user entries.

Main menu 
Settings

Window names, dialog box names, page names or buttons, combined
proper nouns, functions referenced by the interface

Select 
Referencing method A

Predefined entry

Save your 
<own IP address>

User-defined entry

EVENT 52: 
COMMUNICATION

Displays (status, messages, warnings, faults)

Keyboard shortcuts and command sequences or paths are represented as follows.

[Ctrl], [Ctrl] + [S] Key, key combination

Table > Insert table Navigation to menus/submenus (path specification)

2.7.3 Mathematics and formulas
The following signs are used to represent mathematical relationships and formulas.

– Subtraction

+ Addition

× Multiplication

÷ Division

| | Absolute value

http://www.stoeber.de


STOBER 2 | User information
04

/2
02

4 
| 

ID
 4

42
70

6.
03

9

2.8 Trademarks
The following names used in connection with the device, its optional equipment and its accessories are trademarks or
registered trademarks of other companies:

CANopen®, 
CiA®

CANopen® and CiA® are registered European Union trademarks of CAN in
AUTOMATION e.V., Nuremberg, Germany.

EnDat® EnDat® and the EnDat® logo are registered trademarks of Dr. Johannes Heidenhain
GmbH, Traunreut, Germany.

EtherCAT®,
Safety over EtherCAT®,
TwinCAT®

EtherCAT®, Safety over EtherCAT® and TwinCAT® are registered trademarks of
patented technologies licensed by Beckhoff Automation GmbH, Verl, Germany.

PLCopen® PLCopen® is a registered trademark of the PLCopen Organisation, Gorinchem,
Netherlands.

PROFIBUS®, 
PROFINET®

PROFIBUS® and PROFINET® are registered trademarks of PROFIBUS
Nutzerorganisation e.V., Karlsruhe, Germany.

All other trademarks not listed here are the property of their respective owners.

Products that are registered as trademarks are not specially indicated in this documentation. Existing property rights
(patents, trademarks, protection of utility models) are to be observed.
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3 Safety notes

WARNING!

Risk of fatal injury if safety notes and residual risks are not observed!

Failure to observe the safety notes and residual risks in the drive controller documentation may result in accidents causing
serious injury or death.

▪ Observe the safety notes in the drive controller documentation.

▪ Consider the residual risks in the risk assessment for the machine or system.

WARNING!

Malfunction of the machine due to incorrect or modified parameterization!

In the event of incorrect or modified parameterization, malfunctions can occur on machines or systems which can lead to
serious injuries or death.

▪ Observe the security notes in the drive controller documentation.

▪ Protect the parameterization, e.g. from unauthorized access.

▪ Take appropriate measures for possible malfunctions (e.g. emergency off or emergency stop).
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4 What you should know before commissioning
The following chapters provide a quick introduction to the structure of the program interface and accompanying window
designations as well as relevant information about parameters and generally saving your project configuration.

4.1 DS6 program interface
Using the graphical interface of the DriveControlSuite commissioning software (DS6), you can project, parameterize and
commission your drive project quickly and efficiently. In case of service, you can evaluate diagnostic information such as
operating states, fault memories and fault counters of your drive project using DriveControlSuite.

Information

The program interface of DriveControlSuite is available in German, English and French. To change the language of the
program interface, select Settings > Language.

Information

The DriveControlSuite help in the menu bar can be reached via Help > Help for DS6 or via the [F1] key on your keyboard.
When you press [F1] in an area of the program, the corresponding help topic opens.
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Fig. 1: DS6: Program interface

No. Area Description

1 Menu bar Using the File, View, Settings and Window menus, you can open and save projects, display
and hide program windows, select the interface language and access level and change
between different windows in the workspace.

2 Toolbar The toolbar enables quick access to frequently needed functions, like opening and saving
projects and hiding and displaying windows in the program interface.

3 Project tree The project tree forms the structure of your drive project in the form of modules and drive
controllers. Select an element using the project tree first in order to edit it using the
project menu.

4 Project menu The project menu offers you various functions for editing the project, module and drive
controller. The project menu adapts to the element that you selected in the project tree.

5 Workspace The different windows which can be used to edit your drive project, such as the
configuration dialog, wizards, the parameter list or the scope analysis tool, open in the
workspace.

6 Parameter check The parameter check points out irregularities and inconsistencies that were detected in
the plausibility check of calculable parameters.

7 Messages The entries in the messages log the connection and communication status of the drive
controllers, incorrect inputs caught by the system, errors when opening a project or rule
violations in the graphical programming.

8 Variable parameter
lists

You can use variable parameter lists to compile any parameters in individual parameter
lists for a quick overview.

9 Status bar In the status bar, you can find the specifications of the software version and get additional
information about the project file, the devices and the progress of the process during
processes such as loading projects.
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4.1.1 Configuring the view
In DriveControlSuite, you can change the visibility and arrangement of areas and windows, such as to optimize the available
space in the workspace when working with smaller screens.

Showing/hiding areas

Use the icons in the toolbar or the items in the View menu to show or hide specific areas in DriveControlSuite as needed.

Icon Item Description

– Reset Resets the view to factory settings.

Project Shows/hides the Project window (project tree, project
menu).

Messages Shows/hides the Messages window.

Parameter check Shows/hides the Parameter check window.

Variable parameter lists Shows/hides the Variable parameter lists window.

Arrange and group areas

You can undock and rearrange the individual areas via drag and drop. If you drag an undocked window to the edge of
DriveControlSuite, you can release it there in a color-highlighted area either next to or on top of another window to redock
it.

When you release the window onto another window, the two areas are merged into one window where you can use tabs to
switch between the areas.
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4.1.2 Navigation using sensitive circuit diagrams

Fig. 2: DriveControlSuite: Navigation using text links and symbols

In order to illustrate graphically the processing sequence of actual and set values, the use of signals or certain drive
component arrangements and to make configuring the accompanying parameters easier, they are displayed on the
respective wizard pages of the workspace in the form of circuit diagrams.

Blue text links or clickable icons indicate links within the program. These refer to the corresponding wizard pages and, as a
result, allow you to reach additional helpful detail pages with just a click.
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4.2 Meaning of parameters
You can use parameters to adapt the function of the drive controller to your individual application. In addition, parameters
visualize the current actual values (actual velocity, actual torque, etc.) and trigger actions such as Save values, Test phase,
etc.

Interpretation of parameter identification

Parameter identification consists of the following elements, where short forms are also possible, i.e. only specifying a
coordinate or the combination of coordinate and name.

E50 V0

Coordinate Name Version

Drive controller G6

Drive controller
generation/series

4.2.1 Parameter groups
Parameters are assigned to individual groups by topic. The 6th generation of drive controllers differentiates between the
following parameter groups.

Group Topic

 A Drive controllers, communication, cycle times

B Motor

C Machine, velocity, torque/force, comparators

D Set value

E Display

F Terminals, analog and digital inputs and outputs, brake

G Technology – Part 1 (application-dependent)

H Encoder

I Motion (all motion settings)

J Motion blocks

K Control panel

L Technology – Part 2 (application-dependent)

M Profiles (application-dependent)

N Additional functions (application-dependent; e.g. extended cam control unit)

P Customer-specific parameters (programming)

Q Customer-specific parameters, instance-dependent (programming)

R Production data for the drive controller, motor, brakes, motor adapter, gear unit and geared motor

S Safety (safety technology)

T Scope

U Protection functions

Z Fault counter

Tab. 1: Parameter groups
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4.2.2 Parameter types and data types
In addition to topic-based sorting in individual groups, all parameters belong to a certain data type and parameter type. The
data type of a parameter is displayed in the parameter list, properties table. The connections between parameter types,
data types and their value range can be found in the following table.

Data type Parameter type Length Value range (decimal)

INT8 Integer or selection 1 byte (signed) -128 – 127

INT16 Integer 2 bytes (1 word, signed) -32768 – 32767

INT32 Integer or position 4 bytes (1 double word,
signed)

-2 147 483 648 – 2 147 483 647

BOOL Binary number 1 bit (internal: 
LSB in 1 byte)

0, 1

BYTE Binary number 1 byte (unsigned) 0 – 255

WORD Binary number 2 bytes (1 word, unsigned) 0 – 65535

DWORD Binary number or
parameter address

4 bytes (1 double word,
unsigned)

0 – 4 294 967 295

REAL32
(single type according to
IEE754)

Floating-point number 4 bytes (1 double word,
signed)

-3.40282 × 1038 – 3.40282 × 1038

STR8 Text 8 characters —

STR16 Text 16 characters —

STR80 Text 80 characters —

Tab. 2: Parameters: data types, parameter types, possible values

Parameter types: Use

§ Integer, floating-point number
For general computing processes
Example: Set and actual values

§ Selection
Numeric value to which a direct meaning is assigned
Example: Sources for signals or set values

§ Binary number
Bit-oriented parameter information that is collected in binary
Example: Control and status words

§ Position
Integer combined with associated units and decimal places
Example: Actual and set values of positions

§ Velocity, acceleration, deceleration, jerk
Floating-point number combined with associated units
Example: Actual and set values for velocity, acceleration, deceleration, jerk

§ Parameter address
Referencing of a parameter
Example: In F40 AO1 source, for example, E08 n-motor filtered can be parameterized

§ Text
Outputs or messages
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4.2.3 Parameter types
The following types of parameters are differentiated.

Parameter type Description Example

Simple parameters Consist of one group and one line with a
defined value.

A21 Brake resistor R: Value = 100 ohms

Array parameters Consist of a group, a line and multiple
sequential (listed) elements, which have the
same properties but different values.

A10 Access level

§ A10[0] access level: Value = Access level
via operating unit

§ A10[2] access level: Value = Access level
via CANopen and EtherCAT

§ A10[4] access level: Value = Access level
via PROFINET

Record parameters Consist of a group, a line and multiple
sequential (listed) elements, which can have
different properties and different values.

A00 Save values

§ A00[0] Start: Value = Start action

§ A00[1] Progress: Value = Display action
progress

§ A00[2] Result: Value = Display action
result

Tab. 3: Parameter types

4.2.4 Parameter structure
Every parameter has specific coordinates with the following structure.

E250 [2] .3

Axis
Group

Line

1.

Element
Bit

§ Axis (optional)
In case of multiple axes, the one to which a parameter is assigned; not applicable for global parameters 
(value range: 1 – 4).

§ Group
The thematic group to which a parameter belongs (value range: A – Z).

§ Line
Distinguishes the parameters within a parameter group (value range: 0 – 999).

§ Element (optional)
Elements of an array or record parameter (value range: 0 – 16000).

§ Bit (optional)
Selection of a single bit for complete data addressing; depends on the data type (value range: 0 – 31).
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4.2.5 Parameter visibility
The visibility of a parameter is primarily controlled by the access level you set in DriveControlSuite and by the properties
you project for the respective drive controller (e.g. hardware, firmware and application). A parameter can also be shown or
hidden depending on other parameters or settings. For example, the parameters of an additional function are only shown
as soon as you activate the relevant additional function.

Access level

The access options for the individual software parameters are ranked hierarchically and divided into individual levels. This
means that parameters can be hidden for a specific purpose and, relatedly, their configuration options can be locked
starting from a specific level.

Each parameter has one access level for read access (visibility) and one access level for write access (editability). The
following levels are present:

§ Level 0
Elementary parameters

§ Level 1
Important parameters of an application

§ Level 2
Important parameters for service with extensive diagnostic options

§ Level 3
All parameters needed for commissioning and optimizing an application

The parameter A10 Access level controls general access to parameters:

§ Over the drive controller display (A10[0])

§ Over CANopen or EtherCAT (A10[2])

§ Over PROFINET (A10[3])

Information

It is not possible to write to or read the parameter hidden in DriveControlSuite during communication via fieldbus.

Hardware

Which parameters are available to you in DriveControlSuite is determined by which series you select in the configuration
dialog for the drive controller, for example, or whether you project an option module. Basically, the only parameters that
are displayed are the ones you need to parameterize the configured hardware.

For example, a drive controller can evaluate an encoder using terminal X120, provided that a corresponding terminal
module has been installed. The accompanying evaluation is activated using parameter H120. However, this parameter is
visible only if the terminal module was initially selected during the drive project configuration.

Firmware

Due to the further development and updating of functions for the 6th generation of drive controllers, new parameters and
also new versions of existing parameters are continuously being implemented in DriveControlSuite and in the firmware. The
parameters are displayed in the software according to the DriveControlSuite version used and the configured firmware
version of the respective drive controller.

Applications

Applications generally differ in terms of functions and their control. For this reason, different parameters are available with
each application.
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4.3 Signal sources and process data mapping
The transmission of control signals and set values in DriveControlSuite meets the following principles.

Signal sources

Drive controllers are controlled either over a fieldbus, using mixed operation consisting of a fieldbus system and terminals
or exclusively using terminals. 
You can use the corresponding selection parameters, referred to as signal sources, to configure whether the control signals
and set values of the application are obtained over a fieldbus or using terminals.

In case of activation over a fieldbus, parameters that are selected as data sources for control signals or set values must be
part of the subsequent process data mapping. In the case of activation using terminals, the respective analog or digital
inputs are specified directly.

Process data mapping

If you are working with a fieldbus system and have selected the source parameters for control signals and set values,
configure the fieldbus-specific settings, e.g. the assignment of the process data channels for transmitting receive and
transmit process data, as the last step. The respective procedure can be found in the accompanying STOBER fieldbus
manuals.

4.4 Non-volatile memory
All project configurations, parameterizations and related changes to parameter values are in effect after transmission to the
drive controller, but are only stored in volatile memory.

Saving to a drive controller

To save the configuration in non-volatile memory on a drive controller, you have the following options:

§ Saving the configuration using the Save values wizard:
Project menu > Wizards area > Projected axis > Save values wizard: Select the Save values action

§ Saving the configuration using the parameter list:
Project menu > Parameter list area > Projected axis > Group A: Drive controller > A00 Save values: Set the parameter
A00[0] to the value 1: Active

§ Saving the configuration using the operating unit:
Drive controller with operating unit: Press the save button for 3 seconds

Saving to all drive controllers within a project

To save the configuration in non-volatile memory on several drive controllers, you have the following options:

§ Saving the configuration using the toolbar:
Toolbar > Save values icon: Click the Save values icon

§ Saving the configuration using the Online functions window:
Project menu > Online connection button > Online functions window: Click on Save values (A00)

Information

Do not shut off the drive controller while saving. If the supply voltage to the control unit is interrupted while saving, the
drive controller will start without an executable configuration the next time it is switched on. In this case, the configuration
must be transferred to the drive controller again and stored in non-volatile memory.
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5 Commissioning
The following chapters describe how to commission your drive system using DriveControlSuite.

For the components of your axis model, as an example, we require a synchronous servo motor with EnDat 2.1/2.2 digital
encoder and optional brake. These motors are saved along with all relevant data for the project configuration in the
DriveControlSuite motor database and in the electronic nameplate. 
Upon selecting the motor from the database, such as when reading out the nameplate, all data is transferred to the
corresponding parameters. There is no need for complex parameterization of the motor, brake or encoder.

For asynchronous motors, the motor data relevant for project configuration is also taken from the motor database. All
other motor types need to have their parameters configured manually.

Before you begin commissioning, make sure that the system nodes are hooked up and supplied with control voltage.

Information

Always perform the steps described below in the specified order!

Some parameters are interdependent and do not become accessible to you until you have first configured certain settings.
Follow the steps in the specified sequence so that you can finish the parameterization completely.
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5.1 Initiating the project
In order to be able to configure all drive controllers and axes of your drive system using DriveControlSuite, you must record
them as part of a project.

5.1.1 Projecting the drive controller and axis
Create a new project and project the first drive controller along with the accompanying axis.

Information

Make sure that you project the correct series in the Drive controller tab. The projected series cannot be changed
afterwards.

Creating a new project

1. Start DriveControlSuite.

2. On the start screen, click Create new project.

ð The new project is created and the configuration dialog for the first drive controller opens.

ð The Drive controller button is active.

Projecting the drive controller

1. Properties tab: 
Establish the relationship between your circuit diagram and the drive controller to be projected in DriveControlSuite.
Reference: Specify the reference code (equipment code) of the drive controller.
Designation: Give the drive controller a unique name.
Version: Version your project configuration.
Description: If necessary, specify additional supporting information, such as the change history of the project
configuration.

2. Drive controller tab:
Select the series, device type and firmware version of the drive controller.

3. Option modules tab:
Depending on the drive controller series, various option modules are available for you to select.
Communication module: If the drive controller communicates with a controller via a fieldbus, select the corresponding
communication module.
Terminal module: If you are controlling the drive controller using analog and digital inputs, select the corresponding
terminal module (in addition to the communication module in mixed operation).
Safety module: If the drive controller is part of a safety circuit, select the corresponding safety module.

4. Device control tab:
Device control: Select Drive Based.
Receive process data (Rx), transmit process data (Tx): If you control the drive controller using a fieldbus, select the
fieldbus-specific receive and transmit process data.
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Projecting the axis

1. Click on Axis 1.

2. Properties tab: 
Establish the connection between your circuit diagram and the axis to be projected in DriveControlSuite.
Reference: Specify the reference code (equipment code) of the axis.
Designation: Give the axis a unique name.
Version: Version your project configuration.
Description: If necessary, specify additional supporting information, such as the change history of the project
configuration.

3. Application tab:
Select Drive Based.

4. Motor tab:
Select the type of motor operated using this axis.

5. Confirm with OK.

ð The configuration dialog closes and the drive controller is created in a new module in the project tree.

5.1.2 Configuring safety technology
If the drive controller is part of a safety circuit, you must configure the safety technology in accordance with the
commissioning steps outlined in the corresponding manual in the next step (see Detailed information).

5.1.3 Creating other drive controllers and modules
In DriveControlSuite, all drive controllers within a project are grouped using modules. If you add a new drive controller to
your project, be sure to always assign it to an existing module. Group drive controllers in a module if, for example, they are
located in the same control cabinet or work together to operate the same machine part.

Creating a drive controller

1. In the project tree, select your project P1 > module M1 > context menu Create new drive controller.

ð The drive controller is created in the project tree and the configuration dialog opens.

2. Project the drive controller as described in Projecting the drive controller and axis [} 21].

3. Repeat the steps for all other drive controllers that you want to project.

Creating a module

1. In the project tree, select your project P1 > context menu Create new module.

ð The module is created in the project tree.

2. Project the module as described in Projecting the module [} 23].

3. Repeat the steps for all other modules that you want to project.
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5.1.4 Projecting the module
Give your module a unique name, enter the reference code and, as an option, store additional information like the version
and change history of the module.

1. Select the module in the project tree and click on Project configuration in the project menu.

ð The configuration dialog for the module opens.

2. Establish the relationship between your circuit diagram and the module in DriveControlSuite.
Reference: Specify the reference code (equipment code) of the module.
Designation: Give the module a unique name.
Version: Version the module.
Description: If necessary, specify additional supporting information, such as the change history of the module.

3. Confirm with OK.

5.1.5 Projecting the project
Give your project a unique name, enter the reference code and, as an option, store additional information like the version
and change history of the project.

1. Mark the project in the project tree and click on Project configuration in the project menu.

ð The configuration dialog for the project opens.

2. Establish the relationship between your circuit diagram and the project in DriveControlSuite.
Reference: Specify the reference code (equipment code) of the project.
Designation: Give the project a unique name.
Version: Version the project.
Description: If necessary, specify additional supporting information, such as the change history of the project.

3. Confirm with OK.
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5.2 Mapping the mechanical axis model
To be able to put your real drive train with one or more drive controllers into operation, you must map your complete
mechanical environment in DriveControlSuite.

The 6th generation of STOBER drive controllers are specially developed for communication between the drive controller
and controller on the basis of the actual variables at the output (° or mm of real axis movement). The scaling of the axis
model is calculated by the drive controller's firmware independently of the encoder model, without any rounding errors or
drift.

5.2.1 Parameterizing a STOBER motor
You have projected a STOBER synchronous servo motor with EnDat encoder and integrated brake.

By projecting the corresponding motor, limiting values for currents and torques as well as associated temperature data are
automatically transferred to the respective parameters of the individual wizards. At the same time, all additional data on
the energy supply, brake and encoder is transferred.

5.2.2 Parameterizing the axis model
Parameterize the setup of your drive in this order:

§ Define the axis model

§ Scale the axis

§ Parameterize the position and velocity window

§ Limit the axis (optional)

• Limit the position

• Limit the velocity, acceleration and jerk

• Limit the torque and force
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5.2.2.1 Define the axis model

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Axis model wizard.

3. I05 Type of axis:
Define whether the axis type is rotational or translational.

3.1. If you would like to configure the units of measure and the number of decimal places individually for specifying
and displaying positions, velocities, accelerations and jerk, select 0: User defined, rotational or 1: User defined,
translational.

3.2. If the units of measure and the number of decimal places for specifying and displaying positions, velocities,
accelerations and jerk are to be fixed, select 2: Rotational or 3: Translational.

4. B26 Motor encoder:
Define the interface to which the motor encoder is connected.

5. I02 Position encoder (optional):
Define the interface to which the position encoder is connected.

6. I00 Position range:
Define whether the travel range of the axis is limited or endless (modulo).

7. If you select I00 = 1: Endless, parameterize a revolution length when you scale the axis.

Information

When you parameterize I05 Type of axis, you can either use selection 0: User defined, rotational or 1: User defined,
translational to configure units of measure and the number of decimal places for the axis model individually or use
selections 2: Rotational and 3: Translational to revert to preset values.

Selection 0: User defined, rotational and selection 1: User defined, translational let you configure the unit of measure (I09)
and the decimal places (I06) individually. Velocity, acceleration and jerk are represented as the derivative of the unit of
measure with respect to time.

Selection 2: Rotational sets the following units of measure for the axis model: position in °, velocity in rpm, acceleration in
rad/s2, jerk in rad/s3.

Selection 3: Translational sets the following units of measure for the axis model: position in mm, velocity in m/s,
acceleration in m/s2, jerk in m/s3.

Information

If you do not parameterize it differently for I02 Position encoder, B26 Motor encoder is used for position control as
standard.
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5.2.2.2 Scale the axis

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Axis model wizard > Axis: Scaling.

3. Scale the axis by configuring the overall gear ratio between the motor and output.
To simplify this scaling for you, you are provided with the scaling calculator Conversion of positions, velocities,
accelerations, torque/force, which calculates the effects of changed motion variables on the entire system.

4. I01 Circular length:
If you have selected 1: Endless for I00 Position range, enter the revolution length.

5. I06 Decimal places position (optional):
If you have selected 0: User defined, rotational or 1: User defined, translational for I05 Type of axis, define the desired
number of decimal places.

6. I09 Measure unit (optional):
If you have selected 0: User defined, rotational or 1: User defined, translational for I05 Type of axis, define the desired
unit of measure.

7. I03 Axis polarity:
Use the polarity to specify the direction of interpretation between the axis movement and motor movement.

Information

A change to parameter I06 moves the decimal separator for all axis-specific position values! Ideally, define I06 before
parameterizing other position values and then check them.

If the axis receives set value specifications from a controller or follows the master values of a master, the resolution of
position values directly impacts the smooth operation of the axis. Therefore, you should define a sufficient number of
decimal places appropriate for your application.

Information

Parameter I297 Maximum speed position encoder must be parameterized according to your application case. If I297 is set
too low, the permitted maximum speed is exceeded even at normal operating speeds. On the other hand, if I297 is set too
high, measuring errors of the encoder can be overlooked.

I297 depends on the following parameters: I05 Type of axis, I06 Decimal places position, I09 Measure unit as well as
I07 Distance factor numerator position and I08 Distance factor denominator position or A585 Feed constant for CiA 402. If
you have made changes to one of the parameters listed, select I297 accordingly as well.
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5.2.2.3 Parameterizing the position and velocity window

Enter position limits and velocity zones for set values. To do so, parameterize boundary values for reaching a position or
velocity.

1. Select the Axis model wizard > Window position, velocity.

2. C40 Velocity window:
Parameterize a tolerance window for velocity tests.

3. I22 Target window:
Parameterize a tolerance window for position tests.

4. I87 Actual position in window time:
Parameterize how long a drive must stay in the specified position window before a corresponding status message is
output.

5. I21 Maximal following error:
Parameterize a tolerance window for lag tests.

For more information on monitoring the lag, see Lag monitoring [} 138].
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5.2.2.4 Limiting the axis

If necessary, limit the movement variables for position, velocity, acceleration, jerk as well as torque/force according to the
applicable conditions for your axis model.

Limiting the position (optional)

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Axis model wizard > Limit: Position.

3. If necessary, limit the position of your axis using a software or hardware limit switch to secure the travel range.

Limiting velocity, acceleration, jerk (optional)

The default values are designed for slow velocities without gear units. For this reason, adapt the saved values.

For example, verify the maximum velocity of the motor (B83) against the velocity of the output (I10).

1. Select the Motor wizard.

2. Determine the maximum possible motor velocity in parameter B83 v-max motor.

3. Select the Axis model wizard > Axis: Scaling > Conversion of positions, velocities, accelerations, torque/force area.

4. Velocity line: 
Enter the maximum motor velocity from B83 in the Velocity line of the Motor column and confirm with ENTER.

ð The maximum velocity of the motor is converted to the output.

5. Repeat the procedure for other limits, such as for the gear unit input speed (C11).

6. Select the Axis model wizard > Limit: Velocity, acceleration, jerk.

7. I10 Maximal speed: 
Limit the maximum velocity of the output, taking into account the determined system limits.

8. Determine the limiting values for acceleration and jerk if necessary and enter them into the associated parameters.

Limiting torque/force (optional)

The default values take into account the rated operation together with the overload reserves.

1. Select the Axis model wizard > Limit: Torque/force.

2. If the motor force must be limited, adapt the saved values as necessary.
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5.3 Referencing absolute position
When commissioning a system with position measurement systems, the relation of a measured to an actual axis position
must be determined to be able to work with absolute positions.

If you are working with absolute positions, reference the axis now. Otherwise, proceed by parameterizing application-
specific conditions and responses of the Drive Based device control.

5.3.1 Defining the referencing method
1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >

Wizard area.

2. Select the Referencing wizard.

3. I30 Referencing type, I31 Referencing direction, I35 Referencing with zero pulse:
Define the characteristics for referencing.
For information on possible combinations of the named characteristics as well as detailed descriptions of the
individual referencing methods, see Referencing methods [} 107].

4. I43 Move to reference position:
If the axis is to automatically move to the referenced position after referencing, set this parameter to 1: Active.

5.3.2 Parameterizing the reference switch
If you are working with absolute positions and would like to determine a reference position while referencing using the
reference switch, proceed as follows.

1. Select the Drive Based application wizard > Data sources > Application digital signals: Data source.

2. I103 Source reference switch:

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If bit 3 of the control word I210 of the application is the source, select 2: Parameter.

5.3.3 Setting the reference
If you are working with absolute positions and would like to reference without using a referencing run, the value of the
current actual position is applied directly as a parameter value from I34 using the Set reference signal.

1. Select the Drive Based application wizard > Data sources > Application digital signals: Data source.

2. I111 Source set reference:

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If bit 11 of the control word I210 of the Drive Based application is the signal source, select 2: Parameter.
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5.3.4 Parameterizing the limit switch
Using the limit switch, you can limit the travel range in the positive and negative direction using sensor signals, regardless of
the operating mode. Both signals are protected against wire breaks (= low active, i.e. a low level leads to a limit switch
fault).

Parameterizing a positive limit switch

1. Select the Drive Based application wizard > Data sources > Application digital signals: Data source.

2. I101 Source positive /limit switch:
To limit the travel range in the positive direction of motion, select the source for the positive limit switch.

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If bit 1 of the control word I210 of the application is the source, select 2: Parameter.

Parameterizing a negative limit switch

1. Select the Drive Based application wizard > Data sources > Application digital signals: Data source.

2. I102 Source negative /limit switch:
To limit the travel range in the positive direction of motion, select the source for the negative limit switch.

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If bit 2 of the control word I210 of the application is the source, select 2: Parameter.
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5.4 Parameterizing Drive Based device control
The Drive Based device control describes the control sequence of a drive controller based on a state machine, i.e. a drive
controller switches its state due to an event. Some of the conditions and responses coupled with the state transitions can
be influenced depending on the application; for example, it is possible to define the end of a quick stop or enable signal
delays tailored to the respective application case.

Detailed information on the device control and Drive Based device state machine can be found in the chapter Drive Based
device control [} 130].

5.4.1 Parameterizing transition conditions

ü You have projected a drive controller with the Drive Based device control.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based device control wizard.

3. A34 Auto start:
If the drive controller is to switch directly to the Operation enabled state after the Switch on disabled state, activate
this parameter.

4. A43 Enable switch-on/off delay
If you need to hide possible fault or test pulses on the enable signal input, enter the maximum internal activation and
deactivation delay.

5. A44 Quick stop at enable off:
If the drive is to be stopped with a quick stop in the event of a deactivated enable signal, activate this parameter.

6. A60 Source additional enable:
If you are working with multiple enable signals, define the source of additional signals in this parameter.

7. A29 Quick stop in case of fault:
If the drive is to be stopped with a quick stop—if possible—in case of a fault, activate this parameter. If the parameter
is deactivated, motion of the axis is no longer controlled by the drive controller.

8. A39 Maximum quick stop duration for enable off:
If you have selected 1: Active for parameter A44, define the maximum time after which the power unit is switched off
in A39.

9. A45 Quick stop end:
In this parameter, define whether a quick stop is considered ended when the drive is at a standstill or when the quick
stop request is canceled.

10. A62 Source /quick stop: 
Define how a quick stop is triggered in this parameter.

11. E48 Device control state:
Shows the current state of the drive controller.
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5.5 Transmitting and saving a configuration
In order to transmit and save the configuration to one or more drive controllers, you must connect your PC and the drive
controllers over the network.

WARNING!

Injury to persons and material damage due to axis movement!

If there is an online connection between DriveControlSuite and the drive controller, changes to the configuration can lead
to unexpected axis movements.

▪ Only change the configuration if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

▪ For access via remote maintenance, there must be a communication link between you and a person on site with eye
contact to the axis.

Information

During the search, all drive controllers within the broadcast domain are found via IPv4 limited broadcast.

Requirements for finding a drive controller in the network:

▪ Network supports IPv4 limited broadcast

▪ All drive controllers and the PC are in the same subnet (broadcast domain)

5.5.1 Transmitting the configuration
The steps for transmitting the configuration vary depending on the safety technology.

Drive controller without SE6 safety module

ü You have verified the plausibility of the predefined test motion variables.

ü The drive controllers are switched on.

1. In the project tree, select the module under which you have recorded your drive controller and click Online
connection in the project menu.

ð The Add connection dialog box opens. All drive controllers found via IPv4 limited broadcast are displayed.

2. Direct connection tab > IP address column: 
Activate the IP addresses in question and confirm your selection with OK.

ð The Online functions window opens. All drive controllers connected through the previously selected IP addresses
are displayed.

3. Select the drive controller to which you want to transmit a configuration and change the selection of the transmission
type from Read to Send.

4. Change the selection Create new drive controller:
Select the configuration that you would like to transfer to the drive controller.

5. Repeat steps 3 and 4 for all other drive controllers to which you would like to transfer your configuration.

6. Online tab:
Click Establish online connection.

ð The configurations are transferred to the drive controllers.
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Drive controller with SE6 safety module

ü You have verified the plausibility of the predefined test motion variables.

ü The drive controllers are switched on.

1. In the project tree, select the module under which you have recorded your drive controller and click Online
connection in the project menu.

ð The Add connection dialog box opens. All drive controllers found via IPv4 limited broadcast are displayed.

2. Direct connection tab > IP address column: 
Activate the IP addresses in question and confirm your selection with OK.

ð The Online functions window opens. All drive controllers connected through the previously selected IP addresses
are displayed.

3. Select the drive controller to which you want to transmit a configuration and change the selection of the transmission
type from Read to Send.

4. Change the selection Create new drive controller:
Select the configuration that you would like to transfer to the drive controller.

5. Repeat steps 3 and 4 for all other drive controllers to which you would like to transfer your configuration.

6. Online tab:
Click Establish online connection.

ð The configurations are transferred to the drive controllers.

ð A dialog box prompts you to open the PASmotion configuration tool.

1. Confirm the dialog box with Yes.

ð PASmotion opens.

2. In the PASmotion project administration, navigate to the safety module for the drive controller and double-click to
open it.

ð The dialog box for the password prompt opens.

3. Enter the password and confirm with OK.

ð The wizard for device synchronization opens.

ð Device configuration and configuration are checked against each other automatically.

4. If the configurations match, click on Done after device synchronization has finished.

5. Optional: If the configurations do not match, click on Next after device synchronization has finished.

5.1. Confirm the production number of the safety module and click Next.

5.2. Enter the password for the configuration on the safety module and click Next.

5.3. Click Upload to transfer the device configuration to the project.

5.4. After the successful transfer, click Done.

6. Exit PASmotion.

ð The safety configuration is transferred to the selected drive controller.
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5.5.2 Saving the configuration

ü You have successfully transmitted the configuration.

1. Online functions window:
Click Save values (A00).

ð The Save values (A00) window opens.

2. Click Start action.

ð The configuration is stored on the drive controllers in non-volatile memory.

3. Close the Save values (A00) window.

Information

For the configuration to take effect on the drive controller, a restart is required when the configuration is saved on the
drive controller for the first time or when changes are made to the firmware or process data mapping.

Restarting a drive controller

ü You have stored the configuration on the drive controller in non-volatile memory.

1. Online functions window:
Click Restart (A09).

ð The Restart (A09) window opens.

2. Select which of the connected drive controllers you want to restart.

3. Click Start action.

4. Confirm the safety note with OK.

ð The Restart (A09) window closes.

ð The fieldbus communication and connection between DriveControlSuite and drive controllers are interrupted.

ð The selected drive controllers restart.
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5.6 Testing the configuration
Check the configuration of your projected axis model before continuing with the parameterization of the application. Use
Jog control panel to test the electronic and mechanical data of your project configuration and parameterization for
plausibility. Control panel motion gives you the option to test the basic movements of your axis using motion commands.

Information

Check the suitability of the default values for your application before starting the test. If they appear too large or unsuitable
compared with the results of the scaling calculator, replace them with values that are more suitable for test operation.

5.6.1 Testing jog mode
Jog control panel provides various commands for jog mode which you can use to test the configuration of your projected
axis model for plausibility.

WARNING!

Injury to persons and material damage due to axis movement!

When you activate the control panel, DriveControlSuite gives you sole control of the motions of the axis. If you are using a
controller, it no longer monitors the axis movements after the control panel is activated. The controller cannot intervene to
prevent collisions. The controller takes over control again when the control panel is deactivated, which can cause
unexpected axis movements.

▪ Do not switch to other windows when the control panel is active.

▪ Only use the control panel if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

▪ For access via remote maintenance, there must be a communication link between you and a person on site with eye
contact to the axis.

Information

If you are using an SD6 drive controller, you can also use jog mode via the operating unit of the SD6.

Information

Make sure that the values of the control panel are compatible with your projected axis model and adjust the default values
if necessary. This is the only way to get suitable test results which you can use to optimize your configuration for the
respective axis.

The scaling calculator is available under the Axis model wizard > Axis: Scaling to recalculate the values for the control panel
according to your projected axis model.
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Testing the configuration using the jog control panel

ü The drive controller is switched on.

ü You have established an online connection to the drive controller.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Jog control panel wizard.

3. Click Control panel on and then Enable.

ð The axis is monitored via the active control panel.

4. Check the default values of the control panel and adjust them to your projected axis model if necessary.

5. To test the configuration of your projected axis for direction of motion, velocity, etc., move the axis gradually using
the Jog+, Jog-, Jog step+ and Jog step- buttons.

6. Use your test results to optimize your configuration as necessary.

7. To deactivate the control panel, click on Control panel off.

Information

Jog+ and Jog− cause a continual manual movement in the positive or negative direction. Jog step+ and Jog step- move the
axis relative to the current actual position by the increment specified in I14.

Jog+ and Jog− have a higher priority than Jog step+ and Jog step−.
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5.6.2 Testing the motion commands
Control panel motion provides a standard set of motion commands which you can use to test the basic movements of your
axis. The command set is based on the PLCopen standard and supplemented by manufacturer-specific motion commands.

If you are working with absolute position measuring systems and need the MC_MoveAbsolute motion command for
testing, you must reference an absolute position in advance (see Referencing absolute position [} 29]).

WARNING!

Injury to persons and material damage due to axis movement!

When you activate the control panel, DriveControlSuite gives you sole control of the motions of the axis. If you are using a
controller, it no longer monitors the axis movements after the control panel is activated. The controller cannot intervene to
prevent collisions. The controller takes over control again when the control panel is deactivated, which can cause
unexpected axis movements.

▪ Do not switch to other windows when the control panel is active.

▪ Only use the control panel if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

▪ For access via remote maintenance, there must be a communication link between you and a person on site with eye
contact to the axis.

Information

Make sure that the values of the control panel are compatible with your projected axis model and adjust the default values
if necessary. This is the only way to get suitable test results which you can use to optimize your configuration for the
respective axis.

The scaling calculator is available under the Axis model wizard > Axis: Scaling to recalculate the values for the control panel
according to your projected axis model.

Testing the configuration using the motion control panel

ü The drive controller is switched on.

ü You have established an online connection to the drive controller.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Control panel motion wizard.

3. Click Control panel on and then Enable.

ð The axis is monitored via the active control panel.

4. Check the default values of the control panel and adjust them to your projected axis model if necessary.

5. K402 Command: 
Select the desired command and define the position, velocity, acceleration, deceleration and jerk.

6. Execute the command by clicking Start.

7. To test the configuration of your projected axis for direction of motion, velocity, etc., move the axis precisely using the
individual commands.

8. Use your test results to optimize your configuration as necessary.

9. To deactivate the control panel, click on Control panel off.
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5.7 Parameterizing the Drive Based application
The Drive Based application provides three operating modes: command operating mode, motion block operating mode and
velocity, torque/force operating mode.

The operating modes provide you with a standard set of motion commands based on PLCopen that are supplemented with
unique motion commands. The operating mode that is best suited to your application depends on your application case. If
you are coordinating motion sequences using a controller, use the command operating mode. If you are not using a
controller and are instead storing the motion profiles on the respective drive controller, use the motion block operating
mode. If you only want to execute simple movements in which only set values may be subject to possible changes, such as
for pumps, fans or conveyor belts, use the velocity, torque/force operating mode.

The general motion variables are grouped in the mode-independent Data sources wizard. Depending on the operating
mode, unique wizards are also available which you can use to parameterize operating mode-specific motion variables. The
general or operating mode-specific motion variables you need to parameterize depend on your drive project.

If you would like to use set values from external sources for your project, parameterize them in the first step. Then,
continue with the operating mode-specific motion variables in the respective wizards.

5.7.1 General motion variables and signal sources
First, parameterize the general motion variables and signal sources before you begin parameterization of the operating
mode-specific motion variables. The motion variables that you need to parameterize depend on your drive project.

5.7.1.1 Velocity – Parameterizing sources

If you are obtaining the set value for velocity from external sources for applications of the Drive Based type, enter this as
described below.

Either an analog input or a parameter can be used as the source for the set value. If you transmit data via fieldbus, the set
value can either be obtained directly from an internal parameter or indirectly by reading out a parameter (such as with PID
controllers).

Set velocity – Parameterizing the source

If you are obtaining the set value for velocity from an external source, enter the source for the main set value.

ü Use the motion command MC_MoveSpeed or MC_MoveVelocity.

1. Select the Drive Based application wizard > Data sources > External velocity: Data source.

2. G461 Source external velocity:

2.1. If an analog input acts as the source, select the corresponding input.

2.2. If you are transmitting data via fieldbus and would like to configure the value as the general data source, select
4: Parameter G460.

2.3. If the set value is read out indirectly via a parameter, select 5: Indirect read parameter G811.

3. G460 External velocity:
If you have selected 4: Parameter G460 for G461, enter the set velocity here.

4. G811 Indirect read external velocity:
If you have selected 5: Indirect read parameter G811 for G461, enter the associated parameter coordinate here.
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Additional velocity – Parameterizing the source

If you also want to regulate the set velocity, enter the source for the additional set value.

ü Use the motion command MC_MoveSpeed or MC_MoveVelocity.

ü You obtain the set velocity from an external source.

1. Select the Drive Based application wizard > Data sources > External additional velocity: Data source.

2. G464 Source external additional velocity:

2.1. If an analog input acts as the source, select the corresponding input.

2.2. If you are transmitting data via fieldbus and would like to configure the value as the general data source, select
4: Parameter G463.

2.3. If the set value is read out indirectly via a parameter, select 5: Indirect read parameter G812.

3. G463 External additional velocity:
If you have selected 4: Parameter G463 for G464, enter the set velocity here.

4. G812 Indirect read additional external velocity:
If you have selected 5: Indirect read parameter G812 for G463, enter the parameter coordinate here.

5.7.1.2 Velocity override – Parameterizing the source

If you would like to use a velocity override to scale the velocity profile of your motion commands, enter the source for the
velocity override.

Either an analog input or a parameter can be used as the source for the set value. If you transmit data via fieldbus, the set
value can either be obtained directly from an internal parameter or indirectly by reading out a parameter (such as with PID
controllers).

1. Select the Drive Based application wizard > Data sources > Velocity override: Data source.

2. G467 Source velocity override:

2.1. If an analog input acts as the source, select the corresponding input.

2.2. If you are transmitting data via fieldbus and would like to configure the value as the general data source, select
4: Parameter G466.

2.3. If the set value is read out indirectly via a parameter, select 5: Indirect read parameter G813.

3. G466 Velocity override:
If you have selected 4: Parameter G466 for G467, enter the set velocity here.

4. G813 Indirect read velocity override:
If you have selected 5: Indirect read parameter G813 for G467, enter the parameter coordinate here.



5 | Commissioning STOBER

40

04
/2

02
4 

| 
ID

 4
42

70
6.

03

5.7.1.3 Torque/Force – Parameterizing sources

If you have selected the motion command MC_TorqueControl for Drive Based type applications and obtain set values from
external sources, enter the sources for the set torque/force and velocity bracketing.

Either an analog input or a parameter can be used as the source for the set value. If you transmit data via fieldbus, the set
value can either be obtained directly from an internal parameter or indirectly by reading out a parameter (such as with PID
controllers).

Set torque/force – Parameterizing the source

If you obtain the set value for torque/force from an external source, enter the source for the set torque/force.

ü You are using the 9: MC_TorqueControl motion command.

1. Select the Drive Based application wizard > Data sources > Set torque/force, velocity bracketing: Data source.

2. G470 Source torque/force reference:

2.1. If an analog input acts as the source, select the corresponding input.

2.2. If you are transmitting data via fieldbus and would like to configure the value as the general data source, select
4: Parameter G469.

2.3. If the set value is read out indirectly via a parameter, select 5: Indirect read parameter G814.

3. G469 Torque/Force reference:
If you have selected 4: Parameter G469 for G470, define the value for set torque/force here. The value relates to
C03 Maximum positive torque/force and C05 Maximum negative torque/force.

4. G814 Indirect read torque/force reference:
If you have selected 5: Indirect read parameter G814 for G470, define the associated parameter coordinate here.

5. G500 Torque/force ramp removal, G501 Torque/force ramp removal:
Define the ramps for the build-up or reduction of torque/force.
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Velocity bracketing – Parameterizing the source

If you obtain values for limiting the velocity from an external source, enter the source for the velocity bracketing.

ü You are using the 9: MC_TorqueControl motion command.

1. Select the Drive Based application wizard > Data sources > Set torque/force, velocity bracketing: Data source.

2. G473 Source velocity bracketing positiv:

2.1. If an analog input acts as the source, select the corresponding input.

2.2. If you are transmitting data via fieldbus, select 4: Parameter G472.

3. G472 Velocity bracketing positiv:
If you have selected 4: Parameter G472 for G473, define the maximum limit that you want to permit for your
mechanical system.

4. G476 Source velocity bracketing negative:

4.1. If an analog input acts as the source, select the corresponding input.

4.2. If you are transmitting data via fieldbus, select 4: Parameter G475.

5. G475 Velocity bracketing negative:
If you have selected 4: Parameter G475 for G476, define the maximum limit that you want to permit for your
mechanical system here.

Information

If you define the velocity bracketing using G472 or G475, you should allow the control enough room. Therefore, select a
value for the velocity bracketing that is greater than 1%. G472 and G475 refer to I10 Maximal speed.
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5.7.1.4 Parameterizing analog inputs

If the analog inputs serve as a source for the application in your drive project, parameterize the respective analog input as
described below.

For more information and continuous function charts for analog inputs AI1 – AI3, see Analog inputs [} 80].

5.7.1.4.1 Parameterizing analog input AI1

Parameterize the analog input as a voltage source by defining a time constant for the associated filter and calibrating using
the maximum positive, maximum negative and 0 V voltage. After that, you can scale the analog input as needed.

If the analog input is the current source, calibrate using the maximum and minimum currents instead, and optionally enable
wire break monitoring.

Parameterizing analog input AI1

1. Select the Terminals wizard > Analog input 1.

2. F13 AI1 lowpass filter:
If the quality of the signal requires it, adjust the time constant for the filter accordingly.

3. F15 AI1 wire break monitoring:
If you want to use analog input AI1 as a current source and enable wire break monitoring, select 1: Active.

4. F116 AI1 operating mode:
Select the operating mode of analog input AI1.

4.1. If analog input AI1 is the voltage source, select 0: -10V to 10V.

4.2. If analog input AI1 is the current source, select 1: 0 to 20mA or 2: 4 to 20mA.

Calibrating analog input AI1 (voltage source)

ü Analog input AI1 is interpreted as a voltage source (F116 = 0: -10V to 10V).

1. Select the Terminals wizard > Analog input 1 > Analog input 1: Calibration.

2. Set the voltage source to the minimum voltage.

2.1. F112 AI1 maximum negative value:
Apply the value from parameter E110[1] for parameter F112.

2.2. F114 AI1 maximum negative % value:
Define the associated value for F112 in % in parameter F114.

3. Set the voltage source to the maximum voltage.

3.1. F111 AI1 maximum positive value:
Apply the value from parameter E110[1] for parameter F111.

3.2. F115 AI1 maximum positive % value:
Define the associated value for F111 in % in parameter F115.

4. Set the voltage source to 0 V voltage.

4.1. F110 AI1 zero point offset:
Apply the value from parameter E110[1] for parameter F110.

5. F113 AI1 deadband:
Optionally define a deadband to compensate for any noise of the 0 V voltage at the analog input.
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Calibrating analog input AI1 (current source)

ü Analog input AI1 is interpreted as a current source (F116 = 1: 0 to 20mA or 2: 4 to 20mA).

1. Select the Terminals wizard > Analog input 1 > Analog input 1: Calibration.

2. Set the current source to the minimum current.

2.1. F110 AI1 zero point offset:
Apply the value from parameter E110[1] for parameter F110.

2.2. F114 AI1 maximum negative % value:
Define the associated value for F110 in % in parameter F114.

3. Set the current source to the maximum current.

3.1. F111 AI1 maximum positive value:
Apply the value from parameter E110[1] for parameter F111.

3.2. F115 AI1 maximum positive % value:
Define the associated value for F111 in % in parameter F115.

Scaling analog input AI1

1. Select the Drive Based Center Winder application wizard > Analog inputs: Scaling > Analog input 1: Scaling.

2. G260 AI1 scaling:
Select the scaling for the analog input.

2.1. If you want to use the value unscaled, select 0: Without scaling.

2.2. If you want to use the value unsigned, select 1: Absolute value.

2.3. If you want to use the value inverted, select 2: Inverting.

2.4. If you want to scale the value using a curve, select 3: X/Y characteristic.

ð Parameters G261 and G262 for scaling the analog input using a curve are displayed.

3. G261 AI1 X-value scaling, G262 AI1 Y-value scaling:
If you have selected 3: X/Y characteristic for G260, define the value pairs of the calibrated value and scaled value for
the scaling of the analog input.

ð The scaling of the analog input is completed.

ð The scaled value of analog input AI1 is displayed in G270.
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5.7.1.4.2 Parameterizing analog input AI2

Parameterize the analog input as a voltage source by defining a time constant for the associated filter and calibrating using
the maximum positive, maximum negative and 0 V voltage. After that, you can scale the analog input as needed.

Parameterizing analog input AI2

1. Select the Terminals wizard > Analog input 2.

2. F23 AI2 lowpass filter:
If the quality of the signal requires it, adjust the time constant for the filter accordingly.

Calibrating analog input AI2

1. Select the Terminals wizard > Analog input 2 > Analog input 2: Calibration.

2. Set the voltage source to the minimum voltage.

2.1. F122 AI2 maximum negative value:
Apply the value from parameter E111[1] for parameter F122.

2.2. F124 AI2 maximum negative % value:
Define the associated value for F122 in % in parameter F124.

3. Set the voltage source to the maximum voltage.

3.1. F121 AI2 maximum positive value:
Apply the value from parameter E111[1] for parameter F121.

3.2. F125 AI2 maximum positive % value:
Define the associated value for F121 in % in parameter F125.

4. Set the voltage source to 0 V voltage.

4.1. F120 AI2 zero point offset:
Apply the value from parameter E111[1] for parameter F120.

5. F123 AI2 deadband:
Optionally define a deadband to compensate for any noise of the 0 V voltage at the analog input.

Scaling analog input AI2

1. Select the Drive Based Center Winder application wizard > Analog inputs: Scaling > Analog input 2: Scaling.

2. G263 AI2 scaling:
Select the scaling for the analog input.

2.1. If you want to use the value unscaled, select 0: Without scaling.

2.2. If you want to use the value unsigned, select 1: Absolute value.

2.3. If you want to use the value inverted, select 2: Inverting.

2.4. If you want to scale the value using a curve, select 3: X/Y characteristic.

ð Parameters G264 and G265 for scaling the analog input using a curve are displayed.

3. G264 AI2 X scaling, G265 AI2 Y scaling:
If you have selected 3: X/Y characteristic for G263, define the value pairs of the calibrated value and scaled value for
the scaling of the analog input.

ð The scaling of the analog input is completed.

ð The scaled value of analog input AI2 is displayed in G271.
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5.7.1.4.3 Parameterizing analog input AI3

Parameterize the analog input as a voltage source by defining a time constant for the associated filter and calibrating using
the maximum positive, maximum negative and 0 V voltage. After that, you can scale the analog input as needed.

Parameterizing analog input AI3

1. Select the Terminals wizard > Analog input 3.

2. F33 AI3 lowp. filter:
If the quality of the signal requires it, adjust the time constant for the filter accordingly.

Calibrating analog input AI3

1. Select the Terminals wizard > Analog input 3 > Analog input 3: Calibration.

2. Set the voltage source to the minimum voltage.

2.1. F132 AI3 maximum negative value:
Apply the value from parameter E112[1] for parameter F132.

2.2. F134 AI3 maximum negative % value:
Define the associated value for F132 in % in parameter F134.

3. Set the voltage source to the maximum voltage.

3.1. F131 AI3 maximum positive value:
Apply the value from parameter E112[1] for parameter F131.

3.2. F135 AI3 maximum positive % value:
Define the associated value for F131 in % in parameter F135.

4. Set the voltage source to 0 V voltage.

4.1. F130 AI3 zero point offset:
Apply the value from parameter E112[1] for parameter F130.

5. F133 AI3 deadband:
Optionally define a deadband to compensate for any noise of the 0 V voltage at the analog input.

Scaling analog input AI3

1. Select the Drive Based Center Winder application wizard > Analog inputs: Scaling > Analog input 3: Scaling.

2. G266 AI3 scaling:
Select the scaling for the analog input.

2.1. If you want to use the value unscaled, select 0: Without scaling.

2.2. If you want to use the value unsigned, select 1: Absolute value.

2.3. If you want to use the value inverted, select 2: Inverting.

2.4. If you want to scale the value using a curve, select 3: X/Y characteristic.

ð Parameters G267 and G268 for scaling the analog input using a curve are displayed.

3. G267 AI3 X-value scaling, G268 AI3 Y-value scaling:
If you have selected 3: X/Y characteristic for G266, define the value pairs of the calibrated value and scaled value for
the scaling of the analog input.

ð The scaling of the analog input is completed.

ð The scaled value of analog input AI3 is displayed in G272.
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5.7.2 Parameterizing velocity, torque/force operating mode
The following graphic shows the signal flows of velocity, torque/force operating mode. The elements shown in a lighter
shade are optional.

Controller

Motion
command

Motion
variables Alternative sources

Controller

DI

Start signalStart

Controller

AI
Override Motion

core

Motor

Drive controller
enable signal

MC_MoveSpeed
MC_TorqueControl

MC_Velocity

AI

Fixed values

Controller

Fig. 3: Velocity, torque/force operating mode: Signal flows

In the velocity, torque/force operating mode, an individual motion command is permanently stored on the drive controller
with the associated set values. This way, you can operate simple applications such as belt drives, pumps or fans with set
velocity. You can use set torque or set force to operate simple applications such as screwing machines, winders or presses.

In velocity, torque/force operating mode, drive controllers are either activated using a fieldbus or by a mixed operation of a
fieldbus and terminals.

Proceed as follows ...

§ Activate velocity, torque/force operating mode.

§ Velocity operating mode

• Select either the motion command MC_MoveSpeed or MC_MoveVelocity and parameterize the start signal for
MC_MoveVelocity if necessary.

• If you obtain the set velocity from an external source, parameterize the main and, if applicable, additional set
value.

• If you want to switch between fixed set velocities, add the fixed set values for the velocity.

• Store fixed values for acceleration, deceleration and jerk.

• You can optionally limit the maximum velocity.
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§ Torque/force operating mode

• Select the motion command MC_TorqueControl.

• Parameterize the associated set values and limits.

Information

The motion variables available for this operating mode that you configure in the software depend on your application case
as well as on additional project-specific factors such as the use of a controller or the type of data transmission (fieldbus,
terminals).

5.7.2.1 Activate velocity, torque/force operation mode

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard.

3. Operating modes area:
Activate the Velocity, torque/force operating mode option.

ð The corresponding wizards are displayed.

5.7.2.2 Parameterizing velocity operating mode

In the velocity operating mode, two motion commands are available for moving the axis with a set velocity:
MC_MoveSpeed and MC_MoveVelocity. Depending on your drive project, you can either specify the set velocity using set
values or fixed set values. For both approaches, you also store fixed values for acceleration, deceleration and jerk.

Work with set values if your drive project requires continuous value changes – e.g. for conveyor belts, which must assume
varying velocities. The set values are either fed in here using a potentiometer, a fieldbus or the analog output group of a
controller.

Work with fixed set values if your drive project requires switching between different fixed and unchanging set values – e.g.
for a 3-stage pump setting. The fixed set values are stored directly in the software and are selected by a controller either via
fieldbus or using the controller's own binary output group. As an alternative, the fixed set values can be defined using a BCD
coded switch.
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5.7.2.2.1 Velocity – Defining the motion command

In the velocity operating mode, two motion commands are available for moving the axis with a set velocity:
MC_MoveSpeed and MC_MoveVelocity. The parameterization of set and fixed set values is identical for both commands.

For MC_MoveSpeed, velocity control is active and the set and fixed set values are processed automatically with the enable
signal of the power unit. For MC_MoveVelocity, position control is active and the set and fixed set values are processed by a
start signal, which you must parameterize manually.

Selecting the motion command

1. Select the Drive Based application wizard > Velocity, torque/force operating mode.

2. D01 Command: 
Select a motion command in order to move the axis with a set velocity.

2.1. If you want to move the axis with velocity control, select 1: MC_MoveSpeed.

2.2. If you want to move the axis with position control, select 2: MC_MoveVelocity.

MC_MoveVelocity – Parameterizing the start signal

Parameterize the signal source for the start signal used to start the motion command MC_MoveVelocity.

ü You have selected MC_MoveVelocity for D01 Command.

1. Select the Drive Based application wizard > Data sources > Application digital signals: Data source.

2. I100 Source execute:

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If the control word I210 of the application acts as the signal source, select 2: Parameter.
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5.7.2.2.2 Velocity – Parameterizing set values

If continuous value changes are necessary in your drive project, configure corresponding set values for the velocity.

Information

Before you start parameterizing the operating mode-specific motion variables, parameterize the general motion variables
and signal sources. If you obtain set values for velocity, velocity override or torque/force for your drive project from
external sources, proceed as described in the chapter General motion variables and signal sources [} 38].

Velocity – Parameterizing the main set value

If you obtain the set velocity from an external source, enter the source for the main set value.

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Main set value.

2. D30 Source main reference value:
If you want to obtain the set value from an external source, select 1: Parameter G462.

3. D33 Inverting main reference value:
If you want to change the direction of rotation of the drive and apply the previously configured main set value, select
1: Active.

4. D232 Maximum positive torque/force: 
If you also want to limit the torque/force using the operating mode, enter the maximum permitted positive value for
torque/force.

5. D233 Maximum negative T/F: 
If you also want to limit the torque/force using the operating mode, enter the maximum permitted negative value for
torque/force.

Velocity – Parameterizing the additional set value

If you also want to regulate the main set value for the set velocity, enter the source for the additional set value.

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Additional reference value.

2. D31 Source additional reference value: 
Select 1: Parameter G465.

3. D34 Inverting additional reference value:
If you want to change the direction of rotation of the drive and apply the previously configured additional set value,
select 1: Active.
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5.7.2.2.3 Velocity – Parameterizing fixed set values

If switching between different, fixed and unchanging set velocities is a necessary part of your drive project, add them
directly to the software as fixed set values. A controller either accesses the values via fieldbus or selects them with binary
coding using corresponding digital inputs. You can add a maximum of 15 fixed set values.

Velocity – Parameterizing fixed set values

If you obtain the set velocity from fixed set values, enter the fixed set values as the source for the main set value.

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Main set value.

2. D30 Source main reference value:
If you want to obtain the set value from an external source, select 2: Fixed reference value D20.

3. D232 Maximum positive torque/force: 
If you also want to limit the torque/force using the operating mode, enter the maximum permitted positive value for
torque/force.

4. D233 Maximum negative torque/force: 
If you also want to limit the torque/force using the operating mode, enter the maximum permitted negative value for
torque/force.

Velocity – Storing fixed set values

If you are working with fixed set values, store them in the software.

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Fixed reference values: Velocity.

2. D12 Fixed velocity reference value:
You can store a total of 15 fixed set values in the parameter elements D12[0] – D12[14]. 
Element D12[15] is pre-assigned with I10 Maximal speed by the system.

3. To parameterize the selection of fixed set values, click on the Selection link.

ð The Fixed set value for velocity: Selection wizard opens.

Velocity – Parameterizing the fixed set value selection

If you are working with fixed set values, define whether they are selected via fieldbus or using digital inputs.

ü You are in the Fixed set value for velocity: Selection wizard.

1. D05 Source selection fixed velocity reference value:
Define whether the fixed set values are selected via fieldbus or using the digital inputs.

1.1. If you are selecting fixed set values using a fieldbus, select 1: Parameter D13.

1.2. If you are selecting fixed set values using the digital inputs, select 2: Digital inputs.

2. D13 Control byte fixed velocity reference value:
If you have selected 1: Parameter D13 for D05, this parameter is written by the controller. The displayed number
corresponds to the respective D12 parameter element configured previously.

3. D04 Source binary selection fixed velocity reference value:
If you have selected 2: Digital inputs for D05, configure the signal sources for parameter elements D04[0] – D04[7].
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5.7.2.2.4 Acceleration, deceleration, jerk – Parameterizing fixed values

Parameterize at least one fixed value each for acceleration, deceleration and jerk. You need the fixed values for your drive
project regardless of whether you specify the set velocity using set values or fixed set values.

5.7.2.2.4.1 Acceleration – Parameterize fixed value

If you have stored one or more set or fixed set values for the velocity, you must parameterize a fixed value for the
acceleration.

Acceleration – Storing fixed values

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Fixed values: Acceleration.

2. D14 Fixed acceleration value:
You can store a total of 15 fixed set values in the parameter elements D14[0] – D14[14]. 
Element D14[15] is pre-assigned with I11 Maximal acceleration by the system.

3. To parameterize the selection of fixed values, click on the Selection link.

ð The Fixed value for acceleration: Selection wizard opens.

Acceleration – Parameterizing the fixed value selection

Define whether the fixed values are selected via fieldbus or using the digital inputs.

ü You are in the Fixed value for acceleration: Selection wizard.

1. D07 Source selection fixed acceleration value:
Define whether the fixed values are selected via fieldbus or using the digital inputs.

1.1. If you are selecting fixed values using a fieldbus, select 1: Parameter D15.

1.2. If you are selecting fixed values using the digital inputs, select 2: Digital inputs.

2. D15 Control byte fixed acceleration value:
If you have selected 1: Parameter D15 for D07, this parameter is written by the controller. The displayed number
corresponds to the respective D14 parameter element configured previously.

3. D06 Source binary selection fixed acceleration value:
If you have selected 2: Digital inputs for D07, configure the signal sources for parameter elements D07[0] – D07[7].

5.7.2.2.4.2 Delay – Parameterize fixed value

If you have stored one or more set or fixed set values for the velocity, you must parameterize a fixed value for the
deceleration.

Deceleration – Storing fixed values

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Fixed values: Deceleration.

2. D16 Fixed deceleration value:
You can store a total of 15 fixed set values in the parameter elements D16[0] – D16[14]. 
Element D16[15] is pre-assigned with I11 Maximal acceleration by the system.

3. To parameterize the selection of fixed values, click on the Selection link.

ð The Fixed value for deceleration: Selection wizard opens.
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Deceleration – Parameterizing the fixed value selection

Define whether the fixed values are selected via fieldbus or using the digital inputs.

ü You are in the Fixed value for deceleration: Selection wizard.

1. D09 Source selection fixed deceleration value:
Define whether the fixed values are selected via fieldbus or using the digital inputs.

1.1. If you are selecting fixed set values using a fieldbus, select 1: Parameter D17.

1.2. If you are selecting fixed set values using the digital inputs, select 2: Digital inputs.

2. D17 Control byte fixed deceleration value:
If you have selected 1: Parameter D17 for D09, this parameter is written by the controller. The displayed number
corresponds to the respective D16 parameter element configured previously.

3. D08 Source binary selection fixed deceleration value:
If you have selected 2: Digital inputs for D09, configure the signal sources for parameter elements D08[0] – D08[7].

5.7.2.2.4.3 Jerk – Parameterize fixed value

If you have stored one or more set or fixed set values for the velocity, you must parameterize a fixed value for the jerk.

Jerk – Storing fixed values

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Fixed values: Jerk.

2. D18 Fixed jerk value:
You can store a total of 15 fixed set values in the parameter elements D18[0] – D18[14]. 
Element D18[15] is pre-assigned with I16 Maximal jerk by the system.

3. To parameterize the selection of fixed values, click on the Selection link.

ð The Fixed value for jerk: Data source wizard opens.

Jerk – Parameterizing the fixed value selection

ü You are in the Fixed value for jerk: Data source wizard.

1. D19 Control byte fixed jerk value:
This parameter is written by the controller. The displayed number corresponds to the respective D18 parameter
element configured previously.

5.7.2.2.5 Limit velocity

If you move the axis with a set velocity and use a fieldbus, you have the option of limiting the velocity in ongoing operation.

1. Select the Drive Based application wizard > Velocity, torque/force operating mode > Limit: Velocity; operating mode:
Velocity, torque/force.

2. D244 Source activation positive v limitation:
If you are transmitting the maximum positive velocity via fieldbus, select 2: Parameter.

3. D242 Activation positive velocity limitation:
Activate the positive velocity limit by setting the parameter to 1: Active.

4. D245 Source activation negativ v limitation:
If you are transmitting the maximum negative velocity via fieldbus, select 2: Parameter.

5. D243 Activation limitation negativ velocity:
Activate the negative velocity limit by setting the parameter to 1: Active.
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5.7.2.3 Parameterizing torque/force operating mode

In the torque/force operating mode, the motion command MC_TorqueControl is available for moving the axis with a set
torque/force. Unlike in velocity operating mode, a distinction is not made between set values and fixed set values. You only
define set values, limiting values and the associated sources.

The motion command MC_TorqueControl is activated with the enable signal of the power unit, thus eliminating the
parameterization of a start signal.

Information

Before you start parameterizing the operating mode-specific motion variables, parameterize the general motion variables
and signal sources. If you obtain set values for velocity, velocity override or torque/force for your drive project from
external sources, proceed as described in the chapter General motion variables and signal sources [} 38].

5.7.2.3.1 Torque/force – Parameterize values

1. Select the Drive Based application wizard > Velocity, torque/force operating mode.

2. D01 Command: 
Select 3: MC_TorqueControl.

3. D232 Maximum positive torque/force: 
If you also want to limit the torque/force using the operating mode, enter the maximum permitted positive value for
torque/force.

4. D233 Maximum negative torque/force: 
If you also want to limit the torque/force using the operating mode, enter the maximum permitted negative value for
torque/force.

Information

The mechanical limit for torque/force is executed by C03 Maximum positive torque/force and C05 Maximum negative
torque/force using the axis model. The additional limit using the operating mode is optional and refers to the values that
you defined in the axis model.

Information

The operating mode configuration is completed.

If you are working with a fieldbus system, next parameterize the settings specific to CANopen, EtherCAT or PROFINET. The
respective procedure can be found in the corresponding fieldbus manual (see Detailed information [} 141]).
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5.7.3 Parameterizing motion block operating mode
The following graphic shows the signal flows of motion block operating mode. The elements shown in a lighter shade are
optional.

Controller
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Fig. 4: Motion block operating mode: Signal flows

In the motion block operating mode, motion profiles are permanently stored on the drive controller in the form of motion
blocks. A motion block includes a PLCopen-compliant motion command which defines the basic motion method of the axis.
The associated motion variables supply specifications on velocity, acceleration, deceleration and jerk, which the motion
core of the drive controller uses to calculate the motion profile.

Motion blocks can be selected individually using motion block numbers and they can be linked with each other, i.e. they are
automatically processed in succession. In motion block linking, a linear, defined sequence as well as branches based on
conditions are both possible for the further motion block action. You can parameterize specifications on velocity override
and brake for each motion block individually.

In motion block operating mode, drive controllers are either activated using a fieldbus or by a mixed operation of a fieldbus
and terminals. The number of axes and motion blocks used determines the memory you need for your project.
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Proceed as follows ...

§ Activate motion block operating mode.

§ Parameterize one or more motion blocks.

§ Test the individual motion blocks using the motion block control panel.

§ If you want to link motion blocks with each other, define subsequent motion blocks and triggers for continuation.

§ Test the motion block links using the motion block control panel.

§ Define how the motion blocks are started.

§ Parameterize the source for the continue, reset and, if necessary, stop signals.

Information

The motion variables available for this operating mode that you configure in the software depend on your application case
as well as on additional project-specific factors such as the use of a controller or the type of data transmission (fieldbus,
terminals).

5.7.3.1 Activating motion block operating mode

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard.

3. Operating modes area:
Activate the Motion block operating mode option.

ð The corresponding wizards are displayed.
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5.7.3.2 Limiting the torque/force using the operating mode

Define whether you also want to limit torque/force using the operating mode. Limiting using the mechanical system takes
place in the project configuration of the axis model. You have the option of specifying an additional limit for all motion
blocks together or for each motion block individually.

1. Select the Drive Based application wizard > Motion block operating mode > Motion block > Torque/force limit: Data
source.

2. J08 Source maximum T/F:

2.1. If you would like to specify the maximum value from the axis model for all motion blocks centrally, select 
3: 100%.

2.2. If you would like to specify the maximum value using the operating mode for all motion blocks centrally, select
1: Parameter J09.

2.3. If you would like to define an individual maximum value for each motion block, select 2: Parameter J25.

3. J09 Maximum torque/force:
If you have selected 1: Parameter J09 for J08, enter the maximum permitted value for torque/force.

4. If you have selected 2: Parameter J25 for J08, enter the maximum permitted value for torque/force during the
parameterization of individual motion blocks in J25 Maximum torque/force.
To do so, proceed as described in the chapter Parameterizing the motion block [} 57].

Information

The mechanical limit for torque/force is executed by C03 Maximum positive torque/force and C05 Maximum negative
torque/force using the axis model. The additional limit using the operating mode is optional and refers to the values that
you defined in the axis model.
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5.7.3.3 Parameterizing motion blocks

Before you start parameterizing the individual motion blocks, determine whether you also want to limit torque/force using
the operating mode. You have already defined the maximum value for torque/force in the axis model, but you have the
option of specifying an additional limit for all motion blocks together or for each motion block individually.

For each motion block, select an appropriate motion command and parameterize the associated motion variables. You can
copy parameterized motion blocks completely to create other motion blocks.

Then, test the parameterization of the individual motion blocks using Motion block control panel.

Information

Before you start parameterizing the operating mode-specific motion variables, parameterize the general motion variables
and signal sources. If you obtain set values for velocity, velocity override or torque/force for your drive project from
external sources, proceed as described in the chapter General motion variables and signal sources [} 38].

5.7.3.3.1 Parameterizing the motion block

To parameterize a motion block, first select the desired motion command, then parameterize the associated motion
variables according to your drive project.

ü You have activated motion block operating mode.

1. Select the Drive Based application wizard > Motion block operating mode.

ð By default, 16 motion blocks are available to you which you can parameterize individually.

2. To parameterize the first motion block, click its motion block number in the Number column.

ð The details view for the first motion block is displayed.

3. J10 Name: 
Define the name of the motion block.

4. J11 Command: 
Select the desired motion command.

ð The associated parameters are displayed.

5. J25 Maximum torque/force:
If you have also limited torque/force using the operating mode and have selected 2: Parameter J25 for J08, enter the
maximum permitted value for torque/force for each motion block.

6. Parameterize the selected motion command based on its associated parameter.

Information

Using J28 Velocity override enable, you activate the scaling of the velocity profile of a motion block. For motion blocks with
final velocity, the velocity override influences J14 Velocity and J18 End velocity equally, i.e. the relationship between J14
and J18 remains the same.

Information

Use J21 Command Mode to define how the motion block, as the subsequent motion block, is executed for motion block
linking. If you select 0: Abort current command, the ongoing motion block is interrupted when the trigger is activated and
the subsequent motion block is executed immediately. If you select 1: Start when current command has finished, the
ongoing motion block is completed first before the subsequent motion block is started.
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Moving the axis with a set velocity

ü You have selected the motion command MC_MoveSpeed or MC_MoveVelocity.

1. J30 Source velocity:
Select the source from which you will obtain the set value for the velocity.

1.1. If you obtain the set value via fieldbus, select 0: Parameter J14.

1.2. If you obtain the set value from an external source, select 1: Parameter G462.

2. J14 Velocity:
If you have selected 0: Parameter J14 for J30, enter the set velocity.

3. J15 Acceleration, J16 Deceleration, J17 Jerk: 
Enter the set values for acceleration, deceleration and jerk.

4. J28 Velocity override enable: 
If you would like to apply a velocity override to the motion block, select 1: Active.

5. J21 Command Mode:
Select the mode in which the selected motion block, as the subsequent motion block, is to be executed.

Moving the axis with a set torque/force

ü You have selected the motion command MC_TorqueControl.

1. J32 Source reference torque/force: 
Select the source from which you will obtain the set value for torque/force.

1.1. If you obtain the set value via fieldbus, select 0: Parameter J26.

1.2. If you obtain the value from external sources, select 1: Parameter G471.

2. J26 Torque/Force reference:
If you have selected 0: Parameter J26 for J32, enter the set torque or set force.

3. J16 Deceleration, J17 Jerk:
Enter the set values for deceleration and jerk.

4. J28 Velocity override enable: 
If you would like to apply a velocity override to the motion block, select 1: Active.

5. J21 Command Mode:
Select the mode for the motion block in which it, as the subsequent motion block, is to be executed.
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Moving the axis to the set position

ü You have selected the motion command MC_MoveAbsolute, MC_MoveAdditive or MC_MoveRelative.

1. J13 Position:
Enter the absolute or relative position to which the axis is to be moved.

2. J14 Velocity:
Enter the set value for the velocity.

3. J15 Acceleration, J16 Deceleration, J17 Jerk: 
Enter the set values for acceleration, deceleration and jerk.

4. J18 End velocity:
Enter the final velocity with which you want to reach the set position J13.

5. J24 Waiting time at the end:
If a subsequent motion block is not to be started immediately, enter the wait time at the end of the motion block.

6. J27 Engage brake at the end:
If you have parameterized a brake and it is to engage at the end of the motion block, select 1: Active.

7. J28 Velocity override enable: 
If you would like to apply a velocity override to the motion block, select 1: Active.

8. J21 Command Mode:
Select the mode for the motion block in which it, as the subsequent motion block, is to be executed.

Information

For motion blocks with a final velocity that is not 0, a change of travel direction by the subsequent motion block is not
permitted.

Referencing the axis

ü You have selected the motion command MC_Home.

1. I30 Referencing type:
Indicates what referencing type you have parameterized for the referencing process.

2. J16 Deceleration, J17 Jerk:
Enter the set values for deceleration and jerk with which the axis is stopped if referencing is interrupted by a control
panel.

3. J24 Waiting time at the end:
If a subsequent motion block is not to be started immediately, enter the wait time at the end of the motion block.

4. J27 Engage brake at the end:
If you have parameterized a brake and it is to engage at the end of the motion block, activate J27.

5. J28 Velocity override enable: 
If you have parameterized a velocity override and would like to apply it to the motion block, select 1: Active.

Information

To parameterize the referencing process, click the Referencing link and proceed as described in the chapter Referencing
absolute position [} 29].
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Stopping the axis

ü You have selected the motion command MC_Halt or MC_Stop.

1. J16 Deceleration, J17 Jerk:
Enter the set values for deceleration and jerk with which the axis is stopped.

2. J24 Waiting time at the end:
If a subsequent motion block is not to be started immediately, enter the wait time at the end of the motion block.

3. J27 Engage brake at the end:
If you have parameterized a brake and it is to engage at the end of the motion block, activate J27.

5.7.3.3.2 Parameterizing the motion block duration

If you are using an endless motion command to move the axis with a set velocity or set torque/force, for example, you can
switch to a subsequent motion block after a defined time using the additional motion block duration function and an
indirect trigger.

ü You are using an endless motion command.

1. Select the Drive Based application wizard > Motion block operating mode > Subsequent motion block > Indirect
trigger: Data source.

2. Activate the Motion block duration option.

ð The additional function is activated and the associated parameter J452 FSM block duration is shown in the Motion
block wizard.

3. Click on the Motion block link.

ð The Motion block wizard opens.

4. Number:
Use the arrow keys to select the number of the motion block for which you would like to define a motion block
duration.

5. J452 FSM block duration:
Enter the duration for which the motion block is to be executed.

Information

As soon as the motion block duration is reached, the information is stored in bit 0 of parameter J453 FSM end of block
duration. To continue on to a subsequent motion block once the motion block duration is reached, parameterize a
subsequent motion block using the interrupt signal with an indirect trigger as described in Parameterizing the subsequent
motion block with a trigger [} 62].

5.7.3.3.3 Copying a motion block

To make parameterization of similar motion blocks easier, you can apply the values from existing motion blocks.

ü You are in the Motion block wizard.

ü You have parameterized at least one motion block.

1. Number:
Select the number of the motion block to which you want to copy the values from an existing motion block.

2. Apply from:
Click on Apply from and select the existing motion block whose values you want to copy.

3. Confirm by clicking on OK.

ð The values of the existing motion block are applied to the current motion block.

4. Adjust the copied values, such as J10 Name, if necessary.
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5.7.3.3.4 Testing the motion block parameterization

Motion block control panel provides all functions you need to test the parameterization of individual motion blocks.

WARNING!

Injury to persons and material damage due to axis movement!

By activating the control panel, you have sole control over the movements of the axis using DriveControlSuite. If you are
using a controller, it no longer monitors the axis movements after the control panel is activated. The controller cannot
intervene to prevent collisions. The controller takes over control again when the control panel is deactivated, which can
cause unexpected axis movements.

▪ Only use the control panel if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

ü The drive controller is switched on.

ü You have established an online connection to the drive controller.

ü You have parameterized at least one motion block.

1. Select the Drive Based application wizard > Motion block operating mode > Motion block control panel.

2. Click Control panel on and then Enable.

ð The drive is controlled using the active control panel.

3. J311 Motion block selection:
Select the motion block whose parameterization you would like to test.

4. Test the positions, velocities, accelerations and brakes and optimize your parameterization based on your test results
if necessary.

5. If you want to link motion blocks with each other as subsequent motion blocks, first test the parameterization for each
motion block individually to be able to rule out errors in motion block linking.

6. In order to deactivate the control panel, click Control panel off.
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5.7.3.4 Parameterizing motion block linking

In order to configure rolling programs automatically, you can connect multiple motion blocks with each other in sequence.
To do so, link the motion blocks in question with each other as subsequent motion blocks and enter the associated signal
sources for continuation. The subsequent motion blocks that are assigned to a motion block are displayed in the motion
block overview.

Then, test the linking of the individual motion blocks using Motion block control panel.

5.7.3.4.1 Parameterizing subsequent motion blocks

You can define one or more possible subsequent motion blocks for each motion block. Continuation to the subsequent
motion block either happens automatically at the end of the motion block or is caused by a trigger. The trigger can either be
a direct trigger signal or a trigger condition that is configurable in the software (indirect trigger). Buffered subsequent
motion blocks are parameterized without triggers and are intended for the case where the axis is moved to a set position in
the previous motion block that is reached with the final velocity.

You can find more information on motion block linking and subsequent motion block under Motion block [} 78].

5.7.3.4.1.1 Parameterizing the subsequent motion block with a trigger

You can define up to five subsequent motion blocks that are each activated by a trigger signal or trigger condition (indirect
trigger) for each motion block in the Subsequent motion block wizard. Depending on the configuration, the subsequent
motion block is only executed at the end of the previous motion block, or the ongoing motion block is interrupted when an
interrupt signal is triggered or an interrupt condition occurs and the subsequent motion block is started.

For each subsequent motion block, define the signal sources for continuation by parameterizing either a direct trigger signal
or an indirect trigger condition. You can configure multiple triggers for each motion block. Each trigger can either activate a
subsequent motion block through interruption or a subsequent motion block at the end of the previous motion block. If
multiple triggers are active simultaneously, the sequence continues with the subsequent motion block with the highest
priority (A – E).

Information

Depending on the application case, you can either parameterize a regular subsequent motion block or a buffered
subsequent motion block at the end of the previous motion block. The use of a regular subsequent motion block at the end
rules out the simultaneous use of a buffered subsequent motion block for the same motion block, and vice versa. You can
combine subsequent motion blocks through interruption with regular subsequent motion blocks at the end and with
buffered subsequent motion blocks.

Information

J450 Source trigger and J439 Source indirect trigger are array parameters. The first element (J450[0], J439[0]) corresponds
to trigger 1, the second element (J450[1], J439[1]) corresponds to trigger 2, etc.
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Parameterizing the subsequent motion block at the end of motion block

Use subsequent motion blocks at the end of the motion block if you want to move the axis with a finite motion command
and automatically switch to the subsequent motion block when the specified set value is reached.

The following section explains the process as an example, based on the parameterization of subsequent motion block A. For
the parameterization of subsequent motion block B – E, proceed in the same manner.

ü You have parameterized at least two motion blocks.

ü You are moving the axis with MC_MoveAbsolute, MC_MoveRelative or MC_MoveAdditive in the motion block to
which you would like to add a subsequent motion block.

1. Select the Drive Based application wizard > Motion block operating mode > Subsequent motion block.

2. Number:
Use the arrow keys to select the number of the motion block to which you would like to add a subsequent motion
block.

3. J281 Next motion block A at end:
If the subsequent motion block is to be executed once the motion block selected in Number has been completed,
select the subsequent motion block here.

4. J251 Source trigger next motion block A: 
Select the trigger that activates continuation to the subsequent motion block.

5. Click on the Trigger: Source link.

ð The Trigger: Data source wizard opens.

6. J450[0] Source trigger:
Select the source of the trigger signal used to start the subsequent motion block.

6.1. If you would like the subsequent motion block to be activated directly at the end of the previous motion block,
select 1: High.

6.2. If a digital input (direct or inverted) acts as the source, select the corresponding input.

6.3. If the subsequent motion block is to be executed when a configurable condition is fulfilled (indirect trigger),
select 2: Parameter and proceed as described in the section Parameterizing the indirect trigger.

Information

For subsequent motion blocks at the end of the motion block, the trigger condition is only evaluated at the end of the
ongoing motion block by using J281 – J285. Since the evaluation only takes place at the motion block end, J21 Command
Mode does not influence when the subsequent motion block is started. The subsequent motion block always starts at the
motion block end if the trigger condition is active.
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Parameterizing the subsequent motion block due to interruption

Use subsequent motion blocks due to interruption if you would like to interrupt the ongoing motion block when the trigger
is activated and continue to the subsequent motion block.

The following section explains the process as an example, based on the parameterization of subsequent motion block A. For
the parameterization of subsequent motion block B – E, proceed in the same manner.

ü You have parameterized at least two motion blocks.

ü You have selected 0: Abort current command for the subsequent motion block in J21 Command Mode.

1. Select the Drive Based application wizard > Motion block operating mode > Subsequent motion block.

2. Number:
Use the arrow keys to select the number of the motion block to which you would like to add a subsequent motion
block.

3. J271 Next motion block A by interrupt:
If the subsequent motion block is to be executed as soon as the motion selected in Number is interrupted by an
interrupt signal, select the subsequent motion block here.

4. J251 Source trigger next motion block A: 
Select the trigger that activates continuation to the subsequent motion block.

5. Click on the Trigger: Source link.

ð The Trigger: Data source wizard opens.

6. J450[0] Source trigger:
Select the source of the trigger signal that activates continuation to the subsequent motion block.

6.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

6.2. If the subsequent motion block is to be executed when a configurable condition is fulfilled (indirect trigger),
select 2: Parameter and proceed as described in Parameterizing the indirect trigger.

Information

For subsequent motion blocks due to interruption, the trigger condition is evaluated while the previous motion is still
running by using J271 – J275. J21 Command Mode controls when the triggered subsequent motion block is started. When
0: Abort current command is selected, the subsequent motion block is executed immediately after the trigger condition is
active. When 1: Start when current command has finished is selected, the subsequent motion block is buffered during
activation of the trigger condition, but not executed until the motion block end.

Information

For motion blocks with a final velocity, you can parameterize a special case: a buffered subsequent motion block with
trigger condition. To do so, use a subsequent motion block due to interruption (J271 – J275) with J21 Command Mode = 
1: Start when current command has finished.

When 1: Start when current command has finished is selected, the subsequent motion block is buffered during activation of
the trigger condition, but not executed until the motion block end. This enables a fluid transition to the subsequent motion
block, depending on a trigger condition.
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Parameterizing the indirect trigger

Parameterize the trigger condition for motion block continuation. If you parameterize a subsequent motion block that is to
be triggered at the end of the previous motion block, the condition for continuation must be fulfilled before the set position
is reached.

ü You have selected 2: Parameter for J450[0] Source trigger.

1. Select the Drive Based application wizard > Motion block operating mode > Subsequent motion block > Indirect
trigger: Data source.

2. J439[0] Source indirect trigger:
Activate the desired indirect trigger and enter the condition for continuation to subsequent motion block A.

2.1. If a simple parameter is used as the condition for continuation, select the BOOL notation: Coordinate.

2.2. If a certain bit of a simple parameter is used as the condition for continuation, select the bit notation:
Coordinate.Bit.

2.3. If an array or record parameter is used as the condition for continuation, select the array notation:
Coordinate[Element].

2.4. If a certain bit of an array or record parameter is used as the condition for continuation, select the following
notation: Coordinate[Element].Bit.

Information

Using J439, you can specify a parameter, a single bit or an element of an array parameter as the source for the indirect
trigger. Possible sources for indirect triggers include individual bits of the status or control word for control via fieldbus or
signals from additional functions such as motion block duration, comparator or cams.

Notation Input format Example

BOOL notation Coordinate J439[0] = I86

The subsequent motion block is only triggered if I86 In
reference is fulfilled, i.e. if the axis is referenced.

Bit notation Coordinate.Bit J439[0] = J453.0

You use J452 FSM block duration and the triggering of the
subsequent motion block is to be time-controlled. The
information "Motion block duration is reached" is stored in
bit 0 of J453 FSM end of block duration.

Array notation Coordinate[Element] J439[0] = I64[0]

The subsequent motion block is to be triggered once the
first cam position is reached. The information for the first
cam is stored in array element 0 of I64 Cam result.

Combined notation Coordinate[Element].Bit –

Tab. 4: Indirect trigger: Notations
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5.7.3.4.1.2 Parameterizing the buffered subsequent motion block

In the Subsequent motion block wizard, you can define a buffered subsequent motion block for each motion block. This
means that the subsequent motion block is already loaded while the previous motion block is still being executed.
Continuation therefore takes place automatically at the end of the previous motion block, without a delay and without a
trigger signal.

Information

Depending on the application case, you can either parameterize a regular subsequent motion block or a buffered
subsequent motion block at the end of the previous motion block. The use of a regular subsequent motion block at the end
rules out the simultaneous use of a buffered subsequent motion block for the same motion block, and vice versa. You can
combine subsequent motion blocks through interruption with regular subsequent motion blocks at the end and with
buffered subsequent motion blocks.

Parameterizing the buffered subsequent motion block

Use a buffered subsequent motion block if you are moving the axis in the previous motion block with a set position
(MC_MoveAbsolute, MC_MoveRelative, MC_MoveAdditive) and would like to transition fluidly into the next motion upon
reaching the set position with the final velocity.

ü You have parameterized at least two motion blocks.

ü You are moving the axis in the previous motion block with MC_MoveAbsolute, MC_MoveRelative or
MC_MoveAdditive.

ü You have selected 1: Start when current command has finished for the motion block intended as the subsequent
motion block in J21 Command Mode.

1. Select the Drive Based application wizard > Motion block operating mode > Subsequent motion block.

2. Number:
Use the arrow keys to select the number of the motion block to which you would like to add a buffered subsequent
motion block.

3. J286 Buffered motion block:
Select the motion block that is to follow the motion block selected in Number without a delay or trigger signal.

Information

If you add a buffered subsequent motion block using J286 Buffered motion block, make sure that J281 Next motion block A
at end up to J285 Next motion block E at end is set to -1: Inactive.

Information

For motion blocks with a final velocity, you can parameterize a special case: a buffered subsequent motion block with
trigger condition. To do so, use a subsequent motion block due to interruption (J271 – J275) with J21 Command Mode = 
1: Start when current command has finished.

When 1: Start when current command has finished is selected, the subsequent motion block is buffered during activation of
the trigger condition, but not executed until the motion block end. This enables a fluid transition to the subsequent motion
block, depending on a trigger condition.
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5.7.3.4.2 Testing the motion block linking

Motion block control panel provides all functions that you need to test the motion block linking.

WARNING!

Injury to persons and material damage due to axis movement!

By activating the control panel, you have sole control over the movements of the axis using DriveControlSuite. If you are
using a controller, it no longer monitors the axis movements after the control panel is activated. The controller cannot
intervene to prevent collisions. The controller takes over control again when the control panel is deactivated, which can
cause unexpected axis movements.

▪ Only use the control panel if you have visual contact with the axis.

▪ Make sure that no people or objects are within the travel range.

ü The drive controller is switched on.

ü You have established an online connection to the drive controller.

ü You have parameterized at least one motion block.

1. Select the Drive Based application wizard > Motion block operating mode > Motion block control panel.

2. Click Control panel on and then Enable.

ð The drive is controlled using the active control panel.

3. J311 Motion block selection:
Select the motion block whose linking with the subsequent motion block you would like to check.

4. Test the positions, velocities, accelerations and brakes and optimize your parameterization based on your test results
if necessary.

5. Repeat the tests for each additional motion block for which you have defined subsequent motion blocks.

6. In order to deactivate the control panel, click Control panel off.
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5.7.3.5 Parameterizing the type of motion block

Define how the motion blocks are to be started. Motion block operating mode offers the option to parameterize the direct
start of up to three motion blocks without a controller. If you would like to use a controller, parameterize the start signal by
defining the source for the execute signal and the source for the selection of the motion block to be started.

5.7.3.5.1 Parameterizing the direct motion block type

Motion block operating mode offers the option to parameterize the direct start of up to three motion blocks of your choice
without a controller.

1. Select the Drive Based application wizard > Motion block operating mode > Motion block > Direct motion block start:
Data source.

2. J80 Activation direct motion block start:
In order to activate the direct motion block start, select 1: Active.

3. J87 Selected direct motion block start 1: 
Enter the number of the motion block that you would like to start directly.

4. J81 Source direct motion block start 1:

4.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

4.2. If you would like to activate the motion block directly, select 2: Parameter J84.

5. J84 Direct motion block start 1:
If you have selected 2: Parameter J84 for J81 and want to start the motion block directly from DriveControlSuite,
select 1: High.

6. Configure the direct start of a second and third motion block in the same way as the first motion block, if necessary.

6.1. If you want to parameterize the direct start for a second motion block, repeat the steps in the same way for
J88, J82 and J85.

6.2. If you want to parameterize the direct start for a third motion block, repeat the steps in the same way for J89,
J83 and J86.

Information

If you have configured the direct start of multiple motion blocks, they are activated with a simultaneous start signal
according to your priority: J83 Source direct motion block start 3 > J82 Source direct motion block start 2 > J81 Source direct
motion block start 1.
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5.7.3.5.2 Parameterizing the execute signal

If you want to use a controller and start the motion block using an execute signal, define the source for the execute signal
and the source for the selection of the motion block that is to be started by the execute signal.

Defining a source for the execute signal

1. Select the Drive Based application wizard > Data sources > Application digital signals: Data source.

2. I100 Source execute:
To start a motion block via a controller, select the source for the execute signal.

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If bit 0 of the control word I210 of the application is the source, select 2: Parameter.

Source for motion block selection

1. Select the Drive Based application wizard > Motion block operating mode > Motion block > Motion block selection:
Data source.

2. J03 Source motion block selection:
To be able to select a motion block via a controller, select the source for the motion block selection signal.

2.1. If the control word J02 of motion block operating mode acts as the data source, select 1: Parameter J02 and
enter the number of the motion block to be started in the event of an execute signal in J02Reference motion
block.

2.2. If digital inputs act as the source, select 2: Digital inputs and enter the digital inputs (direct or inverted) that
activate a controller or binary switch.

5.7.3.6 Parameterizing the motion block end control unit

The motion block end control unit allows you to monitor the status of up to 5 freely selectable motion blocks, making it
easier for you to keep track of the motion block linking.

1. Select the Drive Based application wizard > Motion block operating mode > Motion block end control unit.

2. Activate the desired number of motion blocks to be monitored using the respective option.

ð Parameter J455[0] – [4] can be parameterized according to your selection.

3. J455 Move reference block:
Select the number of the motion block whose status you wish to monitor.

ð The state of the selected reference motion blocks can be observed in J457[0] – [4].

Information

The motion block end control unit indicates that the end of motion block has been reached (J457 = 1: High) as soon as the
motion core has completed the motion command to be executed (I92 = 1: Active) and the actual motion block matches the
reference motion block (J300 = J455).

If J455 is subsequently changed, the motion block chain must first be run through completely before J457 displays the
correct state. If a motion block is executed several times, J457 is reset to 0: Low until the motion command is ended again.
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5.7.3.7 Parameterizing the continue, reset and halt signal

To use the continue function to resume an interrupted motion block, configure the sources of the continue and reset
signals. If you would like to use the motion command MC_Halt to stop a motion block during its run, also add the associated
signal source here.

You can find more information on the continue function, continuable motion commands and reasons for canceling under
Continue function [} 136].

1. Select the Drive Based application wizard > Motion block operating mode > Motion block > Operating mode digital
signals: Data source.

2. J917 Source continue: 
To use the continue function to resume interrupted motion commands, select the source for the continue signal.

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If the control byte J01 of the application acts as the source, select 2: Parameter J01.

ð Bit 2 of the control byte is set as the source.

3. J07 Source reset motion block:
To delete a canceled motion block from the continue memory and enable a different motion block start, enter the
source for the reset signal.

3.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

3.2. If the control word J01 is used as the source for the motion block operating mode, select 2: Parameter J01.

ð Bit 1 of the control word is set as the data source.

4. J06 Source MC_Halt motion block: 
To be able to stop a motion block in general, select the source for the stop signal.

4.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

4.2. If the control word J01 is used as the source for the motion block operating mode, select 2: Parameter J01.

ð Bit 0 of the control word is set as the data source.

Information

The operating mode configuration is completed.

If you are working with a fieldbus system, next parameterize the settings specific to CANopen, EtherCAT or PROFINET. The
respective procedure can be found in the corresponding fieldbus manual (see Detailed information [} 141]).
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5.7.4 Parameterizing command operating mode
The following graphic shows the signal flows of the command operating mode. The elements shown in a lighter shade are
optional.

Controller

Motion
command

Motion
core

Continue
function

DI DI

Controller

AI

Controller

Controller

Start

Motion
variables

Motor

Start signal

Override

Alternative
sources

Fig. 5: Command operating mode: signal flows

In command operating mode, motion profiles are sent from a controller to the drive controller in the form of motion tasks.
A motion task includes a PLCopen-compliant motion command which defines the basic motion method of the axis. The
associated motion variables supply specifications on velocity, acceleration, deceleration and jerk, from which the motion
core of the drive controller calculates the motion profile.

The controller coordinates the time progression and selects the motion tasks for the drive controller that the positioning,
velocity and torque/force commands process and run. In the controller, you define the motion tasks. In the DS6, you
parameterize the signal sources from which the drive controller receives the motion tasks from the controller.

In command operating mode, drive controllers are either activated using a fieldbus or by a mixed operation of a fieldbus
and terminals.

Proceed as follows ...

§ Activate command operating mode.

§ Optional: Limit torque/force using the operating mode.

§ Parameterize the command-specific motion variables.

§ Define the source for the start signal.

§ Optional: Define the source for the continue signal.
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Information

The motion variables available for this operating mode that you configure in the software depend on your application case
as well as on additional project-specific factors such as the use of a controller or the type of data transmission (fieldbus,
terminals).

5.7.4.1 Activating command operating mode

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard.

3. Operating modes area:
Activate the Command operating mode option.

ð The corresponding wizards are displayed.

5.7.4.2 Limiting the torque/force using the operating mode

Define whether you also want to limit torque/force using the operating mode. Limiting using the mechanical system takes
place in the project configuration of the axis model. An additional limit using the operating mode is optional.

1. Select the Drive Based application wizard > Data sources > Torque/force limit: Data source.

2. C132 Source maximum positiv T/F, C133 Source maximum negative T/F:
Select the source for the torque/force limit.

2.1. If an analog input acts as the source, select the corresponding input.

2.2. If the limiting values are transmitted over a fieldbus, select 4: Parameter C232 or 4: Parameter C233.

3. If the limiting values are transmitted over a fieldbus, select Drive Based application > Command operating mode
wizard.

4. J47 Maximum positive torque/force, J48 Maximum negative torque/force: 
Enter the maximum permitted positive and negative values for torque/force.

Information

The mechanical limit for torque/force is executed by C03 Maximum positive torque/force and C05 Maximum negative
torque/force using the axis model. The additional limit using the operating mode is optional and refers to the values that
you defined in the axis model.

Information

If an analog input serves as the source for the application, parameterize, calibrate and scale the respective analog input as
described in Parameterizing analog inputs [} 42].
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5.7.4.3 Parameterizing command-specific motion variables

The parameters for the acceleration, deceleration and jerk motion variables are not included as standard in the process
data mapping. You can either store the values for the motion variables permanently on the drive controller or add the
corresponding parameters to the process data mapping in order to receive the values from the controller.

Information

Before you start parameterizing the operating mode-specific motion variables, parameterize the general motion variables
and signal sources. If you obtain set values for velocity, velocity override or torque/force for your drive project from
external sources, proceed as described in the chapter General motion variables and signal sources [} 38].

5.7.4.3.1 Storing motion variables: Drive controller

If you want to store the specifications for acceleration, deceleration and jerk permanently on the drive controller, check the
default values in the Command operating mode wizard and, if necessary, adjust them to your drive project.

ü You have activated command operating mode.

ü Parameters J44, J45 and J46 are not part of the process data mapping.

1. Select the Drive Based application wizard > Command operating mode.

2. J44 Acceleration, J45 Deceleration, J46 Jerk:
Define the set values for acceleration, deceleration and jerk.

ð The specifications for acceleration, deceleration and jerk are permanently stored on the drive controller.

Information

The parameters in the Command operating mode wizard are written by the controller once there is an online connection
between the drive controller and controller. In this state, you can read off the values in the parameters that the drive
controller receives from the controller. Using parameter J41 Motion-ID, you can identify the ongoing motion task in order
to assign the status bit correctly.

5.7.4.3.2 Storing motion variables: Process data mapping

If you want to specify the settings for acceleration, deceleration and jerk via a controller, add the required parameters to
both the receive process data of the drive controller and the transmit process data of the controller.



5 | Commissioning STOBER

74

04
/2

02
4 

| 
ID

 4
42

70
6.

03

EtherCAT: Supplementing motion variables in PDO mapping

If you want to specify values for motion variables using a controller, supplement the desired parameters in the receive
process data of the drive controller.

ü You have activated command operating mode.

1. Select the EtherCAT wizard > Received process data RxPDO.

2. Coordinate column:
Enter the coordinate of the parameter that you want to apply to the process data mapping in the Coordinate column.

2.1. If you want to obtain the values for acceleration from the controller, enter J44.

2.2. If you want to obtain the values for deceleration from the controller, enter J45.

2.3. If you want to obtain the values for jerk from the controller, enter J46.

ð The parameter is applied to the receive process data of the drive controller.
In the Name, Data type and Length columns, your information about the parameters is displayed.

3. Add your changes to the process data mapping also to the transmit process data of the controller.

PROFINET: Supplementing motion variables in PZD mapping

If you want to specify values for motion variables using a controller, supplement the desired parameters in the receive
process data of the drive controller.

ü You have activated command operating mode.

1. Select the PROFINET wizard > Received process data RxPZD.

2. Coordinate column:
Enter the coordinate of the parameter that you want to apply to the process data mapping in the Coordinate column.

2.1. If you want to obtain the values for acceleration from the controller, enter J44.

2.2. If you want to obtain the values for deceleration from the controller, enter J45.

2.3. If you want to obtain the values for jerk from the controller, enter J46.

ð The parameter is applied to the receive process data of the drive controller.
In the Name, Data type and Length columns, your information about the parameters is displayed.

3. Add your changes to the process data mapping also to the transmit process data of the controller.
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5.7.4.4 Parameterizing the start signal

Define the source for the execute signal in order to start a motion command selected in J40 in command operating mode.

1. Select the Drive Based application > Data sources > Application digital signals: Data source.

2. I100 Source execute:

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If the control word I210 of the application acts as the source, select 2: Parameter.

ð Bit 0 of the control word is set as the data source.

5.7.4.5 Parameterizing the continue signal

To use the continue function to resume an interrupted movement command, configure the source of the continue signal. If
you do not use the continue function, select a new command using J40 and start it using the start signal (execute).

You can find more information on the continue function, continuable motion commands and reasons for canceling under
Continue function [} 136].

1. Select the Drive Based application > Command operating mode > Operating mode digital signals: Data source.

2. J38 Source continue:
To use the continue function to resume interrupted motion commands, select the source for the continue signal.

2.1. If a digital input (direct or inverted) acts as the source, select the corresponding input.

2.2. If the control byte J37 for the command operating mode acts as the source, select 2: Parameter.

ð Bit 0 of the control byte is set as the source.

Information

The operating mode configuration is completed.

If you are working with a fieldbus system, next parameterize the settings specific to CANopen, EtherCAT or PROFINET. The
respective procedure can be found in the corresponding fieldbus manual (see Detailed information [} 141]).
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6 More on Drive Based?
The following chapters summarize the important terms, modules and relationships concerning Drive Based.

6.1 Drive Based – Concept
Applications such as Drive Based, which calculate and adjust the motions in the drive itself, are referred to as drive-based
systems. They are either networked via a fieldbus or obtain signals and set values using analog and digital hardware inputs.

The Drive Based application provides you with a standard set of motion commands based on PLCopen, which is
supplemented by your own motion commands and thus offers flexible drive-based motion control for the position, velocity
and torque/force control types.

The motion commands are combined into corresponding operating modes for different applications. Depending on the
selected operating mode, the motion variables required for parameterizing individual motion profiles, such as set or limit
values, are recorded.

In addition, the Drive Based application provides you with various additional functions for different applications, such as
jerk limitation, motion block linking, cam control unit or PID controller.

Based on all parameterized data, the motion core finally calculates an individual motion profile. Specified set values are
transmitted to the control cascade, which in turn activates the motor.

Additional wizards such as control panels or jog mode help with commissioning and the configuration test or are designed
for emergency operation.

The following graphic shows the components and configuration steps for the Drive Based application. The elements shown
in a lighter shade are optional.



STOBER 6 | More on Drive Based?
04

/2
02

4 
| 

ID
 4

42
70

6.
03

77

Scaling

Auxiliary
functions

Referencing
methods

Data sources

Operating
modes

Jog
mode

Control
panels

Configuring the
motion profile

Motion
core

Control
cascade

Motor

Calculating the
motion profile

Controlling the motor

Carrying out the
motion profile

Fig. 6: Components and configuration steps

6.1.1 Operating modes
The operating modes of the Drive Based application involve command sets bundled by application for configuring individual
motion profiles for production operation.

The drive functions of these operating modes include simple functions, like the position, velocity, and torque/force control
types, as well as technology functions for single-axis applications.

Thanks to flexible, user-defined adjustment options for the operating modes, the Drive Based application offers a compact
– yet extremely variable – scope of functions that is suitable for a wide range of application cases in drive technology. After
selecting the suitable operating mode for the respective application case, Drive Based users concentrate just on
parameterizing the most important sequences for their application.

Note that a drive controller can only process one operating mode per axis.



6 | More on Drive Based? STOBER

78

04
/2

02
4 

| 
ID

 4
42

70
6.

03

6.1.1.1 Velocity, torque/force

The Velocity, torque/force operation mode is suitable for simple movements for which only set values are subject to any
changes.

Typical application cases are pumps, fans, conveyor belts or machines with higher-level position control that output an
analog set value for control and receive a corresponding position value of the axis as a response (CNC) .

6.1.1.2 Motion block

In motion block operating mode, motion properties are predefined in the form of motion blocks. Special linking options can
be used to set up complete motion sequences that allow for quick execution of motion sequences – regardless of whether
an external controller is connected or the motion sequences are executed via binary signals.

Typical application examples are small machine automations or machine modules with predefined motion sequences.

Motion block linking

You can define one or more possible subsequent motion blocks for each motion block. Continuation to the subsequent
motion block either happens automatically at the end of the motion block or is caused by a trigger. The trigger can either be
a direct trigger signal or a trigger condition that is configurable in the software (indirect trigger).

For subsequent motion blocks with triggers, a distinction is made between subsequent motion blocks that are triggered at
the end of the previous motion block and subsequent motion blocks that interrupt the previous motion block when an
interrupt signal is triggered. The continuation can be executed by a direct or indirect trigger in either case.

Subsequent motion blocks at the end of a motion block are triggered as soon as the set value of a finite motion command is
reached and the trigger is active. For subsequent motion blocks due to interruption, a finite or endless motion is
interrupted and continued in the subsequent motion block as soon as the trigger is active. For example, the ongoing motion
can be interrupted when a sensor or light barrier is triggered and the axis stopped.

Buffered subsequent motion blocks are parameterized without triggers and are intended for the case where the axis is
moved to a set position in the previous motion block that is reached with the final velocity. In order to continue the motion
fluidly and start the next motion command without a delay or standstill, the subsequent motion block is loaded in advance
(buffered) while the previous motion block is still being executed. The continuation happens automatically at the end of the
previous motions block.

6.1.1.3 Command

Command operating mode enables a drive controller to run parameterizable motions. In this process, a range of motion
commands are processed that correspond to the behavior of the motion control blocks of the PLCopen standard.

A controller coordinates the time sequences by selecting PLCopen-compliant motion commands, such as
MC_MoveAbsolute (move to absolute set position) or MC_MoveRelative (move relative to actual position).

Parameters such as set position, velocity or torque limit can be defined individually.

Typical application examples are individual axis movements that are communicated by a controller (PLC) to the drive
controller.
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6.1.2 Jog mode
For commissioning, emergency operation and maintenance or repair work, the manufacturer-specific jog mode (manual
movement) is available. Using jog mode, you can move the drive independently of the controller, for example.

You can use jog mode either through the operating unit of the SD6 drive controller, the jog control panel or a controller
that applies the manual movement.

6.1.3 Control panels
The control panels are special wizards in DriveControlSuite, which you can use to take control of the axis. With the help of
the control panels, you can manually release and move an axis even if the drive controller has no operating unit or is
difficult to access.

Using control panels, you can check the connection wiring, the project configuration of your physical axis model or the
parameterization of your application in the respective operating mode before you switch to normal operation.

The following control panels are available:

§ Jog control panel is used to check the projected axis model in jog mode.

§ Control panel motion provides you with a standard set of motion commands based on PLCopen. Via the control panel,
independent of the application and fieldbus interface, you can parameterize a motion profile directly for the motion
core of the axis in order to check the basic functions of the drive controller.

§ Motion block control panel is used to check the parameterized motion block operating mode and provides you with all
the functions you need to test the parameterization of individual motion blocks or motion block linking.

§ Control panel for velocity, torque/force is used to review the parameterized velocity, torque/force operating mode.

Because control panels override normal operation, they can be activated only with a deactivated enable signal and should
be operated by experienced users only.

6.1.4 Motion core
Based on the projected and parameterized data, the motion core calculates a motion profile and associated detail
movements as a basis for the drive controller as well as mandatory set values for the control cascade.
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6.1.5 Data sources
The signals that activate a drive controller can be obtained from different data sources. 
Each of the possible operating modes has a set of set values that is permanently stored in the software. Furthermore,
signals exist for the motion start or motion limits or velocity specifications that generally come from external data sources.

A fieldbus commonly acts as the signal source, though analog or digital hardware inputs or even a mixed operation made up
of the above-listed data sources are also possible.

Values that are obtained from external data sources are usually adapted to the stored reference values automatically, i.e.
calibrated and calculated with scaling.

6.1.5.1 Analog inputs

The analog inputs of the drive controller can serve as sources for set and actual values of the application in your drive
project if, for example, you use sensors to measure motion variables such as velocities or torques/forces.

The available connections vary depending on the series and, if applicable, the terminal module of the drive controller.

For more information on the available connections, refer to the manual of the respective drive controller (see Detailed
information [} 141]).

Information

If an analog input serves as the source for the application, parameterize, calibrate and scale the respective analog input as
described in Parameterizing analog inputs [} 42].
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Analog input AI1

Depending on whether analog input AI1 is used as a voltage source or current source, the following continuous function
charts serve as examples (operating mode: F116).
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Fig. 7: Continuous Function Chart: analog input AI1 (F116 = 0: -10V to 10V)
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Fig. 8: Continuous Function Chart: analog input AI1 (F116 = 1: 0 to 20mA)
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Fig. 9: Continuous Function Chart: analog input AI1 (F116 = 2: 4 to 20mA)
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Analog input AI2

For analog input AI2 as a current source, the following continuous function chart serves as an example.
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Fig. 10: Continuous Function Chart: analog input AI2

Analog input AI3

For analog input AI3 as a current source, the following continuous function chart serves as an example.
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Fig. 11: Continuous Function Chart: analog input AI3
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6.1.6 Additional functions
Each of the available operating modes can be expanded by drive-based additional functions. For example, these offer
convenient monitoring of process variables such as position, velocity or torque/force (cams, comparators) or control of
external process variables (PID controller).

6.1.6.1 Additional counter function

The additional counter function in Drive Based type applications provides you with up to 4 independent counters with
which you can implement smaller automation tasks directly in the drive controller, such as direct or indirect control of the
digital outputs.

Function

For each counter, you define a comparison value, a digital signal for increasing the counter reading and a digital signal for
resetting the counter reading (comparison value: N41; increase source: N43; reset source: N46). With each rising edge of
the counter signal, the counter reading is increased by 1 until the comparison value is reached (counter reading: N44).
When the comparison value is reached, a status signal is issued and further counter signals are ignored until the counter
reading is reset or the comparison value is increased (status: N42).

Signals

Counter reading

3 = Comparison value
2
1
0

Reset

Counting

t

t

t

Fig. 12: Additional counter function: Example

The digital inputs of the drive controller (direct or inverted), parameters with the BOOL data type or individual bits of
parameters with the BYTE, WORD or DWORD data type (example bit addressing: E49.4 for Switch on inhibit reason = STO)
can serve as the source for the signals for increasing and resetting the counter status. The reset signal has priority and is
executed immediately; as long as it is active, the counter reading remains at 0 and rising edges to increase the counter
reading are ignored.
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6.1.6.1.1 Parameterizing counters

To parameterize the additional counter function, proceed as described below.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard > Additional functions.

3. Activate the Counter option.

ð The additional function is activated and the associated wizards and parameters are displayed.

4. Select the Drive Based application wizard > Additional functions > Counters.

5. Number:
Select the desired counter and activate it using the corresponding option.

ð The associated parameters are displayed.

6. N41 Counter comparison value:
Define the comparison value.

7. N43 Source counter:
Select the source for the signal that increases the counter reading by 1 until the comparison value is reached.

7.1. If a parameter is the source, select 2: Parameter.

7.2. If a digital input (direct or inverted) acts as the source, select the corresponding input.

8. N45 Counter indirect reading:
If a parameter is used as the source for increasing the counter, define the desired coordinate, if necessary with bit
addressing.

9. N46 Source reset counter reading:
Select the source for the signal that resets the counter reading to 0.

9.1. If a parameter is the source, select 2: Parameter.

9.2. If a digital input (direct or inverted) acts as the source, select the corresponding input.

10. N47 Reset counter reading via parameter:
If a parameter is used as the source for resetting the counter, define the desired coordinate, if necessary with bit
addressing.
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6.1.6.1.2 Parameterizing counters: Examples

For example, you can use the additional counter function to control the digital outputs directly or indirectly (using the
additional INT32 comparator function) by reaching the comparison value.

In motion block operating mode, the additional counter function offers you options for automating motion block
continuation, e.g. for repeating a motion block as often as required or interrupting a motion block after a certain number of
events.

You can find more information on parameterizing motion blocks, subsequent motion blocks and triggers under
Parameterizing motion block operating mode [} 54].

Controlling a digital output directly

To control a digital output directly via the counter, you can use the status of the counter as a source.

1. Activate the additional counter function.

2. Select the Counters wizard.

3. Parameterize the counter according to your application case.

4. Select the status of the counter as the source for the desired digital output (e.g. DO1: F61 = N42).

ð The digital output is controlled directly via the status of the counter.

Controlling a digital output indirectly (INT32 comparator)

To indirectly control a digital output, you can use the additional counter and INT32 comparator functions in combination
with each other. If you use the INT32 comparator to check whether the current counter reading fulfills a certain condition,
you can control a digital output depending on the result of the comparator.

1. Activate the additional counter and comparator functions.

2. Select the Counters wizard.

3. Parameterize the counter according to your application case.

4. Select the INT32 comparators wizard.

5. Parameterize the INT32 comparator according to your application case.

5.1. C78 Source INT32 comparator:
Select the counter reading N44 as the source for the INT32 comparator.

6. Select the result of the INT32 comparator as the source for the desired digital output (e.g. DO1: F61 = C83).

ð The digital output is controlled indirectly via the counter reading.
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Interrupting a motion block

To interrupt a motion block after a certain number of events, parameterize a motion block with an endless motion
command and a subsequent motion block using interrupt with a motion command to stop an ongoing movement. The
subsequent motion block is triggered by an indirect trigger, using the status of the counter as the source.

1. Activate the additional counter function.

2. Select the Counters wizard.

3. Parameterize the counter according to your application case.

4. Select the Motion block wizard.

5. Parameterize at least motion block 0 and motion block 1 according to your application.

5.1. J11[0] Command:
Select for motion block 0 an endless motion command (e.g.8: MC_MoveSpeed).

5.2. J11[1] Command:
Select a motion command to stop for motion block 1 (e.g. 5: MC_Stop).

6. For motion block 0, parameterize the motion block start (e.g. J80 = 1: Active; J81 = 3: DI1; J87 = 0).

7. Select the Subsequent motion block wizard.

8. J271[0] Next motion block A by interrupt:
Select motion block 1 as the subsequent motion block using interrupt for motion block 0.

9. Select the Trigger: Data source wizard.

10. J450[0] Source trigger:
To parameterize the status of the counter as an indirect trigger for the subsequent motion block, select 2: Parameter.

11. Select the Indirect trigger: Data source wizard.

12. J439[0] Source indirect trigger:
Activate the indirect trigger and define the status of the counter N42 as the source.

ð As soon as the counter has reached the comparison value, motion block 0 (8: MC_MoveSpeed) is interrupted by
motion block 1 (5: MC_Stop) as a subsequent motion block by interrupt.
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Repeating a motion block

To execute a motion block for a certain number of repetitions, parameterize a motion block with a finite motion command
and a subsequent motion block at the end with the 0: MC_DoNothing motion command. The subsequent motion block is
triggered by an indirect trigger using the status of the counter as a source as soon as the desired number of repetitions has
been reached.

1. Activate the additional counter function.

2. Select the Counters wizard.

3. Parameterize the counter according to your application case.

3.1. N41 Counter comparison value:
Define the desired number of motion block repetitions as the comparison value.

3.2. N43 Source counter, N45 Counter indirect reading:
To count the number of times a motion block has been completed using the status byte of motion block
operating mode, select N43 = 2: Parameter and N45 = J302.3.

4. Select the Motion block wizard.

5. Parameterize at least motion block 0 and motion block 1 according to your application.

5.1. J11[0] Command:
Select a finite motion command for motion block 0 (e.g. 2: MC_MoveRelative).

5.2. J11[1] Command:
Select motion command 0: MC_DoNothing for motion block 1.

6. For motion block 0, parameterize the motion block start (e.g. J80 = 1: Active; J81 = 3: DI1; J87 = 0).

7. Select the Subsequent motion block wizard.

8. To be able to both repeat and interrupt motion block 0, parameterize two subsequent motion blocks for motion block
0.

8.1. J281[0] Next motion block A at end:
Select motion block 1 as the subsequent motion block at the end of motion block 0 (0: MC_DoNothing).

8.2. J282[0] Next motion block B at end:
Select motion block 0 as the subsequent motion block at the end of motion block 0 (2: MC_MoveRelative).

ð Subsequent motion block A is executed with higher priority than subsequent motion block B if both subsequent
motion blocks are triggered simultaneously.

9. Select the Trigger: Data source wizard.

10. J450[0] Source trigger:
To parameterize the status of the counter as an indirect trigger for subsequent motion block A, select 2: Parameter.

11. J450[1] Source trigger:
To automatically repeat motion block 0, select 1: High as the trigger for subsequent motion block B.

ð Subsequent motion block B is executed until subsequent motion block A is triggered (priority: J281 > J282).

12. Select the Indirect trigger: Data source wizard.

13. J439[0] Source indirect trigger:
Activate the indirect trigger and parameterize the status of the counter N42 as the source.

ð As soon as the counter has reached the desired number of repetitions, motion block 1 (0: MC_DoNothing) is executed
at the end of motion block 0 (2: MC_MoveRelative) due to its higher priority.
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6.1.6.2 Additional motor potentiometer function

In Drive Based type applications, the additional motor potentiometer (MOP) function provides you with the option of
adjusting an electromechanical potentiometer, for example for set value specification, for direct control of the analog
outputs or for indirect control of the digital outputs.

Function

The motor potentiometer can be adjusted continuously via digital up and down signals, for example for specifying set
values for axis movements via the output value (output value: G373). The output value can be limited by a maximum
positive and a maximum negative value (limit: G362, G363; limit value reached: G374). Either the digital inputs of the drive
controller or the graphical programming can serve as the source for the up and down signals (source: G364, G365). The
initialization signal has priority over the up and down signals and is executed immediately; the initialization value is freely
definable (source: G369; value: G366).

t

t

t

t

Signals

Up

Down

0

MOP MOP

Signals

Init

Up

Down

Init

Init
0
Init
Step 1

Step 3

Step 2

Fig. 13: Motor potentiometer: Linear and stepwise calculation

You can use the operating mode of the motor potentiometer to influence both the calculation of the output value and the
storage behavior (operating mode: G368). The output value is calculated either linearly or in steps and can be saved either
with an active enable signal, prior to the next restart of the drive controller or in non-volatile memory. The parameterized
ramp (ramp: G361) applies to both the linear and stepwise calculations. With a linear calculation, the output value is
changed for the duration of the incoming up or down signal. With a stepwise calculation, the output value is changed by the
parameterized increment at signal input (increment: G367). If another up or down signal is received while the set value has
not yet been reached, it is adjusted by the corresponding increment. If the up and down signals are active at the same time,
the output value remains unchanged in both operating modes.
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6.1.6.2.1 Parameterizing motor potentiometers

To parameterize the additional motor potentiometer function, proceed as described below.

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard > Additional functions.

3. Activate the Motor potentiometer option.

ð The additional function is activated and the associated wizards and parameters are displayed.

4. Select the Drive Based application wizard > Additional functions > Motor potentiometer.

5. G361 Motor potentiometer ramp:
Define the ramp for calculating the output value.

6. G362 Motor potentiometer positive maximum value, G363 Motor potentiometer negative maximum value:
Define the maximum permissible positive and negative output values of the motor potentiometer.

7. G364 Source motor potentiometer up, G365 Source motor potentiometer down:
Select the sources for the up and down signals of the motor potentiometer.

7.1. If the graphical programming is used as the source, select 2: Parameter.

7.2. If a digital input (direct or inverted) acts as the source, select the corresponding input.

8. G368 Motor potentiometer operating mode:
Select the desired operating mode for the motor potentiometer.

8.1. To calculate the output value of the motor potentiometer linearly, select 0: Linear, 2: Linear (remanent) or 
4: Linear (enable-dependent), depending on the desired storage behavior.

8.2. To calculate the output value of the motor potentiometer in steps, select 1: Step-by-step, 3: Step-by-step
(remanent) or 5: Step-by-step (enable-dependent), depending on the desired storage behavior.

9. G367 Motor potentiometer increment:
If you calculate the output value of the motor potentiometer in steps, define the desired increment.

10. G366 Motor potentiometer initialization value:
Optionally define the desired initialization value.

11. G369 Source motor potentiometer initialization:
Select the source for the initialization signal of the motor potentiometer.
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6.1.6.2.2 Parameterizing motor potentiometers: Examples

For example, you can use the additional motor potentiometer function to specify set values for the velocity, velocity
override or torque/force and thus control the axis directly in local operation, e.g. during commissioning, if the controller
fails or if the machine has no controller at all. Using the motor potentiometer, you can also control the analog outputs
directly or the digital outputs indirectly (using the additional REAL32 comparator function).

Controlling an analog output directly

To control an analog output directly, you can use the output value of the motor potentiometer as the source.

1. Activate the additional motor potentiometer function.

2. Select the Motor potentiometer wizard.

3. Parameterize the motor potentiometer according to your application case.

4. Select the Analog output 1 or Analog output 2 wizard.

5. F40 AO1 source, F50 AO2 source:
Select the output value of the motor potentiometer G373 as the source for the desired analog output AO1 or AO2.

6. F41 AO1 reference value source, F51 AO2 reference value source:
If necessary, delete the reference value of the desired analog output.

ð The analog output is controlled directly via the motor potentiometer.

Controlling a digital output indirectly (REAL32 comparator)

To indirectly control a digital output, you can use the additional motor potentiometer and INT32 comparator functions in
combination with each other. If you use the REAL32 comparator to check whether the output value of the motor
potentiometer fulfills a certain condition, you can control a digital output depending on the result of the comparator.

1. Activate the additional motor potentiometer and REAL32 comparator functions.

2. Select the Motor potentiometer wizard.

3. Parameterize the motor potentiometer according to your application case.

4. Select the REAL32 comparators wizard.

5. Parameterize the REAL32 comparator according to your application case.

5.1. C65 Source REAL32 comparator:
Select the output value of the motor potentiometer G373 as the source for the REAL32 comparator.

6. Select the result of the REAL32 comparator as the source for the desired digital output (e.g. DO1: F61 = C75).

ð The digital output is controlled indirectly via the motor potentiometer.
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Specifying a set velocity (external velocity)

To specify a set velocity via the motor potentiometer, select its output value as the source for the external velocity and use
this as the set value source for the motion command.

1. Activate the additional motor potentiometer function.

2. Select the Motor potentiometer wizard.

3. Parameterize the motor potentiometer according to your application case.

4. Select the External velocity: Data source wizard.

5. G461 Source external velocity: 
Select 5: Indirect read parameter G811.

6. G811 Indirect read external velocity:
Select the output value of the motor potentiometer G373 as the source for the external velocity.

ð The output value of the motor potentiometer serves as the source for the external velocity.

ð The external velocity can be provided as a set value specification by accessing parameter G462.

7. For the motion block operating mode, parameterize the motion command and set value source via parameters J11
and J30.

7.1. J11 Command:
Select the motion command 4: MC_MoveVelocity or 8: MC_MoveSpeed.

7.2. J30 Source velocity:
Select 1: Parameter G462 as the source for the external velocity.

8. For the command operating mode, parameterize the motion command and set value source via parameters J40 and
J52.

8.1. J40 Command:
Select the motion command 4: MC_MoveVelocity or 8: MC_MoveSpeed.

8.2. J52 Source velocity 1:
Select 1: Parameter G462 as the source for the external velocity.

9. For the velocity, torque/force operating mode, parameterize the motion command and set value source via
parameters D01 and D30.

9.1. D01 Command:
Select the motion command 1: MC_MoveSpeed or 2: MC_MoveVelocity.

9.2. D30 Source main reference value:
Select 1: Parameter G462 as the source for the external velocity.

ð The output value of the motor potentiometer serves as the set value specification; the conversion to a set velocity is
carried out using maximum permissible speed I10.
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Specifying a set velocity (external additional velocity)

To additionally regulate the set velocity via the motor potentiometer, select its output value as the source for the external
additional velocity and use this as the set value source for the motion command.

ü You are using command operating mode or velocity, torque/force operating mode.

1. Activate the additional motor potentiometer function.

2. Select the Motor potentiometer wizard.

3. Parameterize the motor potentiometer according to your application case.

4. Select the External additional velocity: Data source wizard.

5. G464 Source external additional velocity: 
Select 5: Indirect read parameter G811.

6. G812 Indirect read additional external velocity:
Select the output value of the motor potentiometer G373 as the source for the external additional velocity.

ð The output value of the motor potentiometer serves as the source for the external additional velocity.

ð The external velocity can be provided as a set value specification by accessing parameter G465.

7. For the command operating mode, parameterize the motion command and set value source via parameters J40 and
J54.

7.1. J40 Command:
Select the motion command 4: MC_MoveVelocity or 8: MC_MoveSpeed.

7.2. J54 Source velocity 2:
Select 1: Parameter G465 as the source for the external additional velocity.

8. For the velocity, torque/force operating mode, parameterize the motion command and set value source via
parameters D01 and D31.

8.1. D01 Command:
Select the motion command 1: MC_MoveSpeed or 2: MC_MoveVelocity.

8.2. D31 Source additional reference value:
Select 1: Parameter G465 as the source for the external additional velocity.

ð The output value of the motor potentiometer serves as the set value specification; the conversion to a set velocity is
carried out using maximum permissible speed I10.
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Specifying the velocity override

To specify a velocity override via the motor potentiometer, select its output value as the set value source and apply the
velocity override to the motion command.

1. Activate the additional motor potentiometer function.

2. Select the Motor potentiometer wizard.

3. Parameterize the motor potentiometer according to your application case.

4. Select the Velocity override: Data source wizard.

5. G467 Source velocity override: 
Select 5: Indirect read parameter G813.

6. G813 Indirect read velocity override:
Select the output value of the motor potentiometer G373 as the source for the velocity override.

ð The output value of the motor potentiometer serves as the source for the velocity override.

ð The velocity override can be provided as a set value specification by accessing parameter G468.

7. For the motion block operating mode, parameterize the motion command and set value source via parameters J11
and J28.

7.1. J11 Command:
Select the motion command 4: MC_MoveVelocity or 8: MC_MoveSpeed.

7.2. J28 Velocity override enable:
To apply the velocity override to the desired motion block, select 1: Active.

8. For the command operating mode, parameterize the motion command and set value source via parameters J40 and
J51.

8.1. J40 Command:
Select the motion command 4: MC_MoveVelocity or 8: MC_MoveSpeed.

8.2. J51 Source velocity override:
Select 1: Parameter G468 as the source for the velocity override.

9. For the velocity, torque/force operating mode, parameterize the motion command and set value source via
parameter D01.

9.1. D01 Command:
Select the motion command 1: MC_MoveSpeed or 2: MC_MoveVelocity.

ð The parameterized velocity override is applied automatically; no further settings are necessary.

ð The output value of the motor potentiometer is used as the set value specification for the velocity override.
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Specifying the set torque/set force

To specify a set torque/force via the motor potentiometer, select its output value as the set value source for the motion
command.

1. Activate the additional motor potentiometer function.

2. Select the Motor potentiometer wizard.

3. Parameterize the motor potentiometer according to your application case.

4. Select the Set torque/force, velocity bracketing: Data source wizard.

5. G470 Source torque/force reference: 
Select 5: Indirect read parameter G814.

6. G814 Indirect read torque/force reference:
Select the output value of the motor potentiometer G373 as the source for the set torque/force.

ð The output value of the motor potentiometer serves as the source for the set torque/force.

ð The set torque/force can be provided as a set value specification by accessing parameter G471.

7. For the motion block operating mode, parameterize the motion command and set value source via parameters J11
and J32.

7.1. J11 Command:
Select the 9: MC_TorqueControl motion command.

7.2. J32 Source reference torque/force:
Select 1: Parameter G471 as the source for the set torque/force.

8. For the command operating mode, parameterize the motion command and set value source via parameter J40.

8.1. J40 Command:
Select the 9: MC_TorqueControl motion command.

ð The parameterized set value source is applied automatically; no further settings are necessary.

9. For the velocity, torque/force operating mode, parameterize the motion command and set value source via
parameter D01.

9.1. D01 Command:
Select the 3: MC_TorqueControl motion command.

ð The parameterized set value source is applied automatically; no further settings are necessary.

ð The output value of the motor potentiometer serves as the set value specification for the set torque/force.
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6.1.6.3 Additional fieldbus-controlled analog output function

In Drive Based type applications, the additional fieldbus-controlled analog output function allows you to control the
respective analog output directly via a controller, e.g. for operating simple actuators such as pumps, fans, or valves. The
additional function can be used to specify an individual set value for each analog output (enable: G303; set value: G306,
G309). When fieldbus communication is active, the set value point is written by the controller via the process data mapping
(G304, G307). In addition, a fallback value can be defined which supplies the set value at the respective analog output if
fieldbus communication fails (G305, G308).

6.1.6.3.1 Parameterizing a fieldbus-controlled analogue output

To parameterize the additional function for controlling analog outputs via fieldbus, proceed as described below.

Information

To use the additional function for controlling the analog outputs via fieldbus, expand the process data mapping of the
application, depending on the fieldbus used. Further information on process data mapping can be found in the relevant
fieldbus manual.

Parameterizing fieldbus-controlled analogue output AO1

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard > Additional functions.

3. Activate the Fieldbus-controlled analog output 1 option.

ð The additional function is activated and the associated wizard is displayed.

4. Select the Drive Based application wizard > Additional functions > Fieldbus-controlled analog output 1.

5. G305 Set value AO1 fallback:
Define the fallback value used to control the analog output if fieldbus communication fails.

6. Select the Terminals wizard > Analog output 1.

6.1. F40 AO1 source:
For set value specification via fieldbus, select parameter G306 as the source for analog output AO1.

6.2. F41 AO1 reference value source:
If necessary, delete the reference value of analog output AO1.

7. For fieldbus communication via CANopen, add parameter G304 to the receive process data RxPDO A225 – A228.

8. For fieldbus communication via EtherCAT, add parameter G304 to the receive process data RxPDO A225 – A228 and
create a new ESI file for the controller if necessary.

9. For fieldbus communication via PROFINET, add parameter G304 to the receive process data RxPZD A90 – A91.
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Parameterizing fieldbus-controlled analogue output AO2

1. Select the relevant drive controller in the project tree and click on the desired projected axis in the Project menu >
Wizard area.

2. Select the Drive Based application wizard > Additional functions.

3. Activate the Fieldbus-controlled analog output 2 option.

ð The additional function is activated and the associated wizard is displayed.

4. Select the Drive Based application wizard > Additional functions > Fieldbus-controlled analog output 2.

5. G308 Set value AO2 fallback:
Define the fallback value used to control the analog output if fieldbus communication fails.

6. Select the Terminals wizard > Analog output 2.

6.1. F50 AO2 source:
For set value specification via fieldbus, select parameter G309 as the source for analog output AO2.

6.2. F51 AO2 reference value source:
If necessary, delete the reference value of analog output AO2.

7. For fieldbus communication via CANopen, add parameter G307 to the receive process data RxPDO A225 – A228.

8. For fieldbus communication via EtherCAT, add parameter G307 to the receive process data RxPDO A225 – A228 and
create a new ESI file for the controller if necessary.

9. For fieldbus communication via PROFINET, add parameter G304 to the receive process data RxPZD A90 – A91.
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6.2 Axis model
With the help of the axis model, you map the real mechanical environment of your drive project in DriveControlSuite by
parameterizing the axis type and the arrangement of existing encoders. The parameterization of the axis model is required
for the smooth operation and easy diagnosis of your drive train.

With I05 Type of axis, you select a rotational or a translational axis model and define whether the scaling of the axis is done
using either predefined or individually configured units of measure. With I00 Position range, you parameterize either an
endless or a limited travel range. You parameterize the encoder arrangement by using B26 Motor encoder and I02 Position
encoder.

The 6th generation of STOBER drive controllers are specially developed for communication between the drive controller
and controller on the basis of the actual variables at the output (° or mm of real axis movement). The scaling of the axis
model is calculated by the drive controller's firmware independently of the encoder model, without any rounding errors or
drift.

If your axis model is not followed by any other gear ratios, you can operate the axis with output-side motion variables
where all nominal and actual values correspond to the real axis movement.

Information

The firmware processes values for the motion variables velocity, acceleration and jerk in the data type REAL32 (floating-
point number, 32 bits). Position values are processed in the INT32 data type (integer, 32 bits) to eliminate rounding errors
and enable precise movements.

Abbreviation Meaning

LinM Linear Motor

M Motor

MEnc Motor Encoder

PEnc Position Encoder

Rotational axis models

The following figures each show a rotational axis model consisting of a motor, a gear unit and a rotary table (endless
rotational) or a pointer (limited rotational). Rotational axis models support rotational motor encoders as well as rotational
position encoders.

n
n

1

2

MEnc Gear PEnc

M

Fig. 14: Endless-rotational motion: Rotary table

M

MEnc PEncGear

n
n

1

2

Fig. 15: Limited-rotational motion: Pointer
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Translational axis models

The following figures each show a translational axis model consisting of a motor, gear unit, feed and conveyor belt (endless
translational) or tool slide (limited translational). Translational axis models support rotational motor encoders as well as
rotational or translational position encoders.

MEnc
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Gear PEnc Feed

M

PEnc

n
x

Fig. 16: Endless translational motion: Conveyor belt

M

MEnc Gear

n
n

1

2

PEnc Feed

PEnc

n
x

Fig. 17: Limited translational motion: Tool slide

Translational axis model: Linear motor

The following figure shows a limited translation axis model using the example of a linear motor. Linear motors only support
translational motor encoders and translational position encoders.

MEnc/PEnc

LinM

Fig. 18: Limited translational motion: Linear motor
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Encoder arrangement

You parameterize the encoder arrangement by using B26 Motor encoder and I02 Position encoder. The motor encoder for
velocity control is located on the motor shaft. The position encoder for position control is located on the gear unit output. If
you use only one of the two encoders, it will be used for both velocity and position control.

Encoder Parameterization Encoder arrangement

Motor encoder B26 ≠ 0: Inactive

I02 = 0: Motor encoder
MEnc

n
n

1

2

Gear unit PEnc

M

Position encoder B26 ≠ 0: Inactive

I02 = B26
MEnc

n
n

1

2

Gear unit PEnc

M

Motor encoder & position
encoder

B26 ≠ 0: Inactive

I02 ≠ B26
MEnc

n
n

1

2

Gear unit PEnc

M
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6.3 Limit switches
Limit switches are sensors that detect when a certain position has been reached.

A distinction is made here between hardware limit switches and software limit switches. While a hardware limit switch is a
real switch (hardware), a software limit switch refers to the position limiting or position monitoring implemented in the
software.

There are hardware and software limit switches on real axes, while virtual masters only have software limit switches.

Behavior in jog mode, reaching the +/- 31 bit computing limit and simultaneous triggering of positive and negative limit
switches are special cases.

6.3.1 Real axes
There are hardware and software limit switches on real axes.

6.3.1.1 Faults

If a hardware limit switch is overshot, a fault is triggered immediately.

If a software limit switch is overshot, a fault is triggered if the following applies:

§ For a positive software limit switch: actual position > limit switch position + I22

§ For a negative software limit switch: actual position < limit switch position + I22

Faults

53: Limit switch

Causes

§ 1: Hardware-Limit-Switch positive

§ 2: Hardware-Limit-Switch negative

§ 3: SW-limit switch positive

§ 4: SW-limit switch negative

§ 5: +/- 31 bit computing limit reached

§ 6: Linear motor moving range

§ 7: Both limit switches not connected

The fault can be acknowledged. Note that movement is only possible in the opposite direction of the limit switch, since the
direction of the triggered hardware or software limit switch is locked. A direction lock is displayed in parameter I196.

A fault can be triggered again when the direction lock is no longer active.
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6.3.1.2 Denial

If the axis is at a hardware limit switch (I441 or I442 = High) or if it is beyond of the software limit switch, movement is
denied in the locked direction.

A direction lock is displayed in parameter I196. The direction lock is deactivated if the following applies:

§ For a positive software limit switch: actual position < limit switch position − I22

§ For a negative software limit switch: actual position > limit switch position + I22

When the direction lock is active, parameter I91 Error = 1: Active.

The cause is output in parameter I90.

Possible causes are:

§ 1: Illegal direction

§ 2: SW-limit switch positive

§ 3: SW-limit switch negative

§ 10: Denied because position is not in circular length

§ 11: HW-limit switch positive

§ 12: HW-limit switch negative

Information

There are no software limit switches for an infinite axis, since this would contradict the nature of an infinite axis.

A movement limitation is also displayed in parameter E80:

§ If E80 = 20: Limit switch, check the parameterization and the connection of the limit switches.

§ If E80 = 15: Illegal direction, check the set values and a possible direction lock in parameter I196.

Also check I196 if the permitted direction was limited with I04.

Information

Parameter I04 is only available for infinite axes.
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6.3.1.3 Hardware limit switches

Hardware limit switches apply if your sources are defined in parameters I101 and I102.

Relevant parameters

§ I101 Source positive /limit switch

§ I102 Source negative /limit switch

§ I441 Signal /HW limit switch positive

§ I442 Signal /HW limit switch negative

§ I805 Actual value HW-Limit switch positive

§ I806 Actual value HW-Limit switch negative

§ I52 Delete limit switch memory

§ I196 Direction blocking

If I441 and I442 = 0: Inactive, fault 53 is triggered with cause 7: Both limit switches not connected. Therefore, after
parameterizing I101 and I102, check whether the hardware limit switches are also connected physically.

If I101 and I102 = 2: Parameter, the fault is triggered by the control word of the application (I210). In this case, check the
controller connection.
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Passable hardware limit switches

The hardware limit switches can be passed over. It is therefore possible to use an infinite cam as a hardware limit switch.
The limit switch is detected if the signal goes to 0: Inactive (parameters I441 and I442).

If the hardware limit switch is overshot, the position at which the limit switch was detected is saved. When resetting limit
switches, the axis must have reached or passed back over this saved position before the signal is valid again.

1

4

3

2

Neg. hardware limit switch

Negative Positive
Axis reference system

Neg. hardware limit switch memory

Pos. hardware limit switch

Pos. hardware limit switch memory

I442

I806

I441

I805

Fig. 19: Hardware limit switch memory

1 Setting the memory (negative hardware limit switch) with rising edge

2 Resetting the memory (negative hardware limit switch) with falling edge

3 Setting the memory (positive hardware limit switch) with rising edge

4 Resetting the memory (positive hardware limit switch) with falling edge

Information

The passable hardware limit switch is no longer effective once the position at which the edge of the limit switch was
detected has been passed over again.

Note that the positions are not saved in non-volatile memory. This means that if the axis is beyond a passable limit switch
after activation, it must first be reset to the regular travel range.

The entire system is simpler if you do not use any passable limit switches.

During commissioning or in case of defective hardware limit switch connections, problems can arise with the saved
positions. These can be deleted with parameter I52. However, deletion only takes place if the corresponding limit switch
signal is inactive. Stored positions can also be deleted by referencing, setting a reference can be deleted using I452 or by
restarting the drive controller.

During referencing, the hardware limit switches are not evaluated as limit switches. There are referencing methods in which
the hardware limit switches are used for referencing.

Example

A positive limit switch ranges from position 100 to 120.
When moving in the positive direction, it is detected at 100.
On the return journey, due to tolerances, it can be the case that the limit switch has already been left at 101.
Despite this, position 100 must be undershot in order to leave the effective limit switch.
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6.3.1.4 Hardware limit switches when referencing

Hardware limit switches assume a special position when referencing.

Limit switch as reference switch

The hardware limit switches can be used in place of a reference switch (I30 = 2: Limit switch).

Change of direction

In other referencing types, a hardware limit switch signal leads to a change of direction. However, the signal only causes a
change if it matches the direction of travel.

If the detected hardware limit switch does not match the direction of travel (e.g. negative limit switch with positive
direction of travel), a fault is then triggered.

Example

At the start of referencing, the axis is between the reference switch and positive limit switch. The referencing direction is
positive. The axis moves in the positive direction and first encounters the positive limit switch, not the reference switch.
The axis reverses and searches for the reference switch in the other direction.

6.3.1.5 Software limit switches

Software limit switches only apply if the axis has been referenced.

Only limited axes have software limit switches (I00 = 0: Limited).

Relevant parameters

§ I50 Software stop positive

§ I51 Software stop negative

§ I196 Direction blocking

If the values defined in parameter I50 and parameter I51 are the same, the software limit switches are deactivated.

6.3.1.6 Software limit switches when referencing

Software limit switches are not evaluated when referencing.

6.3.1.7 Shutting down by the limit switch

If a hardware limit switch is approached from the permitted travel range, a fault is immediately triggered after detecting
the limit switch edge.

If a software limit switch is approached from the permissible travel range, a fault is triggered if the following applies:

§ For a positive software limit switch: actual position > limit switch position + I22

§ For a negative software limit switch: actual position < limit switch position + I22

If the current position is on or beyond the limit switch, a fault can be triggered again when the direction lock is no longer
active (I196).
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6.3.2 Special cases
A few special cases are described below.

6.3.2.1 Behavior in jog mode

DANGER!

Risk of fatal injury due to gravity-loaded vertical axis!

If you select 0: Velocity control as the control type for jog mode, a gravity-loaded vertical axis descends as soon as jog mode
is activated via the control panel, the application or the operating unit (SD6) (parameter I26).

▪ Only use the 0: Velocity control control type with axes that do not have a gravity load.

The jog behavior does not depend on the control type selected for jog mode (I26).

As soon as the axis moves to a software limit switch, a quick stop is triggered instead of a fault. As a result, the axis does not
stop precisely on the software limit switch, but shortly thereafter depending on the quick stop ramp. It can immediately be
shut down again by the software limit switch. The "incorrect" direction is locked.

6.3.2.2 Reaching the +/- 31 bit computing limit

Fault: 
53: Limit switch

Cause:
5: +/- 31 bit computing limit reached

The computing limit can be reached if, for example, so many commands follow after each other for the moving axis that the
total distance to be traveled (including decimal places) adds up to over 231.

6.3.2.3 Linear motor travel range

Fault: 
53: Limit switch

Cause:
6: Linear motor moving range

This fault is triggered if the axis is more than 200 m away from the commutation reference point, which means that the
actual position of the motor has left the permissible range (parameter: E09). Check the axis model and correct the
parameterization if necessary.

6.3.2.4 Simultaneous detection of positive and negative hardware limit switches

Fault: 
53: Limit switch

Cause:
7: Both limit switches not connected

This fault is triggered if I441 and I442 are both 0: Inactive. Check whether the hardware limit switches are also connected
physically.

If I101 and I102 = 2: Parameter, the fault is triggered by the control word of the application (I210). In this case, check the
controller connection.

The fault can be acknowledged with I52.



6 | More on Drive Based? STOBER

106

04
/2

02
4 

| 
ID

 4
42

70
6.

03

6.3.2.5 Behavior upon controller start-up

Fault: 
53: Limit switch

Cause:
7: Both limit switches not connected

If a controller is used as the source for the digital signals for evaluating the hardware limit switches and this is still in device
start-up while the drive controller and fieldbus communication are already active, fault 53: Limit switch is triggered and the
limit switch memory is set (I805, I806 = 1: Active).

If the power unit has not yet been enabled since the supply voltage was switched on, the limit switch memory is
automatically reset as soon as the controller correctly transmits the signals for evaluating the hardware limit switches.
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6.4 Referencing
To be able to work with a system with absolute positions, the relation of a measured to an actual axis position must be
determined.

During initial commissioning or after changes to the axis model, the actual position of the axis is unknown. A defined initial
position is necessary.
As a rule, this is either identified through a reference search or referencing setting. The associated process is referred to as
referencing.
Absolute movements can be performed only in a referenced state.

6.4.1 Referencing methods
The following table shows an overview of the possible referencing methods.

Abbreviation Meaning

S Switch

M/F Torque or force

Method Initial
movement

Zero pulse Feature

S  A Negative Yes Negative limit switch

B Negative Yes Negatively positioned reference switch

C Negative – Negative limit switch

D Negative – Negatively positioned reference switch

S E Positive Yes Positive limit switch

F Positive Yes Positively positioned reference switch

G Positive – Positive limit switch

H Positive – Positively positioned reference switch

S I Positive Yes Centrally positioned reference switch

J Positive – Centrally positioned reference switch

S K Negative Yes Centrally positioned reference switch

L Negative – Centrally positioned reference switch

M Negative Yes Zero pulse

N Positive Yes Zero pulse

O – – Setting the reference

M/F P Positive – Torque/force stop

Q Positive Yes Torque/force stop

M/F R Negative – Torque/force stop

S Negative Yes Torque/force stop

Tab. 5: Referencing methods
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6.4.1.1 Referencing methods in detail

The following chapters show the individual referencing methods in detail.

The following abbreviations are used in the graphs on the referencing methods:

Abbreviation Meaning

ALT Alternative

LS Limit Switch

RS Reference Switch

ZP Zero Pulse

Information

For graphically representing axes, the left is the smallest and the right is the largest position value. This means a positive
movement goes to the right and a negative to the left.

The following parameters are used in the descriptions of the referencing methods:

Coordinate Name

I28 Homing torque/force limit

I29 Time homing torque/force limit

I30 Referencing type

I31 Referencing direction

I32 Referencing speed fast

I33 Referencing speed slow

I34 Reference position

I35 Referencing with zero pulse

I39 Referencing acceleration

I43 Move to reference position

I44 Referencing jerk

I53 Index search offset

I101 Source positive /limit switch

I102 Source negative /limit switch

I103 Source reference switch
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6.4.1.1.1 Referencing method A

Referencing method A determines a reference using a run to the negative limit switch and zero pulse.

LS+LS-

LS-

ZP

Preparation

1. Activate referencing method A by setting the following parameters to the specified values:
I30 to 2: Limit switch,
I31 to 1: Negative,
I35 to 1: Active.

2. I102: 
Enter the data source for the negative limit switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

4. I53:
Define the start of the search for the zero pulse search

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the negative limit switch and continues its run with velocity I33 until it reaches
the next zero pulse after leaving the limit switch.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.2 Referencing method B

Referencing method B determines the reference using a run to the negatively positioned reference switch and zero pulse.

RS

ZP

ALT 2

ALT 1

RS

Preparation

1. Activate referencing method B by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 1: Negative,
I35 to 1: Active.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

4. I53:
Define the start of the search for the zero pulse search

Referencing

If the PLCopen command MC_Home is active, a distinction is made between two referencing variants.

ü Alternative 1: Drive is positioned in front of the reference switch

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it reaches the
next zero pulse after leaving the reference switch.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 2: Drive stopped at reference switch

1. The drive starts in the positive direction with acceleration I39 and velocity I33.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction again and continues at velocity I33
until it reaches the zero pulse.

4. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.3 Referencing method C

Referencing method C determines the reference using a run to the negative limit switch.

LS-

LS+LS-

Preparation

1. Activate referencing method C by setting the following parameters to the specified values:
I30 to 2: Limit switch,
I31 to 1: Negative,
I35 to 0: Inactive.

2. I102: 
Enter the data source for the negative limit switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the negative limit switch and continues its run with velocity I33 until it leaves
the limit switch again.

3. The current actual position is set to the value of the reference position I34 upon leaving the limit switch.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.



6 | More on Drive Based? STOBER

112

04
/2

02
4 

| 
ID

 4
42

70
6.

03

6.4.1.1.4 Referencing method D

Referencing method D determines the reference using a run to the negatively positioned reference switch.

RS

ALT 2

ALT 1

RS

Preparation

1. Activate referencing method D by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 1: Negative,
I35 to 0: Inactive.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

Referencing

If the PLCopen command MC_Home is active, a distinction is made between two referencing variants.

ü Alternative 1: Drive is positioned in front of the reference switch

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it leaves the
reference switch again.

3. The current actual position is set to the value of the reference position I34 upon leaving the reference switch.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 2: Drive stopped at reference switch

1. The drive starts with acceleration I39 and velocity I33 in the positive direction until it leaves the reference switch.

2. It changes its direction upon leaving the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction and continues its run at velocity I33
until it reaches the reference switch again.

4. The current actual position is set to the value of the reference position I34 upon reaching the reference switch.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.5 Referencing method E

Referencing method E determines the reference using a run to the positive limit switch and zero pulse.

LS+

ZP

LS+LS-

Preparation

1. Activate referencing method E by setting the following parameters to the specified values:
I30 to 2: Limit switch,
I31 to 0: Positive,
I35 to 1: Active.

2. I101: 
Enter the data source for the positive limit switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

4. I53:
Define the start of the search for the zero pulse search

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the positive limit switch and continues its run with velocity I33 until it reaches
the next zero pulse after leaving the limit switch.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.6 Referencing method F

Referencing method F determines the reference using a run to the positively positioned reference switch and zero pulse.

RS

ZP

ALT 2

ALT 1

RS

Preparation

1. Activate referencing method F by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 0: Positive,
I35 to 1: Active.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

4. I53:
Define the start of the search for the zero pulse search

Referencing

If the PLCopen command MC_Home is active, a distinction is made between two referencing variants.

ü Alternative 1: Drive is positioned in front of the reference switch

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it reaches the
next zero pulse after leaving the reference switch.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 2: Drive stopped at reference switch

1. The drive starts in the negative direction with acceleration I39 and velocity I33.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction again and continues at velocity I33
until it reaches the zero pulse.

4. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.7 Referencing method G

Referencing method G determines the reference using a run to the positive limit switch.

LS+

LS+LS-

Preparation

1. Activate referencing method G by setting the following parameters to the specified values:
I30 to 2: Limit switch,
I31 to 0: Positive,
I35 to 0: Inactive.

2. I101: 
Enter the data source for the positive limit switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the positive limit switch and continues its run with velocity I33 until it leaves the
limit switch again.

3. The current actual position is set to the value of the reference position I34 upon leaving the limit switch.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.8 Referencing method H

Referencing method H determines the reference using a run to the positively positioned reference switch.

RS

RS

ALT 2

ALT 1

Preparation

1. Activate referencing method H by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 0: Positive,
I35 to 0: Inactive.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

Referencing

If the PLCopen command MC_Home is active, a distinction is made between two referencing variants.

ü Alternative 1: Drive is positioned in front of the reference switch

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it leaves the
reference switch again.

3. The current actual position is set to the value of the reference position I34 upon leaving the reference switch.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 2: Drive stopped at reference switch

1. The drive starts with acceleration I39 and velocity I33 in the negative direction until it leaves the reference switch.

2. It changes its direction upon leaving the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction and continues its run at velocity I33
until it reaches the reference switch again.

4. The current actual position is set to the value of the reference position I34 upon reaching the reference switch.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.9 Referencing method I

Referencing method I determines the reference using a run to the centered reference switch and zero pulse.

LS+LS- RS

RS

ZP

ALT 2

ALT 1

ALT 3

LS+

Preparation

1. Activate referencing method I by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 0: Positive,
I35 to 1: Active.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

4. I53:
Define the start of the search for the zero pulse search

Referencing

If the PLCopen command MC_Home is active, a distinction is made between three referencing sequences.

ü Alternative 1: Drive is positioned between the negative limit and reference switches

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it reaches the
next zero pulse after leaving the reference switch.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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ü Alternative 2: Drive stopped at reference switch

1. The drive starts in the negative direction with acceleration I39 and velocity I33.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction again and continues at velocity I33
until it reaches the zero pulse.

4. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 3: Drive is positioned between the reference and positive limit switches

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the positive limit switch until the reference switch is reached.

3. Upon reaching the reference switch, the drive changes its velocity to I33 until it leaves the reference switch again.

4. The current actual position is set to the value of the reference position I34 after leaving the reference switch and upon
reaching the next zero pulse.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.10 Referencing method J

Referencing method J determines the reference using a run to the centered reference switch.

LS+LS- RS

RS

ALT 2

ALT 1

ALT 3

LS+

Preparation

1. Activate referencing method J by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 0: Positive,
I35 to 0: Inactive.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

Referencing

If the PLCopen command MC_Home is active, a distinction is made between three referencing sequences.

ü Alternative 1: Drive is positioned between the negative limit and reference switches

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it leaves the
reference switch again.

3. The current actual position is set to the value of the reference position I34 upon leaving the reference switch.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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ü Alternative 2: Drive stopped at reference switch

1. The drive starts in the negative direction with acceleration I39 and velocity I33.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I32 until it leaves the
reference switch.

3. When the drive comes to a stop after the reference switch, it changes direction and continues its run at velocity I33
until it reaches the reference switch again.

4. The current actual position is set to the value of the reference position I34 upon reaching the reference switch.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 3: Drive is positioned between the reference and positive limit switches

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. Upon reaching the positive limit switch, the drive changes its direction and continues its run until it reaches the
reference switch.

3. Upon reaching the reference switch, the drive changes its velocity to I33 until it leaves the reference switch again.

4. The current actual position is set to the value of the reference position I34 upon leaving the reference switch.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.11 Referencing method K

Referencing method K determines the reference using a run to the centered reference switch and zero pulse.

ALT 2

ALT 1

ALT 3

RS

ZP

ALT 2

ALT 1

ALT 3

LS-

LS+LS- RS

Preparation

1. Activate referencing method K by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 1: Negative,
I35 to 1: Active.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

4. I53:
Define the start of the search for the zero pulse search

Referencing

If the PLCopen command MC_Home is active, a distinction is made between three referencing variants.

ü Alternative 1: Drive is positioned between the reference and positive limit switches

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it reaches the
next zero pulse after leaving the reference switch.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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ü Alternative 2: Drive stopped at reference switch

1. The drive starts in the positive direction with acceleration I39 and velocity I33.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction again and continues at velocity I33
until it reaches the zero pulse.

4. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 3: Drive is positioned between the negative limit and reference switches

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the negative limit switch and continues its run until the reference switch is
reached.

3. Upon reaching the reference switch, the drive changes its velocity to I33 and continues its run until it reaches the next
zero pulse after leaving the reference switch.

4. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.12 Referencing method L

Referencing method L determines the reference using a run to the centered reference switch.

RS

ALT 2

ALT 1

ALT 3

LS-

LS+LS- RS

Preparation

1. Activate referencing method L by setting the following parameters to the specified values:
I30 to 1: Reference input,
I31 to 1: Negative,
I35 to 0: Inactive.

2. I103: 
Enter the data source for the reference switch.

3. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

Referencing

If the PLCopen command MC_Home is active, a distinction is made between three referencing variants.

ü Alternative 1: Drive is positioned between the reference and positive limit switches

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the reference switch and continues its run with velocity I33 until it leaves the
reference switch again.

3. The current actual position is set to the value of the reference position I34 upon leaving the reference switch.

4. The drive comes to a standstill with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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ü Alternative 2: Drive stopped at reference switch

1. The drive starts with acceleration I39 and velocity I33 in the positive direction until it leaves the reference switch.

2. It changes its direction upon leaving the reference switch and continues its run with velocity I32.

3. When the drive comes to a stop after the reference switch, it changes direction and continues its run at velocity I33
until it reaches the reference switch again.

4. The current actual position is set to the value of the reference position I34 upon reaching the reference switch.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.

ü Alternative 3: Drive is positioned between the negative limit and reference switches

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the negative limit switch and continues its run until the reference switch is
reached.

3. When the reference switch is reached, the drive changes its velocity to I33 and continues its run until it leaves the
reference switch again.

4. The current actual position is set to the value of the reference position I34 upon leaving the reference switch.

5. The drive comes to a standstill with deceleration I39.

6. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.13 Referencing method M

This method determines the reference using a run to the zero pulse.

ZP

Preparation

1. Activate referencing method M by setting the following parameters to the specified values:
I30 to 3: Zero pulse,
I31 to 1: Negative,

2. I32, I39, I44, I34:
Define the set values necessary for the referencing.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

3. The drive comes to a standstill with deceleration I39.

4. If I43 is set to 1: Active, the drive is positioned at reference position I34.

6.4.1.1.14 Referencing method N

Referencing method N determines the reference using a run to the zero pulse.

ZP

Preparation

1. Activate referencing method N by setting the following parameters to the specified values:
I30 to 3: Zero pulse,
I31 to 0: Positive,

2. I32, I39, I44, I34: 
Define the set values necessary for the referencing.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

3. The drive comes to a standstill with deceleration I39.

4. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.15 Referencing method O

Referencing method O determines the reference by setting the reference to any position.

Preparation

1. I30: 
Activate referencing method O by setting this parameter to 5: Define home.

2. I34: 
Define the reference position.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

The current actual position is set to the value of the reference position I34.

6.4.1.1.16 Referencing method P

Referencing method P determines the reference using a run with a torque/force stop.

Preparation

1. Activate referencing method P by setting the following parameters to the specified values:
I30 to 4: Torque/force stopper,
I31 to 0: Positive,
I35 to 0: Inactive.

2. I32, I39, I44, I34: 
Define the set values necessary for the referencing.

3. I28, I29: 
Define the torque/force limit. If the actual torque for the time stored in I29 is above the limit defined in I28 for an
ongoing period, the torque/force limit is reached.

Information

In case of a selected value for the torque/force variable that is too big, the machine can be damaged. In case of a selected
value that is too small, an incorrect reference position may be applied.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. The current actual position is set to the value of the reference position I34 when the torque/force limit is reached and
the time stored in I29 has elapsed.

3. The set values are set to the value 0 with deceleration I39.

4. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.17 Referencing method Q

Referencing method Q determines the reference using a run with a torque/force stop and zero pulse.

ZP

Preparation

1. Activate referencing method Q by setting the following parameters to the specified values:
I30 to 4: Torque/force stopper,
I31 to 0: Positive,
I35 to 1: Active.

2. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

3. I28, I29: 
Define the torque/force limit. If the actual torque for the time stored in I29 is above the limit defined in I28 for an
ongoing period, the torque/force limit is reached.

4. I53:
Define the start of the search for the zero pulse search.

Information

In case of a selected value for the torque/force variable that is too big, the machine can be damaged. In case of a selected
value that is too small, an incorrect reference position may be applied.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the positive direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the torque/force stop and when the time stored in I29 has passed, and
continues its run with velocity I33 until it reaches the next zero pulse.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The set values are set to the value 0 with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.18 Referencing method R

Referencing method R determines the reference using a run with a torque/force stop.

Preparation

1. Activate referencing method R by setting the following parameters to the specified values:
I30 to 4: Torque/force stopper,
I31 to 1: Negative,
I35 to 0: Inactive.

2. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

3. I28, I29: 
Define the torque/force limit. If the actual torque for the time stored in I29 is above the limit defined in I28 for an
ongoing period, the torque/force limit is reached.

Information

In case of a selected value for the torque/force variable that is too big, the machine can be damaged. In case of a selected
value that is too small, an incorrect reference position may be applied.

Referencing

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. The current actual position is set to the value of the reference position I34 when the torque/force stop is reached and
the time stored in I29 has elapsed.

3. The set values are set to the value 0 with deceleration I39.

4. If I43 is set to 1: Active, the drive is positioned at reference position I34.
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6.4.1.1.19 Referencing method S

Referencing method S determines the reference using a run with torque/force stop and zero pulse.

ZP

Preparation

1. Activate referencing method S by setting the following parameters to the specified values:
I30 to 4: Torque/force stopper,
I31 to 1: Negative,
I35 to 1: Active.

2. I32, I33, I39, I44, I34: 
Define the set values necessary for referencing.

3. I28, I29: 
Define the torque/force limit. If the actual torque for the time stored in I29 is above the limit defined in I28 for an
ongoing period, the torque/force limit is reached.

4. I53:
Define the start of the search for the zero pulse search

Information

In case of a selected value for the torque/force variable that is too big, the machine can be damaged. In case of a selected
value that is too small, an incorrect reference position may be applied.

Referencing

If the PLCopen command MC_Home is active, referencing takes places as follows:

1. The drive starts in the negative direction with acceleration I39 and velocity I32.

2. It changes its direction upon reaching the torque/force stop and after the time stored in I29 has passed, and continues
its run with velocity I33 until it reaches the next zero pulse.

3. The current actual position is set to the value of reference position I34 upon reaching the zero pulse.

4. The set values are set to the value 0 with deceleration I39.

5. If I43 is set to 1: Active, the drive is positioned at reference position I34.

6.4.2 Reference position
Depending on the referencing type I30, the actual position I80 is replaced by the reference position I34 during the
referencing event.

6.4.3 Reference retaining
STOBER offers a convenient drive-based referencing system. Depending on the encoder model used and the reference
management, different types of reference retaining (I46) are offered.
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6.5 Drive Based device control
Drive Based device control is based on DRIVECOM profile drive technology 21; this profile describes the control sequence of
a drive controller based on a device state machine. Each device state here represents a certain behavior that can be
changed only through defined events. These events are assigned to individual state transitions.

For example, device control regulates the device start-up when turning on the supply voltage, the enable state of the drive
controller, the process of a quick stop, the behavior in case of fault and the restart after a fault.

Some of the conditions and responses coupled with the state transitions can be influenced specific to the user. For
example, it is possible to define the end of a quick stop or enable delays in a way that is tailored to the respective
application case (see wizard Drive Based device control).

The following chapters describe the device states and the possible state transitions associated with them. You will also
learn whether certain actions are necessary on your part to reach the individual device states, what those actions are and
which user-specific factors you can parameterize yourself.

6.5.1 Drive Based device state machine
The device state machine describes the different device states of the drive controller along with the possible state changes.

Not ready to switch on

Switch on disabled

Ready to switch on

Switched on

Operation enabled

Fault reaction active

Faults

Quick stop active

0

16

1

2 6

53

4

10
12
13

11

7

15

14

8

9

Fig. 20: Drive Based device state machine: device states and state changes
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6.5.2 States, transitions and conditions
The states provided by Drive Based device control all have specific features. A state either transitions into another state
automatically or requires certain actions from the user. There are also transition conditions that you can parameterize to be
tailored to your application case using the Drive Based device control wizard.

Parameter E48 shows the current device state of a drive controller.

6.5.2.1 Not ready to switch on

Features

§ The drive is being initialized, tested and associated parameters are being loaded

§ The power unit as well as drive and activation functions are locked

§ Brakes remain engaged

Transition to Switch on disabled (1)

The drive controller switches to Switch on disabled (1) automatically after successfully completing the self-test.

6.5.2.2 Switch on disabled

Features

§ Initialization has been completed

§ Self-test was successfully completed

§ The power unit as well as drive and activation functions are locked

§ Brakes are or remain engaged in the event of an inactive release override

Possible causes of a switch-on lockout include:

1. Insufficient or no supply voltage or deactivated DC link supply

2. Axis switching is active

3. Projected IGB motion bus is not active

4. STO safety function is active

Transition to Ready to switch on (2)

The exact cause of a switch-on lockout can be found in parameters E47 and E49.

The transition to Ready to switch on happens automatically upon remedying the relevant cause of the switch-on lockout.

Application-specific parameterization

A34 Auto start:

If this parameter is activated, the drive controller switches directly to the state Operation enabled if an enable signal is
present.
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WARNING!

Injury to persons and material damage due to unexpected motor startup!

Only activate autostart if the standards and regulations applicable to the system or machine in question permit a direct
switch to the Operation enabled device state.

▪ In accordance with EN 61800-5-1, clearly mark an activated autostart on the system and in the associated system
documentation.

6.5.2.3 Ready to switch on

Features

§ Power unit and drive function are disabled

§ Drive controller is ready to switch on

§ Brakes are or remain engaged in the event of an inactive release override

Transitions to Switched on (3) or Switch on disabled (6)

Activate the enable signal (3) or one of the possible causes of a switch-on lockout is present (6).

Application-specific parameterization

In addition to the enable signal at terminal X1, the Drive Based device state machine also supports the use of an additional
enable signal, for example over a fieldbus or using digital inputs. The enable signal and additional enable signals are coupled
by an AND link. In this case, the drive controller is enabled only if the value of both signals is HIGH.

A60 Source additional enable:

If you are working with an additional enable signal, define the data source of the additional signal in this parameter. In the
case of a fieldbus connection, A180 bit 0 supplies the additional enable signal.

6.5.2.4 Switched on

Features

§ Power unit is ready for operation

§ Drive function is locked; set values are not processed

§ Brakes are or remain engaged in the event of an inactive release override

Transition to Operation enabled (4), Ready to switch on (5) or Switch on disabled (13)

Leave the enable signal active (4) or deactivate it (5). If one of the possible causes of a switch-on lockout is present, the
drive controller automatically switches to Switch on disabled (13).
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6.5.2.5 Operation enabled

Features

§ Power unit is switched on

§ Drive function is enabled, set values are processed

Transitions to Quick stop active (7), Ready to switch on (11) or Switch on disabled (12)

Request a quick stop (7) or deactivate the enable signal (11). If one of the possible causes of switch-on lockout is present,
the drive controller automatically switches to Switch on disabled (12).

Application-specific parameterization

§ A43 Switch-off delay X1 enable:
If the enable signal at terminal X1 of a safety relay is affected by OSSD test pulses, the drive controller cannot
differentiate these signals from a functional enable-off. An incorrect interpretation of the test pulses can be avoided by
defining a delay time in this parameter that is greater than the duration of the test pulses. This then eliminates
unexpected switching of the drive controller to the states Ready to switch on or Quick stop active (see parameter A44).

§ A44 Quick stop at enable off:
This parameter results in a drive being stopped with a quick stop in case of an inactive enable. In this case, the drive
controller switches to the state quick stop active. If parameter A44 is not activated, the drive switches to the Ready to
switch on state in case of Enable-off.

6.5.2.6 Quick stop active

Features

§ Power unit is switched on; drive function is enabled

§ A quick stop is executed

§ Brakes remain released, brake engages at the end of the quick stop or at standstill

§ Brake engaging ends the quick stop

Transition to Operation enabled (8), Ready to switch on (9) or Switch on disabled (10)

Cancel the quick stop request (8). If the quick stop was carried out fully while the enable signal is inactive, the drive
controller automatically switches to Ready to switch on (9); if one of the possible causes of a switch-on lockout is present,
the drive controller automatically switches to Switch on disabled (10).

Application-specific parameterization

§ A39 Maximum quick stop duration for enable off:
If the drive is stopped with a quick stop in the case of an inactive enable signal (see A44), define the maximum time
after which the power unit is switched off in this parameter.

§ A45 Quick stop end:
Define whether a quick stop is ended with a standstill of the drive or by canceling the quick stop request in this
parameter.

§ A62 Source /quick stop:
Define how a requested quick stop is triggered in this parameter.
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6.5.2.7 Fault reaction active

Features

§ A drive error has occurred

§ Fault response is executed depending on the respective fault event

§ Brakes are activated depending on the respective fault response

Transition to fault (15)

After completed fault response, the drive controller switches to Fault (15) automatically.

Application-specific parameterization

A29 Quick stop in case of fault:

If this parameter is activated, the drive is stopped with a quick stop, if possible, in case of fault; if the parameter is inactive,
the movement of the axis is no longer controlled by the drive controller.

6.5.2.8 Fault

Features

§ A drive error has occurred

§ The fault response is finished

§ The power unit as well as drive and activation functions are locked

§ Brakes are engaged in the event of an inactive release override

Transition to Switch on disabled (16)

After remedying the fault cause and then acknowledging the fault message, the drive controller automatically switches to
Switch on disabled (16).
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6.6 Motion commands
The individual operating modes feature special operating modes that are based on the PLCopen standard and are
supplemented by 2 manufacturer-specific motion commands (MC_DoNothing and MC_MoveSpeed). Any motion
command – except MC_Stop – can be interrupted during execution. To be able to execute a motion command, the
following requirements must be met:

§ Local and jog mode must not be activated.

§ A drive controller must not be in the Switch on disabled or Fault device state.

Command Description Control type Necessary motion variables

0: MC_DoNothing — — —

8: MC_MoveSpeed Axis moves without end with
set velocity
(without position control)

Velocity § Velocity, override

§ Acceleration

§ Deceleration

§ Jerk

4: MC_MoveVelocity Axis moves without end with
set velocity
(with position control)

Position § Velocity, override

§ Acceleration

§ Deceleration

§ Jerk

9: MC_TorqueControl Axis moves without end with
set torque/force

Torque/force § Torque/force

2: MC_MoveRelative Axis moves a relative
distance;
set position is relative to the
actual position at the start of
the command

Position § Position

§ Velocity, override

§ Acceleration

§ Deceleration

§ Jerk

3: MC_MoveAdditive Axis moves a relative
distance;
set position is relative to the
set position of the previous
motion command

Position § Position

§ Velocity, override

§ Acceleration

§ Deceleration

§ Jerk

1: MC_MoveAbsolute Axis moves to an absolute
set position
(referencing necessary)

Position § Position

§ Velocity, override

§ Acceleration

§ Deceleration

§ Jerk

6: MC_Home Axis is referenced Depending on the selected
referencing type

§ Velocity, override

§ Acceleration

§ Deceleration

§ Jerk

§ Torque/force
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Command Description Control type Necessary motion variables

11: MC_Halt Axis is stopped;
next command can be run
before standstill

Velocity § Deceleration

§ Jerk

5: MC_Stop Axis is brought to a
standstill;
next command can be
executed after standstill

Velocity § Deceleration

§ Jerk

Tab. 6: Drive Based: Available motion commands

For detailed information on the motion commands, refer to the associated manual (see Detailed information [} 141]).

6.7 Continue function
In Drive Based type applications, the continue function allows you to resume interrupted motion commands, for example
after a quick stop, the triggering of safety technology or after an event with a fault reaction. Using the continue function,
you can also continue motion commands 2: MC_MoveRelative and 3: MC_MoveAdditive and end with the desired set
position, which would not be possible when restarting using the execute signal.

Cancellation causes that can be continued

§ Event with fault response

§ Enable-off

§ Motion command 5: MC_Stop, 11: MC_Halt

§ Stop signal

§ Quick stop signal

§ SS1, SS2

§ Jog
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Motion commands

Motion command (I401) Continue Note

0: MC_DoNothing – –

1: MC_MoveAbsolute ✓ Motion continues until the set position is reached; set position is
absolute

2: MC_MoveRelative ✓ Motion continues until the set position is reached; set position is relative
to actual position at the start of the command

3: MC_MoveAdditive ✓ Motion continues until the set position is reached; set position is
relative to the set position of the previous motion command

4: MC_MoveVelocity ✓ Motion continues without end at set velocity

5: MC_Stop – –

6: MC_Home – –

8: MC_MoveSpeed ✓ Motion continues without end at set velocity

9: MC_TorqueControl ✓ Motion continues without end with set torque/force

11: MC_Halt – –

Motion block operating mode

In motion block operating mode, the digital inputs, control byte of motion block operating mode or Motion block control
panel can serve as the source for the continue signal (control byte: J01; continue source: J917). The continue signal not only
continues the interrupted motion command, but also the entire motion block chain.

Cause of cancellation Continue Note

Event with fault response ✓ –

Enable-off ✓ –

Motion command 5: MC_Stop – Motion command 5: MC_Stop can be part of a motion block chain

Motion command 11: MC_Halt ✓ Motion command 11: MC_Halt can be part of a motion block chain;
continue is only possible with stop signal via control byte (prerequisite:
J06 = 2: Parameter J01)

Stop signal (I440 = 0: Inactive) – Stop signal is operated from the control panel in motion block operating
mode and is used to stop and end the motion block chain

Quick stop signal 
(A302 = 0: Inactive)

✓ –

SS1 ✓ –

SS2 ✓ –

Jog (I443 = 1: Active) – –

Motion block reset

You can use the continue function to continue an interrupted motion block if both the motion command and the cause of
cancellation can be continued. If it is not possible to resume the motion block or you do not want to continue the
interrupted motion block, it always has to be deleted from the continue memory by means of a reset before a new motion
block can be started using the execute signal.
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6.8 Electronic nameplate
STOBER synchronous servo motors are generally equipped with EnDat encoders that provide a special memory. This
memory includes the electronic nameplate, i.e. all type-relevant master data as well as special mechanical and electronic
values of a motor.

When you operate a drive controller with a STOBER synchronous servo motor and an EnDat encoder, the electronic
nameplate is read and all data transferred if the drive controller is connected online. This specifically includes job data,
current controller values, motor parameters, data on motor temperature sensors, brakes, the commutation offset and the
measured electromotive force. These can be manually optimized later and resaved in the drive controller.

Every time a drive controller is restarted, it checks whether the projected motor, the brake (if applicable), the motor
temperature sensor or commutation have been changed. If so, the changed data is read out. The optimizations saved in the
drive controller are maintained whenever possible.

The automatic read-out of the electronic nameplate is activated at the factory (B04 Electronic nameplate = 64: Active).

6.9 Lag monitoring
In Drive Based type applications, you can monitor the lag of the axis with active position control in order to detect
increasing position deviations at an early stage. Monitoring the lag allows you to react quickly before material damage can
occur, e.g. in the event of stiffness or a mechanical blockage of the output.

To monitor the lag, the difference between the actual position of the axis and the set position x2set of the control is
determined and compared with the maximum permissible lag (actual position: I80; set position: I96; permissible lag: I21;
result: I187). If the permitted lag is exceeded, event 54: Following error is triggered with the corresponding protection level
(protection level: U22).
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7 Appendix

7.1 Standard mapping of Drive Based

Information

For fieldbus communication via PROFINET, the processing of process data in some controllers is WORD-oriented (16 bits). In
Drive Based applications, the standard mapping is pre-assigned appropriately. If changes are made to the standard
mapping, take the parameter data type that you are adding to or removing from the mapping into account.

If you add or remove parameters of the BYTE or INT8 data type (8 bit), this can cause problems in the data structures of the
controller. If necessary, use parameter A101 Dummy byte to fill the 8-bit gaps that result in the process data and implement
the necessary data structure for the controller.
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7.1.1 SD6: Drive Based receive process data
The following table shows the standard mapping for the receive process data in the Drive Based and Drive Based
Synchronous applications. For fieldbus communication via PROFINET, the process data mapping is done via parameter A90
– A92. For fieldbus communication via EtherCAT, the process data mapping is done via parameter A225 – A228. If
necessary, the standard mapping can be customized.

Byte Data type Name Parameters

0 BYTE Device control byte A180

1 BYTE Control byte command 1.J37

2 – 3 WORD Control word application I210

4 INT8 Command 1.J40

5 INT8 Motion-ID 1.J41

6 – 9 INT32 Position 1.J42

10 – 13 REAL32 Velocity 1 1.J43

14 – 17 REAL32 Velocity Override 1.J56

18 – 21 REAL32 Torque/Force reference 1.G469

22 BYTE Control byte motion block J01

23 – 24 INT16 Reference motion block J02

Tab. 7: SD6: receive process data (standard mapping)

7.1.2 SD6: Drive Based transmit process data
The following table shows the standard mapping for the transmit process data in the Drive Based and Drive Based
Synchronous applications. For fieldbus communication via PROFINET, the process data mapping is done via parameter A94
– A96. For fieldbus communication via EtherCAT, the process data mapping is done via parameter A233 – A236. If
necessary, the standard mapping can be customized.

Byte Data type Name Parameters

0 BYTE Status byte device E200[0]

1 BYTE Status byte device E200[1]

2 – 3 WORD Status word 2 E201

4 BYTE Status byte application 1.I212

5 BYTE Status byte command 1.J39

6 – 7 WORD Status word application I200

8 – 11 INT32 Current position 1.I80

12 – 15 REAL32 Actual speed 1.I88

16 – 19 REAL32 Actual torque/force E90

20 – 21 WORD Status word user-defined A67

22 INT8 Operating condition E80

23 BYTE Status byte motion block J302

24 – 25 INT16 Actual motion block J300

26 INT8 Device control state E48

Tab. 8: SD6: transmit process data (standard mapping)
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7.2 Detailed information
The documentation listed below provides you with further relevant information on the 6th STOBER drive controller
generation. The current status of the documentation can be found in our download center at:
http://www.stoeber.de/en/downloads/.
Enter the ID of the documentation in the search field.

Title Documentation Contents ID

SD6 drive controller Manual System design, technical data, project
configuration, storage, installation, connection,
commissioning, operation, service, diagnostics

442426

PROFINET communication – SD6 Manual Installation, electrical installation, data
transfer, commissioning, diagnostics, detailed
information

442710

EtherCAT communication – SD6 Manual Installation, electrical installation, data transfer,
commissioning, diagnostics, detailed
information

442516

SE6 safety technology – Safe drive
monitoring via terminals

Manual Technical data, installation, commissioning,
diagnostics

442796

ST6 safety technology – STO via
terminals

Manual Technical data, installation, commissioning,
diagnostics, detailed information

442478

Motion commands Manual Control and status information, denials and
limitations, motion

443349

http://www.stoeber.de/en/downloads/


7 | Appendix STOBER

142

04
/2

02
4 

| 
ID

 4
42

70
6.

03

7.3 Abbreviations

Abbreviation Meaning

AI Analog Input

ALT Alternative

CAN Controller Area Network

CB Controller Based

CiA CAN in Automation

CNC Computerized Numerical Control

DI Digital Input

EtherCAT Ethernet for Control Automation Technology

IGB Integrated Bus

LinM Linear Motor

LS Limit Switch

LSB Least Significant Bit

M Motor

M/F Torque or force

MEnc Motor Encoder

PEnc Position Encoder

PROFINET Process Field Network

RS Reference Switch

S Switch

PLC Programmable Logic Controller

ZP Zero Pulse
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8 Contact

8.1 Consultation, service and address
We would be happy to help you!

We offer a wealth of information and services to go with our products on our website:
http://www.stoeber.de/en/service

For additional or personalized information, contact our consultation and support service:
http://www.stoeber.de/en/support

If you need our system support:
Phone +49 7231 582-3060
systemsupport@stoeber.de

If you need a replacement device:
Phone +49 7231 582-1128
replace@stoeber.de

Call our 24-hour service hotline:
Phone +49 7231 582-3000

Our address:
STÖBER Antriebstechnik GmbH + Co. KG
Kieselbronner Strasse 12
75177 Pforzheim, Germany

8.2 Your opinion is important to us
We created this documentation to the best of our knowledge with the goal of helping you build and expand your expertise
productively and efficiently with our products.

Your suggestions, opinions, wishes and constructive criticism help us to ensure and further develop the quality of our
documentation.
If you want to contact us for a specific reason, we would be happy to receive an e-mail from you at:
documentation@stoeber.de

Thank you for your interest.
Your STOBER editorial team

http://www.stoeber.de/en/service
http://www.stoeber.de/en/support
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8.3 Close to customers around the world
We offer you committed, expert advise and support in over 40 countries worldwide:

STOBER AUSTRIA
www.stoeber.at
+43 7613 7600-0
sales@stoeber.at

STOBER CHINA 
www.stoeber.cn 
+86 512 5320 8850
sales@stoeber.cn

STOBER FRANCE 
www.stober.fr 
+33 478 98 91 80 
sales@stober.fr

STOBER Germany 
www.stoeber.de 
+49 4 7231 582-0
sales@stoeber.de

STOBER HUNGARY 
www.stoeber.de 
+36 53 5011140
info@emtc.hu

STOBER ITALY 
www.stober.it 
+39 02 93909570 
sales@stober.it

STOBER JAPAN 
www.stober.co.jp 
+81-3-5875-7583
sales@stober.co.jp

STOBER SWITZERLAND 
www.stoeber.ch 
+41 56 496 96 50 
sales@stoeber.ch

STOBER TAIWAN 
www.stober.tw 
+886 4 2358 6089 
sales@stober.tw

STOBER TURKEY 
www.stober.com 
+90 216 510 2290 
sales-turkey@stober.com

STOBER UK 
www.stober.co.uk 
+44 1543 458 858 
sales@stober.co.uk

STOBER USA 
www.stober.com 
+1 606 759 5090 
sales@stober.com
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Glossary

Broadcast domain

Logical grouping of network devices within a local network that reaches all nodes via broadcast.

Control cascade

Complete model of the control structure with the position controller, velocity controller and current controller
components.

Electronic nameplate

The synchronous servo motors are generally equipped with absolute encoders that provide special memory. This
memory includes the electronic nameplate, i.e. all type-relevant master data as well as special mechanical and
electronic values of a motor. When you operate a drive controller with a synchronous servo motor and an absolute
encoder, the electronic nameplate is read and all motor data transferred if the drive controller is connected online. The
drive controller automatically determines the associated limit values and control parameters from this data.

IPv4 limited broadcast

Type of broadcast in a network with IPv4 (Internet Protocol version 4). The IP address 255.255.255.255 is entered as
the destination. The content of the broadcast is not forwarded by a router, which limits it to the local network.

PID controller

Universal controller type with a P-, I- and D-share. These three adjustment parameters make the controller flexible and
ensure exact and highly dynamic control. However, by implication, it also necessitates a wide variety of variants. It is
that much more important to ensure careful construction that is well-coordinated to the system. The application areas
for this controller type are control circuits with systems of the second order and higher, which must be stabilized
quickly and do not allow for any permanent control deviation.

PROFINET

Open Ethernet standard of PROFIBUS Nutzerorganisation e. V. (PNO) for automation.
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